2013年12月18日

donews 不稳定 经常访问不了 用了 8年了 准备切换到51cto

2013年09月27日

asterisk很强大很好使,亲测可用,首先执行下面的操作:

For this install I am using Asterisk 11.0.1 and will be compiling from source on Ubuntu 12.04.1.

注意,这里的含有&&都可以分步做,更好哦。

Before you begin the install process you will want to be sure that your server OS is up to date. When the update completes the server will reboot.

 apt-get update && apt-get upgrade -y && reboot

Next you will want to resolve basic dependencies

apt-get install build-essential wget libssl-dev libncurses5-dev libnewt-dev  libxml2-dev linux-headers-$(uname -r) libsqlite3-dev

Download the source tarballs. These commands will get the current version of DAHDI, libpri and Asterisk.

cd /usr/src/
wget http://downloads.asterisk.org/pub/telephony/dahdi-linux-complete/dahdi-linux-complete-current.tar.gz
wget http://downloads.asterisk.org/pub/telephony/libpri/libpri-1.4-current.tar.gz
wget http://downloads.asterisk.org/pub/telephony/asterisk/asterisk-11-current.tar.gz

Extract the files from the tarballs

tar zxvf dahdi-linux-complete*
tar zxvf libpri*
tar zxvf asterisk*

Install DAHDI

cd /usr/src/dahdi-linux-complete*
make && make install && make config

Install libpri

NOTE: libpri 1.4.13 won’t compile on Ubuntu 12.04 due to a bug (https://issues.asterisk.org/jira/browse/PRI-145). See the video for how to apply a patch to fix the bug. (Edit: libpri 1.4.14 has been released with this bug fix included. If you are a using 1.4.14 or later you should not encounter this bug.)

cd /usr/src/libpri*
make && make install

Install Asterisk. Select your options when the menuselect command runs. Then select “Save & Exit” and the install will continue.

接下来这步会弹出菜单,上下左右键盘操作,回车选择或取消,
建议选上所有Application的组件和尽可能多的CORE支持,但注意单选和不要选择测试模式文件。

cd /usr/src/asterisk*
./configure && make menuselect && make && make install && make config && make samples

Start DAHDI

/etc/init.d/dahdi start

Start Asterisk and connect to the CLI

/etc/init.d/asterisk start
asterisk -rvvv

Verify your installation by checking for the DAHDI and libpri versions on the Asterisk CLI

*CLI> dahdi show version
DAHDI Version: 2.6.1 Echo Canceller: HWEC
*CLI> pri show version
libpri version: 1.4.13

Congratulations! You now have Asterisk 11 running on Ubuntu 12.04. To continue configuring Asterisk check out the quick start guide or take a look at the official Digium online training.

上面做完了,Asterisk就完事了,下面安装Asterisk-Gui。

2. 去http://downloads.asterisk.org/pub/telephony/asterisk-gui/releases/下载最新的Asterisk GUI

本人使用的是:http://downloads.asterisk.org/pub/telephony/asterisk-gui/releases/asterisk-gui-2.1.0-rc1.tar.gz而且没有出现后面说到的警告循环问题,警告一次后即完成文件生成。

3. 下载并解压缩

wget http://downloads.asterisk.org/pub/telephony/asterisk-gui/releases/asterisk-gui-2.1.0-rc1.tar.gz
tar zxvf asterisk-gui-2.1.0-rc1.tar.gz
4. 安装Asterisk GUI

$ ./configure
$ make
$ sudo make install

完成之后,可每执行一次下面的步骤,便运行make checkconfig进行配置完成检查,注意保持路径,也可以不执行下面的第5步,而直接执行配置检查,根据报错逐个修改,最后根据提示修改文件,创建用户名密码。

5. 修改/etc/asterisk/http.conf

enabled=yes

bindaddr=0.0.0.0      #0.0.0.0表示本机的所有IP都可以访问

bindport=8088

enablestatic=yes

修改/etc/asterisk/manager.conf

[general]

enabled = yes

webenabled = yes

port = 5038

bindaddr = 0.0.0.0

[admin]              #登录时的账户名称

secret=admin         #登录时的账户密码

read = system,call,log,verbose,command,agent,config,read,write,originate

write = system,call,log,verbose,command,agent,config,read,write,originate

6. 复制文件及创建连接 (这一步很重要,网上的很多教程都没有这一步,可能会导致”404 not found”, 权限不够等问题)

$ sudo cp -Rfv /var/lib/asterisk/* /usr/share/asterisk/
$ sudo mv /var/lib/asterisk /var/lib/asterisk_original
$ sudo ln -s /usr/share/asterisk  /var/lib/asterisk
$ sudo chmod 777 /usr/share/asterisk/* -R

7. 重启asterisk服务

此处务必要使用root, 否则虽然能启动asterisk,但是http server会总是disabled的状态。

同时asterisk -r是也需要root,否则会出现错误:Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

$ sudo /etc/init.d/asterisk restart
$ sudo asterisk -r

进入asterisk操作界面后运行运行”http show status “可以查看Http服务状态

看到如下状态则成功了。

royn-VGN-Z690J*CLI> http show status
HTTP Server Status:
Prefix:
Server Enabled and Bound to 0.0.0.0:8088
Enabled URI’s:
/httpstatus => Asterisk HTTP General Status
/phoneprov/… => Asterisk HTTP Phone Provisioning Tool
/amanager => HTML Manager Event Interface w/Digest authentication
/arawman => Raw HTTP Manager Event Interface w/Digest authentication
/manager => HTML Manager Event Interface
/rawman => Raw HTTP Manager Event Interface
/static/… => Asterisk HTTP Static Delivery
/amxml => XML Manager Event Interface w/Digest authentication
/mxml => XML Manager Event Interface
Enabled Redirects:
None.

8. 登陆页面

http://localhost:8088/static/config/index.html

注意,修改完成配置文件manager.conf后,直接登录GUI将显示用户名或密码不正确,此时应该重新启动系统,然后登录,接着会看到一个配置更新的警告界面,之后再次登录,即可使用。

ID:admin Password: admin

这里还有要注意的,GUI的设置并不会立即生效,需要重新启动ASTERISK服务才能生效!

——–相关解决说明:

此时页面会陷入死循环,不断刷新,显示:

Your configuration will now be upgraded to work with the latest version of GUI.
这是asterisk-gui和asterisk 1.8不兼容导致的。

修改 /var/lib/asterisk/static-http/config/js/index.js重新登陆即可。

if ( resp_lower.contains(“branches/1.6″) || resp_lower.contains(“asterisk/1.6″) || resp_lower.contains(“svn-branch-1.6″) || resp_lower.contains(“svn-trunk-”) )
..

改为

replace:
if ( resp_lower.contains(“branches/1.6″) || resp_lower.contains(“asterisk/1.6″) || resp_lower.contains(“svn-branch-1.6″) || resp_lower.contains(“svn-trunk-”) || resp_lower.contains(“asterisk/1.8″) )

2013年09月22日

故事一:

两个人其实已经分手很久了,但因为是学生时代的爱情,所以就算分开也舍不得做仇人。加上共同的朋友太多,断断续续的还有联系。男孩已经结婚,女孩也有了稳定的恋情。有天在网上碰到,男孩正在国外玩儿,和女孩聊了两句,问“你有没有什么需要我带的。”女孩开始说不用,后来想了想,随口说“上大学的时候你有一次和家里人出去玩,回来给我带了一条项链,还记得吗?银的链子,带一个蓝色的小坠子,很简单。我特别喜欢,戴了好久。”男孩说:“嗯,我记得。”女孩接着说:“前几年链子断了,坠子就找不到了,你要看到差不多的,给我带一个,没有就算了。”男孩在那头开玩笑说:“你看你,送你的东西都不注意,太没良心了。”女孩一下子就不高兴,说:“我没良心?你给我买过一块手表,白色的皮表带,我戴了四五年,电池都换了两回,最后带子都断了,这款早就停产了,没得修,一直放抽屉里。我搬了这么多次家,像我这种丢三落四的性格,合同都差点找不到。可那块手表到现在还好好的在我的抽屉里。”这话说完,女孩有点意识到自己的失态。男孩也有点尴尬,两个人都没有再多说什么。

那些年,闯进你生命中的那张温暖过你的脸

那块手表是一个很普通的牌子,几百块的样子。当时两个人都是学生,男生后来回忆说,那天买了回到学校,已经挺晚了,本来想第二天见面的时候给她。可在怀里揣着就觉得存不住,巴不得立马给她戴上。于是,赶在宿舍关门前把她叫下楼匆匆忙忙的塞给她。她并没说过有多喜欢,只不过一直都戴着,分手了也没见摘掉。女孩其实是一个挺得瑟的性格,工作之后,手上戴的,宝格丽的手链、卡地亚的镯子也没少买,但是手表确没再买过一块。

故事二:

朋友聚会,关系很铁的一个男生喝醉了,他跟我说起他的初恋。他说那个女孩子对他很好,当年大学时,他爱和兄弟们拼酒,喝醉后总是女孩把他拖回去,给他熬养胃汤,为他擦洗身体。他对我说,不知道当年小小身体的她,是怎么把他拖回家的;不知道每次喝醉时,她是怎样默默一个人收拾一地狼藉。不知道她是怎么一边心疼的看着喝醉酒的他。可是后来,他们还是分手了,因为女孩家庭条件不好,毕业后没有正式工作,男生家里一直反对反对,他的母亲甚至说要赶他出门,他们坚持了好几年,最后还是输给了现实。他说:“我现在很少喝碎酒了。”我说:“是因为年纪大了,要注意身体了吗?”他说:“不是,是因为有天我喝醉了,发现自己在车上睡了一夜,没有人找我,也没有人管我冷不冷,安不安全。”我说:“你老婆呢?”他说:“我老婆说了,我不管你喝酒,但你喝醉了也别麻烦我。”他现在的妻子是相亲认识的,一年内结婚生子,说不上特别爱,彼此相敬如宾。他妻子几乎从不跟他和他兄弟出来玩,她有自己的世界和朋友。对他说不上很上心,该做的都做,却也不会过分的纵容他。不会管他和兄弟出去喝得很醉,但也不会在他醉了之后为他收拾一地狼藉、为他擦洗身体,为他熬一碗热热的养胃茶。但她是他父母觉得不错的女孩,家事不错,有稳定的工作,性格也不错。他和她是世俗大众喜欢看到的般配。

他的女儿,叫:思琦。是他坚定要取的名字。曾经在他喝醉后背他回家,默默陪伴他、照顾他、爱他很多年的那个女孩,乳名叫琦琦。他们还很相爱的时候,他开玩笑说:“如果有一天你离开了我,我就给自己的孩子取名叫思琦,我要一辈子想念着你。”现在真的这样了,他真的只能在一个名字里思念她。

故事三:

最近有一个已婚的好朋友总是找我聊天。某天夜里11点多,他给我打电话。我问她“你在哪?”她说“加完班,回家的路上。”我说“一个人吗?”她说:“是啊。”我问她:“怎么不叫你老公来接你呢?”她说:“他打牌呢,叫我自己打车回家。”知道她上班的那个地方,在新区,有时候晚上走很远都打不到车。后来她走了20多分钟才打到车,我说去接她。她不肯,我说:“你一个女孩子在外面也不安全。”然后她说:“我自己老公都不担心我,没来接我,你担心什么?”听出了她话里的失望。

她跟我说起她大学时候的恋人。她说:“那时候他连让我一个人下楼买点零食都不放心,要陪我一起。”后来她在一家公司实习,9点半下班,男孩子每天都会骑自行车去接她。实习三个月,90多个夜晚,每晚等在公司门口的身影。她说她一辈子都忘不了。后来,大学毕业她父母在本市给她安排了稳定的工作。男孩家三代单传,他父母天天吵着要他回去。男孩希望她去他的城市。可她害怕在那边有一不可预知的未来。父母的独女,这边有稳定工作,爱她的父母、家人、同学、朋友。去了那边,她只有男孩一个人。两个人远距离恋爱了一段时间。后来,她越来越没有安全感,放弃了这段感情。她说,她结婚的时候,男生把她留在他那里所有东西都寄了回来。其中有她很多年前用过的小玩意、小饰品、耳环、零钱包、还有绣着她名字的毛巾。分手这么多年,他还保留着。曾经他们一起用过的情侣号码,男孩用的那个还一直保留着,他说过:“任何时候,这个号码一直为你开通。”知道她哭了。可是开不了口安慰他,她已婚,丈夫是家人满意的,有车有房,众人都说很适合她。28岁结婚,也不算早了。丈夫不会像男孩那样宠溺她。在丈夫眼里,她是个成年人了,很多事情完全可以自己解决。她说:“我老公常说,你又不是小孩了,好多事情完全可以自己做的。”所以一个人去超市扛一大堆东西回家,所以11点多加完班自己打车回家,所以习惯了,习惯了这一种淡淡的失落。在一个人回家的夜晚,还是会想起那个等在公司门外踩着自行车的身影。还是会想起那个人,虽然,回不去了。

到底有多少人。会在一个人回家的夜晚,喝醉酒的深夜,想起从前陪在你身边的人。那些为你付出千般好、万般好,最后却没有和你走到一起的人。

又还有多少人,会在很多年后,还肯这样掏心掏肺的对一个人好。

你说:我再也不会这样无怨无悔的爱一个人了。于是你成了一个吝啬付出的人。也得到了一个有所保留的爱人。

你心里藏着一个人,一段回不去的往事。你身边的人,也许一样。他们最傻最好的时光。给了另一个人。

是现实在残忍?还是输给了时间。或者彼此不够坚定?还是没有学会珍惜?现在你身边的人,是世人都觉得和你很般配的人。

谁管你曾经多么的被一个人宠爱?谁管你曾经多么的爱过的一个人?

反正这就是人生。

2013年07月24日

一.概述:

实际工作中估计会经常碰到用ASA接两家ISP线路,比如电信和网通,而又没有足够的预算买负载均衡设备,但是又想实现链路负载分担和自动切换,从电信来的流量,从电信线路回去,从网通来的流量从网通线路回去,当其中一条线路出现故障时,所有的流量从没有出现故障线路走。
二.基本思路:
A.用OSPF模拟运营商网络,主要是为了不想手工添加路由

B.通过添加默认路由走电信线路、监控电信线路的网关,和高metric的默认路由走网通线路,实现:

—-电信来的流量走电信回去(需要C手工配置网通静态路由相配合)

—-电信链路出现故障时,走网通线路

C.通过添加网通的静态路由走网通线路,并监控网通线路的网关,实现:

—-网通来的流量走网通回去

—-网通链路出现故障时,走电信线路的默认路由

D.对于静态NAT,实际环境只有当两条ISP线路都正常时,才会同时能被访问

E.测试环境,实现静态NAT当一条线路出现故障时,还能同时被访问,实现的方法是:

—ASA两个外部接口配置两条静态NAT

—ASA两个相连的ISP路由器把另外一家ISP所NAT的网段发布出去,并将metric设置比OSPF默认的大

三.测试拓扑:

四.基本配置:
A.R1:
①接口配置:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
interface Loopback61
ip address 61.1.3.1 255.255.255.0
ip ospf network point-to-point
interface Loopback202
ip address 202.100.3.1 255.255.255.0
ip ospf network point-to-point
interface FastEthernet0/0
ip address 202.100.2.1 255.255.255.0
no shut
interface FastEthernet0/1
ip address 61.1.2.1 255.255.255.0
no shut
②路由配置:
router ospf 1
router-id 1.1.1.1
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface FastEthernet0/1
network 61.1.2.1 0.0.0.0 area 0
network 61.1.3.1 0.0.0.0 area 0
network 202.100.2.1 0.0.0.0 area 0
network 202.100.3.1 0.0.0.0 area 0
B:R2:
①接口配置:
interface Loopback0
ip address 2.2.2.2 255.255.255.0
interface FastEthernet0/0
ip address 202.100.1.2 255.255.255.0
no shut
interface FastEthernet0/1
ip address 202.100.2.2 255.255.255.0
no shut
interface FastEthernet1/0
ip address 23.1.1.1 255.255.255.252
no shut
②路由配置:
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/1
no passive-interface FastEthernet1/0
network 23.1.1.1 0.0.0.0 area 0
network 202.100.1.2 0.0.0.0 area 0
network 202.100.2.2 0.0.0.0 area 0
C.R3:
①接口配置:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
interface FastEthernet0/0
ip address 61.1.1.3 255.255.255.0
no shut
interface FastEthernet0/1
ip address 61.1.2.3 255.255.255.0
no shut
interface FastEthernet1/0
ip address 23.1.1.2 255.255.255.252
no shut
②路由配置:
router ospf 1
router-id 3.3.3.3
passive-interface default
no passive-interface FastEthernet0/1
no passive-interface FastEthernet1/0
network 23.1.1.2 0.0.0.0 area 0
network 61.1.1.3 0.0.0.0 area 0
network 61.1.2.3 0.0.0.0 area 0
D.ASA842:
①接口配置:
interface GigabitEthernet0
nameif Inside
security-level 100
ip address 10.1.1.10 255.255.255.0
no shut
interface GigabitEthernet1
nameif Outside
security-level 0
ip address 202.100.1.10 255.255.255.0
no shut
interface GigabitEthernet2
nameif Backup
security-level 0
ip address 61.1.1.10 255.255.255.0
no shut
②两条线路的动态PAT配置:
object network inside_net
subnet 0.0.0.0 0.0.0.0
object network inside_any
subnet 0.0.0.0 0.0.0.0
object network inside_net
nat (Inside,Outside) dynamic interface
object network inside_any
nat (Inside,Backup) dynamic interface
③两条线路的静态NAT配置:
object network Inside_host_outside
host 10.1.1.4
object network Inside_host_backup
host 10.1.1.4
object network Outside-to-backup
host 10.1.1.4
object network Backup-to-outside
host 10.1.1.4
object network Inside_host_outside
nat (Inside,Outside) static 202.100.1.4
object network Inside_host_backup
nat (Inside,Backup) static 61.1.1.4
object network Outside-to-backup
nat (Inside,Outside) static 61.1.1.4
object network Backup-to-outside
nat (Inside,Backup) static 202.100.1.4
—-每条线路配置两条NAT,保证一条ISP线路出现故障时,两条静态NAT都能被访问
④防火墙策略配置:

class-map ALL_IP
match any
policy-map global_policy
class inspection_default
inspect icmp
class ALL_IP
set connection decrement-ttl
service-policy global_policy global
access-list outside extended permit icmp any any
access-list outside extended permit udp any any range 33434 33523
access-list outside extended permit tcp any object Inside_host_outside eq telnet
access-group outside in interface Outside
access-group outside in interface Backup

E:R4:
①接口配置:
interface Loopback0
ip address 192.168.1.4 255.255.255.0
interface FastEthernet0/0
ip address 10.1.1.4 255.255.255.0
no shut
②路由配置:
ip route 0.0.0.0 0.0.0.0 10.1.1.10
③telnet配置:
line vty 0 4
password cisco
login
五.ASA842 SLA及路由配置:
①sla配置:
sla monitor 1
type echo protocol ipIcmpEcho 202.100.1.2 interface Outside
frequency 10
sla monitor schedule 1 life forever start-time now
sla monitor 2
type echo protocol ipIcmpEcho 61.1.1.3 interface Backup
frequency 10
sla monitor schedule 2 life forever start-time now
②track配置:
track 1 rtr 1 reachability
track 2 rtr 2 reachability
③静态路由配置:
route outside 0 0 202.100.1.2 1 track 1
route backup 0 0 61.1.1.3 254
—默认路由走电信线路,当电信线路出现故障时自动切换到网通线路
route Backup 61.1.2.0 255.255.255.0 61.1.1.3 1 track 2
route Backup 61.1.3.0 255.255.255.0 61.1.1.3 1 track 2
—当网通线路正常时,到网通的网络的数据走网通的线路,否则走电信的默认路由
route Inside 192.168.1.0 255.255.255.0 10.1.1.4 1
—增加一条回指路由
六.关于静态NAT:
—为了使两条线路其中一条线路出现故障时,两个被静态NAT地址都能访问,需要:
A.每条线路配置两条静态NAT
—-前面已经配置
B.每个相连的ISP路由器把另外一家ISP所NAT的网段发布出去,并将metric设置比ospf默认的大
—-这种情况在实际环境基本无法实现,两家ISP不可能会帮客户做这样的事情,除非给的费用足够多
—-测试环境下还是可以玩一玩的
①R2路由器:
ip route 61.1.1.0 255.255.255.0 202.100.1.10 254 tag 10
route-map ASA842 permit 10
match tag 10
router ospf 1
redistribute static metric 130 subnets route-map ASA842
②R3路由器:
ip route 202.100.1.0 255.255.255.0 61.1.1.10 254 tag 10
route-map ASA842 permit 10
match tag 10
router ospf 1
redistribute static metric 130 subnets route-map ASA842

七.效果测试:

A.线路正常的情况下:

R4#traceroute 202.100.3.1 source l0
Type escape sequence to abort.
Tracing the route to 202.100.3.1
1 202.100.1.2 160 msec 108 msec 56 msec
2 202.100.2.1 36 msec * 24 msec
R4#traceroute 61.1.3.1 source l0
Type escape sequence to abort.
Tracing the route to 61.1.3.1
1 61.1.1.3 112 msec 8 msec 0 msec
2 61.1.2.1 112 msec * 68 msec
—去电信的流量走电信,去网通的流量走网通

R1#traceroute 202.100.1.4 source l202
Type escape sequence to abort.
Tracing the route to 202.100.1.4
1 202.100.2.2 32 msec 56 msec 20 msec
2 202.100.1.10 40 msec * 24 msec
3 202.100.1.4 80 msec * 16 msec
R1#traceroute 202.100.1.4 source l61
Type escape sequence to abort.
Tracing the route to 202.100.1.4
1 202.100.2.2 140 msec 180 msec 80 msec
2 202.100.1.10 64 msec * 88 msec
3 202.100.1.4 140 msec * 84 msec
R1#traceroute 61.1.1.4 source l61
Type escape sequence to abort.
Tracing the route to 61.1.1.4
1 61.1.2.3 116 msec 32 msec 0 msec
2 61.1.1.10 4 msec * 4 msec
3 61.1.1.4 208 msec * 128 msec
R1#traceroute 61.1.1.4 source l202
Type escape sequence to abort.
Tracing the route to 61.1.1.4
1 61.1.2.3 8 msec 120 msec 192 msec
2 61.1.1.10 0 msec * 20 msec
3 61.1.1.4 152 msec * 204 msec
—-两个被静态NAT地址都能被访问,并且电信的地址走电信接口,网通的地址走网通的接口

B.电信线路不正常的情况下:

R4#traceroute 202.100.3.1 source l0
Type escape sequence to abort.
Tracing the route to 202.100.3.1
1 10.1.1.10 188 msec * 28 msec
2 61.1.1.3 44 msec 0 msec 0 msec
3 61.1.2.1 108 msec * 84 msec
R4#traceroute 61.1.3.1 source l0
Type escape sequence to abort.
Tracing the route to 61.1.3.1
1 10.1.1.10 0 msec * 20 msec
2 61.1.1.3 100 msec 32 msec 0 msec
3 61.1.2.1 108 msec * 72 msec
—去电信和网通的流量都走网通
R1#traceroute 202.100.1.4 source l202
Type escape sequence to abort.
Tracing the route to 202.100.1.4
1 61.1.2.3 4 msec 184 msec 52 msec
2 61.1.1.10 0 msec * 0 msec
3 202.100.1.4 152 msec * 12 msec
R1#traceroute 202.100.1.4 source l61
Type escape sequence to abort.
Tracing the route to 202.100.1.4
1 61.1.2.3 36 msec 4 msec 16 msec
2 61.1.1.10 200 msec * 16 msec
3 202.100.1.4 184 msec * 148 msec
R1#traceroute 61.1.1.4 source l61
Type escape sequence to abort.
Tracing the route to 61.1.1.4
1 61.1.2.3 48 msec 0 msec 0 msec
2 61.1.1.10 4 msec * 32 msec
3 61.1.1.4 148 msec * 180 msec
R1#traceroute 61.1.1.4 source l202
Type escape sequence to abort.
Tracing the route to 61.1.1.4
1 61.1.2.3 76 msec 52 msec 0 msec
2 61.1.1.10 0 msec * 16 msec
3 61.1.1.4 172 msec * 112 msec
—-电信和网通被静态NAT的地址都能被电信和网通的用户访问

C.网通线路不正常的情况下:

R4#traceroute 202.100.3.1 source l0
Type escape sequence to abort.
Tracing the route to 202.100.3.1
1 10.1.1.10 8 msec * 28 msec
2 202.100.1.2 108 msec 72 msec 84 msec
3 202.100.2.1 88 msec * 128 msec
R4#traceroute 61.1.3.1 source l0
Type escape sequence to abort.
Tracing the route to 61.1.3.1
1 10.1.1.10 0 msec * 76 msec
2 202.100.1.2 112 msec 96 msec 24 msec
3 202.100.2.1 248 msec * 76 msec
—去电信和网通的流量都走电信
R1#traceroute 202.100.1.4 source l202
Type escape sequence to abort.
Tracing the route to 202.100.1.4
1 202.100.2.2 4 msec 156 msec 76 msec
2 *
202.100.1.10 40 msec *
3 202.100.1.4 68 msec * 24 msec
R1#traceroute 202.100.1.4 source l61
Type escape sequence to abort.
Tracing the route to 202.100.1.4
1 202.100.2.2 92 msec 60 msec 124 msec
2 202.100.1.10 4 msec * 36 msec
3 202.100.1.4 152 msec * 60 msec
R1#traceroute 61.1.1.4 source l61
Type escape sequence to abort.
Tracing the route to 61.1.1.4
1 202.100.2.2 32 msec 136 msec 116 msec
2 202.100.1.10 80 msec * 56 msec
3 61.1.1.4 120 msec * 120 msec
R1#traceroute 61.1.1.4 source l202
Type escape sequence to abort.
Tracing the route to 61.1.1.4
1 202.100.2.2 4 msec 140 msec 112 msec
2 202.100.1.10 64 msec * 64 msec
3 61.1.1.4 156 msec * 80 msec
—-电信和网通被静态NAT的地址都能被电信和网通的用户访问

2013年07月09日

$command option(s) argument(s)
command:命令
option(s):命令选项,均以’-'号开始
argument(s):参数
命令 用途
——————————————————-
prtconf 显示系统的各项主要配置
svmon -G 查看内存(4k)
iostat 2 查看磁盘读写情况(每2秒刷新);
set -o vi 调用缓冲区 k,j,x,h,l 向上下翻,Esc
smit 进入管理界面
cd 改变路径
ls 列出文件
ls -aF 列出隐含文件,并适当分类
ls -l 列出文件的详细信息
ls -ltr
more 输出文件内容到屏幕
cat 显示文本文件内容/合并文件
pg 分页显示文件内容,回车后下一页
file 显示文件属性(可执行/ASCII/等)
clear 清屏
mkdir 创建目录
rmdir 删除目录
cp 拷贝文件
mv 文件/目录改名,转移
rm 删除文件/目录, 如:rm -fr ora*
rmdir 删除目录,如: rmdir oracle
df -k 显示文件系统的信息
du 磁盘使用信息汇总
mount 显示已经挂装的文件系统的信息或挂装文件系统 mount -rv cdrfs /dev/cd0 /cdrom mount /dev/lv02 /u01
umount 卸载某个文件系统 umount /cdrom
fuser -kxuc /dev/cd0 当光驱不能正常释放时
lsattr -E -l sys0 -a realmem 察看内存的命令
env 输出用户环境变量到屏幕
id 察看用户的属性
whoami 察看当前用户名
who 查看已经登录的用户
who -r 查看目前系统的运行级别
users 用单独的一行打印出当前登录的用户,每个显示的用户名对应一个登录会话
如果一个用户有不止一个登录会话,那他的用户名将显示相同的次数
w 显示当前系统中每个用户和它所运行的进程信息
last 此命令往回搜索wtmp来显示自从文件第一次创建以来登录过的用户
whereis 命令的绝对路径
passwd 设置用户密码
su 改变/切换用户id
lsuser ALL 列出所有已经创建的用户
lsgroup ALL 列出所有已经创建的组
smitty user 管理用户
mkuser 创建新用户,创建用户的缺省属性值于文件:/usr/lib/security/mkuser.default,只能由root修改
smitty group 管理组
mkgroup 创建新组
chfn 改变用户详细信息
jobs 查看后台任务/进程
fg 把后台进程调到前台
bg 把当前进程调到后台运行
grep 查找匹配字符/字符串
netstat -i 显示网络连接信息及统计信息
netstat -IN
netstat -rn 显示核心路由表
netstat -I 网络设置名 端口号 监视端口情况
netstat -v 正在使用的设备驱动程序的统计信息
netstat -m 网络使用的内存空间情况
netstat -D 显示丢弃包的情况
ifconfig -a 显示网络配置信息
umask 显示文件创建掩码,即新建文件或目录的缺省权限,如#umask 664
date 系统时间
find path expression 查找文件,expression的值有:
-name/-type/-size/-mtime(修改时间)/-perm(权限)/-usr/-o(或)
uname 显示操作系统信息
oslevel 系统版本
man 帮助文件
smitty clstart | clstop 起用|关闭HA
smitty hamcp
smitty chinet 改变网卡的配置信息
smitty cluster 配置cluster
smitty hacmp 配置hacmp
/usr/sbin/cluster/clstat & 显示cluster信息
dbassist 启动oracle数据库配置助手(dbca -9i 可以用配置数据库方式启动一个数据库)
netasst 启动oracle数据库listener配置助手(-9i oemapp是一个包,后跟参数,不同工具)
vi 文件编辑器
动作字符:
a 在当前字符后添加文字; x 删除单个字符;
A 在当前行最后添加文字; dw 删除至当前词尾;
i 在当前字符前添加文字; d$ 删除至当前行尾;
I 在当前行开始处添加文字; d0 删除至当前行首;
o 在当前行后添加新行; dd 删除当前行;
O 在当前行前添加新行; :20,40d 删除20行至40行;
/text 向后查询 ?text 向前查询
r 修改当前字符 R 覆盖字符,直至按下[ESC]
s 删除当前字符,并可添加字符直至按[ESC]
S 删除当前行,并可添加字符直至按[ESC]
yy 将当前行存入缓冲区
dd
p
P
errpt|pg 创建/显示错误文件
errclear 0 清除错误日志文件内容
lsvg -o 显示卷组信息
lsvg -l rootvg
instfix -iv|grep AIX_ML 安装的文件集
smitty tcpip tcp/ip配置
lsdev -Cc disk 系统设备信息(磁盘)
lspv 显示卷组里的物理卷信息
lsdev -Cc pdisk 显示阵列里的磁盘信息
errclear 清除error log
lsps -a 显示交换空间
swapon /dev/paging01 激活交换空间
chps -a paging01 删除交换空间
rmps paging01 删除不活动的交换空间
smit mkps 增加交换空间
smit chps 修改交换空间
varyonvg 激活卷组 如:varyonvg datavg 将datavg激活
varyoffvg 关闭卷组
/ect/services 查看端口
/etc/hosts 机器名IP对照表
/etc/inittab 相当于DOS的AUTOEXEC.BAT文件
/etc/filesystems 记录所有的文件系统设置
增加并配置端口
删除端口
ftp://root@10.188.12.250/ 在客户端登录AIX(用IE)
lscfg
lsdev
route ADD 0 10.188.12.1
route add default 192.168.0.1 设置网关(或在/etc/defaultrouter文件中加入网关地址,重起机器就行)
su root 以ROOT用户登录;
smitty lv 增加逻辑盘
LN -s 源目录 目标目录 链接
ls -l 查看权限
./fielname 运行filename文件
smitty clstart 启动HA
smitty clstop 停止HA
.filename 表示filename文件(目录)为隐藏;
cat file1 >> file2 合并file1到file2
SMIT 综合管理工具
# 表示ROOT用户;
$ 表示一般用户;
shutdown -fr 快速重启;
smitty crjfs 创建结点; mount /u05 chown -R oracle.dbs u05 chmod -R 777 u05
加一个文件系统的步骤: 加文件系统/chmod/chown/mount 文件系统名
smitty jfs
smitty lv
smitty lvm 管理逻辑卷
smitty vg 管理卷组
smitty chvg
drwxrwxrwx d表示目录,-表示普通文件,r表示链接; d421421421 777全部权限
-rwxrwxrwx 第2-4:属主用户,5-7:同组用户,8-10所有用户
date 0217142590 This sets the date and time to Sat Feb 17 14:25:00 CST 1990.
当root不能在其终端上登录时 修改/etc/hosts文件,查看其IP地址对应的主机名;
当其他用户不能在其终端上登录时 删除用户,并删除/home下对应的目录,重建;
smitty aio 调整aioservers
#pstat -a|grep aios|wc -l 查看aio的值是否常达到MAX,IF 增加MIN, MAX aio;
当任何用户都不能登录图形界面时 有可能根结点充满,在登录窗口用字符方式登录,加大根结点空间即可;
ps -ef | grep cluster 查找包含”cluster”的进程
more /etc/passwd|grep zhxx 查找静态字符”zhxx”
pe -f 进程查看,如:# ps -f
UID PID PPID C STIME TTY TIME CMD
root 43626 45014 0 20:38:58 pts/1 0:00 -ksh
root 47710 43626 2 21:08:03 pts/1 0:00 ps -f
用户ID 进程ID 父进程ID CPU利用率 开始时间 控制台 运行时间 命令
kill -9 **** ***为进程号,可用ps获得
ping 10.188.12.252 -l 17000 -t 以17000 bytes/包 ping 目标
crontab 创建计划任务(crontab -l 查看已有任务, crontab -e 编辑或增加,删除任务)
0 2 * * * /u05/dmpbak/auto.sh 表示:每天两点执行/u05/dmpbak/auto.sh文件
lsfs 列出所有文件系统
lsvg -l rootvg 列出rootvg的卷
lsvg -p rootvg 列出物理卷信息
lsvg datavg 可查询空闲物理分区数
smit reogvg 重组卷组
smit importvg 导出卷组,卷组必须是不活动的;
lspv hdisk0 显示物理卷
lspv -l hdisk0 逻辑卷映射
lspv -p hdisk0 物理卷映射
defragfs -q /u01 报告文件系统的当前状态
defragfs -r /u01 得到碎片连续化操作后和前后对比情况
defragfs /u01 执行碎片连续化操作
fsck /u05 检查u05文件系统
xclock 时钟,可用于检查环境是否正常
chmod 777 /u02
r 2=3 相当于:chmod 777 /u03
rsh zzyc2_sev 在其他机器上登录某主机
dgmgrl 类似SVRMGRL(9i)
ps -ef |grep oracle |pg 查看oracle用户的所有进程
kill -9 14206 杀14206#进程
kill -l 显示KILL命令可以用的信号量
killall signal 删除除发送外的其他所有进程
/usr/sbin/cluster/clstat & 显示双机热备状态图
exit或logout 退出登录
qprt filename1,filename2… 打印文件
qchk 查看打印队列
qcan 取消打印作业
lsps -a 查询交换空间,如USE超过70%,则要增加
set 查看已定义的变量;
echo $name 查看某个变量的值;
xxx=value 定义变量
unset xxx 删除变量
`` 把``之间的内容作为一个命令,返回命令结果; 如$now=`date` $echo $now
” 直接显示”间的内容,不予解释;
“” 解释”"间的$,``,等字符的特殊含义;
忽略后的特殊字符的特殊含义;
$$ 表示当前进程的ID
$0 当前shell程序的名称
$# 传给当前shell Script的参数个数;
$* 传给当前shell Script的第*个参数,$1-$9,${10}……
$? 最近一个命令的返回值;
$! 最近一个后台进程的ID号;
expr shell下的四则运算:
* 乘; /除; % 求余数; +,- 如:expr (3+3)*(4-2)
command1 && command2 如果第一个命令执行成功,则运行第二个命令;
command1 || command2 如果第一个命令执行失败,则运行第二个命令;
test 表达式 测试条件表达式,主要有:
-f filename 文件是否存在;
-d dirctory 目录是否存在;
-r filename 文件存在,且能被当前进程读;
-w filename 文件存在,且能被当前进程写;
-x filename 文件存在,且能被当前进程运行;
-n string 字符STRING长度非零;
-z string 字符STRING长度零;
string1=string2 两个字符串相同;
integer1 -eq integer2 两个变量相等;(ne:不等 gt:大于 lt:小于 le:小于等于 ge:大于等于)
if ..
then ..
else…
fi
read xxx 从标准输入读入一行,赋给xxx变量; read x echo $x
for i in ….
do

done
while expression
do

done
ksh scriptname
scriptname
pathname/scriptname shell script的三种执行方法
#command 前台进程
#command & 后台进程
nice/renice 增加/再增加nice的值,从而降低进程优先级;
nohup command & 使用户的后台进程在用户退出时仍然运行
#alias alias=string 赋命令别名
unalias aliasname 取消命令别名
history 显示最后的16条命令
cal 2003/cal 2 2003 日历
finger [oracle] 显示用户信息
mail 接收,发出,查看电子邮件
clear 清屏
echo 显示指定信息
wc filename 统计指定文件的行数,词数,字节数
head filename 显示文件头
tail filename 显示文件尾
tail -f /tmp/hacmp.out 显示HACMP启动情况
[^+C]/[^+d]/[^+s]/[^+q]/[^+u] 终止/结束文件传输/暂停屏幕输出/继续屏幕输出/删除当前输入行
smit(system management interface Tool)
其log文件/script文件保存在各用户目录下;
alog -o -t boot 查看引导日志
chtz 设置新时区
/etc/profile
/etc/environment
$HOME/.profile 系统设置用户环境的主要文件;
lsuser -a id home ALL 列出所有用户
/etc/motd 用户登录时显示的信息,可直接编辑,但如果用户主目录下$HOME/.hushlogin存在,motd不显示;
wall ***** 向各登录用户发出*****消息,用户终端上将马上显示;
/var/adm/sulog su命令执行记录
/var/adm/wtmp,/etc/utmp 用who命令查看登录记录
last root |pg root用户登录记录
last reboot | pg 重启记录;
/etc/passwd 合法用户(不含密码)
/etc/group
/etc/security 普通用户不能访问的安全性文件目录
lsdev -P 列出所有的设备, lsdev -Pc disk
smitty devices 设备管理
lsattr -E -l sys0 列出已配置的设备
jfs/Cdrfs/Nfs AIX支持的三种文件系统
/var/adm/wtmp
/var/spool/*/*
/smit.log
/etc/securibty/failedlogin
/var/adm/sulog 这些文件增长很快,要定期清理,可用cat /dev/null > filename方式清理
du /u05 | sort -r -n 查询文件或目录所占用的磁盘块数
vmstat 显示虚拟内存,内存及CPU活动信息;
arp -a 查看解析协议ARP表
hostname 显示机器名
/etc/rc.tcpip 系统启动时自动执行,进而执行以下子进程:
 -syslogd :错误信息日志
 -portmap :端口查找
 -inetd :Internet服务的主守护进程
 -named :域名服务器
 -lpd :打印服务器
 -routed or gated :动态路由
 -sendmail :邮件系统
 -timed :时间服务器
 -rwhod :远程用户信息
 -snmpd :SNMP代理进程
host 机器名/IP 实现IP与机器名的转换
rsh PTYC2_svc date 执行另一台主机上的命令
lscfg 显示机器配置信息
lsdev -C -c if 显示网络接口描述
lsdev -C -c adapetr 显示适配描述
netpmon -v 物理/逻辑资源的详细报告
ps aux 查询内存使用情况
sar [-u|-c|-a|-q|-r] [-p] 1 10 查询系统负载情况
traceroute 10.188.182.1 跟踪IP
netpmon 可以监控关于网络行为的系统事件和性能以及网络行为对CPU的消耗。
lsdev -C|grep Process|wc -l 显示CPU数量
smitty mklv 创建裸设备(字符型设备);
smitty rmlv 删除裸设备(字符型设备);
lslv ***** ******为裸设备名称,显示裸设备相关参数
/etc/default/login 加上CONSOLE=/dev/console 后,可防止root用户telnet;
SSL工具代替telnet等,增加安全性
/etc/passwd …/bin/sh 对应 .profile
/etc/passwd …/bin/csh对应 .login
系统正常从桌面登录执行 .dtprofile
su – username执行 .profile
vmstat 查询内存情况
iostat
mpstat 查询CPU情况
/etc/vfstab 磁盘目录规划
mount 目录安装情况
format 查看磁盘物理信息
p 分区
p
swap [-l|s|d|a] 操作swap交换空间
patchadd -d 补丁文件名 打补丁-p 显示已打的补丁信息
sysdef -i
share -F nfs -o ro /etc
hare -F nfs -o rw=usera:userb /export
unshare /etc
dfshares
/usr/dt/bin/dtconfig -d 这将告知系统在下一次重新引导时不启动登录服务器。
/etc/ftpusers,/etc/default/login SOLARIS8下的FTP和TELNET缺省是关着,看看这两个文件.
sys-unconfig solaris重新设置
kdmconfig 配置显示器
eject 弹出CD-ROM或软驱;

中小型企业cisco IP电话部署案例一

—–CME

亚威讲师袁阳

IP电话是将模拟的声音信号经过压缩封包之后,以数据封包的形式在IP网络进行语音信号的传输。它使你可以通过现有的IP网络资源传送语音、传真、视频和数据等业务。可以实现语音,视频和数据在同一网络共存。达到节约企业电话成本,同时实现统一消息、虚拟电话、虚拟语音/传真邮箱、查号业务、Internet呼叫中心、电视会议、电子商务、传真存储转发和各种信息的存储转发等业务。

下面先简单介绍一下VOIP中用到的电话种类,有关Voip原理在我的后续技术文章中给大家介绍。

1.数字电话:如Cisco 79XX系列。此类电话可以直接把人的声音模拟信号转为数字信号,用采样,量化,编码,压缩等技术实现模拟和数字之间的转换。

2. IP Soft Phone:如CISCO IP Communicator.此类电话为装在PC上的软件,也可以实现IP电话。

3.普通模拟电话:

此类电话为最常见的家用模拟电话。只能处理模拟信号,要在IP网中传输,必须通过DSP(数字信号处理器)实现模拟和数字之间的转化。

有关Voip原理在我的后续技术文章中给大家介绍。下面通过一个实例给大家介绍一下有关IP PHONE 在中小型企业的部署:

企业ABC有总部和一个分支,总部在北京,分支在上海,网络现状是:北京和上海之间以有WAN的连接用与数据的传输,北京和上海间电话走PSTN电话网,每个月有一大部分的长途电话费用支出。现在想把语音和数据都用WAN去传输,电话用的是数字电话CISCO7960或 cisco Ip communicator 软电话。

测试环境:

1. Cisco 3725路由器2台

2. Cisco 3550交换机 2台

3. Cisco 7960 IP 电话2台

4. Cisco Ip communicator 软电话

配置包括CISCO 7960的配置,3550 Switch的配置,3725 Router 的配置等,今天先给大家介绍一下CISCO 3725路由器做CME的配置。其他的在后面的技术文章中陆续给大家介绍。

在部署IP电话时IP电话需要通过DHCP获的IP地址,网关,TFTP地址等,并去TFTP获的配置文件等,可以注册在CISCO的一个专用的叫Callmanage上(功能后面给大家介绍,有些功能象PBX)或注册到路由器,叫CME,对与大的IP电话网可以用Callmanage, 中小型电话网可以用CME实现注册。下面介绍CME的配置:

总部和分支路由器实现CME。北京DN(电话号码)为4001和1001 BR-DN为5001和5002。总部和分支的连接用FR。注意也可以让总部和分支的IP电注册到同一个CME上。

北京配置如下:

一:路由器做DHCP服务器

ip dhcp pool pool1

network 100.1.1.0 255.255.255.0

default-router 100.1.1.1

option 150 ip 100.1.1.1(150指TFTP服务器地址)

ip dhcp excluded-address 100.1.1.1

二.路由器接口和协议的配置

interface Serial0/0

ip address 10.1.1.1 255.255.255.0

encapsulation frame-relay

frame-relay map ip 10.1.1.2 103 broadcast

no frame-relay inverse-arp

interface FastEthernet0/1

ip address 100.1.1.1 255.255.255.0

duplex auto

speed auto

router rip

network 10.0.0.0

network 100.0.0.0

三.VOIP路由和CME

dial-peer voice 1 voip(voip路由)

destination-pattern 5…(当以5开头的电话号码发给10.1.1.2)

session target ipv4:10.1.1.2

telephony-service

max-ephones 10

max-dn 5

ip source-address 100.1.1.1 port 2000

auto assign 1 to 2 type 7960

time-zone 42

create cnf-files version-stamp Jan 01 2002 00:00:00

max-conferences 8 gain -6

!

!

ephone-dn 1 dual-line

number 4001 (电话号码)

!

!

ephone-dn 2 dual-line

number 4002(电话号码0

!

!

ephone 1

mac-address 0007.0E81.10A3 (7960电话的MAC地址,电话号码为4001)

type 7960

button 1:1

ephone 2

mac-address 000C.2952.E6F2 (本电话为CISCO 软电话,电话号码为4002)

type CIPC

button 1:2

上海路由器配置:

一:路由器做DHCP服务器

ip dhcp excluded-address 200.1.1.1

ip dhcp pool pool1

network 200.1.1.0 255.255.255.0

default-router 200.1.1.1

option 150 ip 200.1.1.1

二.路由器接口和协议的配置

interface FastEthernet0/0

ip address 200.1.1.1 255.255.255.0

duplex auto

speed auto

interface Serial0/0

ip address 10.1.1.2 255.255.255.0

encapsulation frame-relay

frame-relay map ip 10.1.1.1 301 broadcast

no frame-relay inverse-arp

frame-relay lmi-type ansi

router rip

network 10.0.0.0

network 200.1.1.0

三.VOIP路由和CME

dial-peer voice 1 voip

destination-pattern 4…

session target ipv4:10.1.1.1 (当以4开头的电话号码发给10.1.1.1)

telephony-service

max-ephones 5

max-dn 5

ip source-address 200.1.1.1 port 2000

auto assign 1 to 2

create cnf-files version-stamp Jan 01 2002 00:00:00

max-conferences 8 gain -6

web admin system name Admin password admin

!

!

ephone-dn 1 dual-line

number 5001

!

!

ephone-dn 2 dual-line

number 5002

!

!

ephone 1

mac-address 0005.5E7C.C704

type 7960

button 1:1

ephone 2

mac-address 000C.2918.5C32

type CIPC

button 1:2

以上只给出了CME的配置。没有连接PSTN,打不了外线。连接PSTN有下面作用:

1. WAN线路允余

2. 打外线

3. CAC等

本文没考虑QOS,SRST,PSTN,CAC,以及 CCM等,以后会给大家陆续介绍。

2013年07月01日

检查您的域名的MX解析记录设置是否正确的步骤如下

1) 在Windows系统中点击”开始”菜单→”运行”→”输入cmd”(Windows98系统为command),打开windows系统的MS-DOS界面。输入”nslookup”命令,进入域名解析界面。
2) 输入” set q=mx “回车,进入MX记录查询状态
输入您公司邮件服务器的主域名,即为用户邮件地址的”@”之后的部分
如:hichina.com等
本文以hiChina.com为例返回如下大致信息:
> hichina.com
Server: 218.106.248.21 --这是当前所使用的DNS主机名
Address: 218.106.248.21#53 --这是当前所使用DNS主机地址

Non-authoritative answer:
hichina.com mail exchanger = 10 mx.hichina.com.
--这是china.com的MX记录指向的主机名
3) 规范的MX记录应当由主域解析出一个主机名(本例中是mx.hichina.com),再由此主机名解析出一个或多个IP地址(本例中是221.122.57.45)。
4) 注意:域名解析修改和添加只是在域名提供商的个别DNS上修改,其他人所使用的DNS服务器未必和您申请域名解析的DNS服务器相同,因此当您的域名添加或者修改后,只有等DNS服务器之间资料同步后才能看到正确的解析结果。万网的解析记录设置完毕后的生效时间为60分钟。其它服务器一般解析生效时间在同一个地区的同步可能需要几小时,全国DNS同步可能需要1-2天,全球DNS同步可能需要更长时间,因此域名解析更改后无法立刻生效。

Tags: ,.
2013年06月27日

一、独处与陪伴

在与人相处时,我常会遭遇一种尴尬,那种尴尬是相对无言的寂寞,感觉有如一阵冷风 在两个人之间的地带上穿行,所到之处一片茫然无措,阴冷肃杀。比如,因为工作关系,第一次见面的同事。你们有一项工作要讨论,于是约一起吃饭,谈事情。正 经事在菜还没有上桌之前就谈妥了,接着你们无话可说,四周的人在聊天,但是你们两个人的空气中却很寂静,仿佛一杯放久的豆浆,上面凝结了一层冷膜。沉默没 有维持多久,你们就打破沉默,开始聊天,你明显地感觉自己和对方都在刻意没话找话说,你们谈今天的天气,讲最新的社会新闻,比如扶梯惨案,公交车爆炸事 件,虐待儿童问题,大学生就业困难……等所有的社会新闻都谈得差不多了,你们的菜终于上来了,你感觉彼此都轻呼一口气,内心轻松许多。“来,来,来,吃 菜,吃菜。” 你们埋头吃菜,多亏了筷子和嘴巴的运动,彼此的尴尬被消融了许多,但是也有的时候,你感觉自己不是在吃美味的菜肴,而是在咀嚼尴尬,这尴尬味同嚼蜡,你恨 不得赶紧吃完饭,回家看电影上网去。如果当你们聊了许多社会新闻,菜还没有上来时,你们的话题就开始进入更加个人的领域。询问对方以下问题:是本地人吗? 如果不是,在这个城市生活了多少年?结婚了吗?有孩子了吗?没结婚的就谈谈没结婚的几个原因。结婚但没孩子的,就谈谈两个人结婚多久,如何认识,交往时候 的一些趣事。有孩子的就谈谈孩子的活泼可爱,也许对方还会拿出手机,让你看看孩子的照片,夸夸孩子的活泼可爱,心里想着:妈的,菜怎么还没有上来?

有 一类人,无法独处,无人陪伴就抓狂,他们充分依赖他人的陪伴和周围喧嚣的环境,没其他人在身边,他们会感觉寂寞又孤独,甚至有的人因无法忍受独处会抓起手 机,挨个儿的给朋友打电话,以求得一丝丝内心的慰藉。周国平说,独处是一种能力。“绝对不能忍受孤独的人是一个灵魂空虚的人。世上正有这样的一些人,他们 最怕的就是独处,让他们和自己呆一会儿,对于他们简直是一种酷刑。只要闲了下来,他们就必须找个地方去消遣。他们的日子表面上过得十分热闹,实际上他们的 内心极其空虚。他们所做的一切都是为了想方设法避免面对面看见自己。”他对此的解释是:“连他们自己也感觉到了自己的贫乏,和这样贫乏的自己呆在一起是顶 没有意思的,再无聊的消遣也比这有趣得多。这样做的结果是他们变得越来越贫乏,越来越没有了自己,形成了一个恶性循环。”

另一类人则醉心于 独处,喜欢独处更甚于陪伴,他们逃避亲密关系和人群,有人陪伴会让他们感觉不自在,浑身不舒服,总想逃离陪伴的关系。我自己的解释是:这类人也在想方设法 避免面对面看见自己。社会学里有个镜子理论。人是社会的产物,一个人的自我认识和自我认同是人与社会的互动、对话、行动中长出来的东西,我们透过“关系” “他人”的映照来认识自己。他们逃避关系,其实是在逃避自我。另一个解释则是他们害怕依恋的关系,害怕在关系中受伤,所以宁愿选择不建立关系。当然,选择 独处是避免受到伤害的方式之一,但如果仅仅因为预期的痛苦而避免依恋,就“不能使一个人活出存在意义上的完整性”,他也无法拥有充实的生活与人生。

与 这两类人相比,我更偏向是后者。也许由于长时间的独立生活和乐于独处,我已习惯一个人,上餐厅吃饭遇到服务员问:小姐,几位?我都可以微笑又大方地说:一 位。就像阿桑歌里唱的:“我一个人吃饭,旅行,到处走走停停。也一个人看书,写信,自己对话谈心……孤单,是一个人的狂欢。狂欢,是一群人的孤单。爱情, 原来的开始是陪伴。但我也渐渐地遗忘,当时是怎样有人陪伴。” 一个人习惯独处,并独处得如鱼得水般,不记得陪伴的滋味,也不适应陪伴的状态,有人陪伴对他而言,反而成为一种需要去努力学习和适应的状态。当有人陪伴着 一起做事还好,当无事可做又无话可说的时候,对这类人反而是一种不自在的煎熬。我就是如此,即便在和男朋友相处时,在与最好的闺蜜相处时,我们虽然彼此熟 悉又亲密,但是这种不自在偶尔还是出现。我写过好几篇关于“一个人”“孤独”等字样的文章,也蛮受读者喜欢,但是却从未写过有关陪伴的文章,因为我对独处 很在行,而陪伴于我则比较陌生和不在行。陪伴有时于我而言就像冬天的蒲扇,夏天的暖炉,多少觉得不合时宜。想象一下,在7月酷暑的天气里,当你面对一个暖 炉时的第一个想法是什么?一个字:逃。

二、沉默的陪伴是付出,是爱

确实如此,我常常逃避 陪伴,也逃避亲密的关系,只觉得一个人最自在舒服,无人对我有要求有期待,我对他人也无要求无期待,这就免去了许多麻烦与失落。我有的时候甚至觉得陪伴是 完全没有必要的,直到我爷爷病重和过世,我对陪伴才有了重新的认识。他得肺癌病逝前的那段时间,我每天都会去陪他一段时间。对一个躺在床上即将走到生命尽 头又在受着病痛摧残的人而言,时间是相当漫长的,过日子成了一种折磨。爷爷在床头摆了一个小闹钟,总是时不时地抬头看下时间。他需要我奶奶一直陪伴着在身 边,如果奶奶离开,去洗头或者做饭,没有跟他说一声,他会生气和抱怨:“你去哪里了,去了那么久?!”我爷爷子孙众多,所以我有一个大家庭。每天晚上7点 以后,一大家十几个人都会来到他的房间陪着他。我和叔叔以及堂哥堂弟几个会轮流帮助他按摩肩背,以缓解他因为消瘦和缺乏翻身而引起的肌肉麻痹感。我们大家 聚在他的房间里拉家常,说一些电视新闻,村民八卦,田间地头的趣事,家长里短,他听我们大家聊这些,就很开心。那时,他一直靠吸氧机帮助自己呼吸,说话已 不大方便。有的时候我们说到远房的一个亲戚想不起名字,他还会着急地补充一下。

记得立春那天夜晚,爷爷的呼吸忽然变得很急促起来。在我们乡 下,节气具有非常重要的象征意义,代表着离开和改变,很多小孩和老人在节气更替之际容易生病,病重的老人会在节气节气更替之际过世。我们大家都很担心爷爷 熬不过这一晚,整个家族的人都陪在他的身边。一开始大家还聊天,深夜两点以后,每个人都疲惫不堪,不再说话,只是默默地陪着他。让大家舒心的是,爷爷平安 地度过立春夜。春节期间,因为更多子孙的归来和陪伴,爷爷的气色也好起来,他过了一个很开心的春节。在元宵节过后不久,他握着奶奶的手,在家人的陪伴家闭 上了眼睛。

子曾经曰过:“未知生,焉知死?”先贤早就教导我们,学习如何好好活着也就是学习如何去死,同样,学习如何去死也就是学习如何好 好活着。爷爷对待病痛和死亡的态度,教会他的子孙如何面对生存与生活。在一天天和大家陪伴爷爷的日子中,我认识到爷爷教给我关于陪伴与爱的功课。他并不是 真的需要大家给他讲故事或者陪他聊天,他需要的只是陪伴,亲人在身边的陪伴,哪怕我们默默地坐在他身边不说一句话的陪伴都很好,这种陪伴就是爱,让他免于 孤独,让他看到自己走过这一生的创造出来的价值,帮助他克服对死亡的恐惧和焦虑。

还有一件小事,也加深我对陪伴的认识。我父亲因为去看爷爷 的时候,不是在他在睡觉时去看他,就是看了一会就离开,所以爷爷会向奶奶抱怨,说他不够孝顺。父亲听后感到很委屈。爷爷和父亲的心理我都能体会。爷爷觉得 我父亲不愿意花时间陪他。我父亲则觉得自己什么都做不了,只能和自己病重的老爸面面相觑,他觉得尴尬无助又焦虑。因为他没有认识到自己仅仅沉默地坐着都是 一种付出,表达着对他的爱和关心。

三、什么都不做地陪着也安心

在人际关系中,我们是如此 害怕沉默的陪伴。与不熟悉的人相处常有沉默时不自在的感觉,在与熟悉的朋友,甚至亲密关系中也会存在这种沉默时的不自在。有一男性朋友曾对我说:我受不了 和女朋友在一起,什么都不做,什么都不说的时候。不说话的时候我们用吃饭和做爱来填满,不做爱的时候,我们用吃饭和谈话来填满。也许这种状态正印证了那句 话:真不知道男女约会除了吃饭还能干吗?

我们与朋友和恋人在一起,不是不停地说话,就是不停地找事做,希望以此塞满沉默的空间。一沉默我们 就感觉尴尬,浑身不自在,如坐针毡,不是刻意没话找话说,就是急于想摆脱这种沉默的尴尬。我们完全没有意识到,什么都不做的陪伴也是一种付出,也是爱。更 重要的是,我们做不到什么都不做还能安心自在。什么都不做还能安心是一种非常高的心境,需要不断地修行。

我看了存在主义心理学大师欧文?亚 龙的不少书,其中在《在生命最深处与人相遇》这本书上讲了一个很有趣的小故事。亚龙有一位敬爱的老师,年岁很大了,患有老年痴呆症,住进疗养院,亚龙经常 去看他。最后一次他和朋友去看老师,可是老师病情加重,不记得他了。他跟老师谈了许多他们过去的事情,老师才记得一点他。

他友善而充满深情 地问老师:“杰里,对你来说,坐在这里跟你不能确定是谁的人一起谈话,那会是怎样的感觉呢?”他总是能够关注当下得体验!杰里听懂了他的话,并对他的问话 里所表达的关心做出回应:“我喜欢这种陪伴,”他说,“你知道,情况并不是那么糟。我每天醒来,看到窗外的绿树和鲜花,我很高兴看到它们。情况并不是那么 糟。”

“我喜欢这种陪伴”这回答的多令人感动。单单是陪伴就已然足够了,不管陪伴你的人你是否能确定彼此的关系。

上周我上心 理学的课,老师让我们体验了两种极端的类型的来访者,一个是喋喋不休的来访者,一个是沉默无语的来访者。老师问我们面对沉默无语的来访者的时候,内心什么 感受。大家说得都差不多:尴尬,无助,无奈,如坐针毡,觉得每一分钟都是煎熬。老师问了我的感受,我答:仿佛置身在一个沉默的密室。有的同学选择给来访者 倒水、放音乐等。其实这些并不是满足来访者的需要,只是满足心理咨询师自己的需要,他仿佛在说:你看,我都为你做了这么多事情,你怎么也得说一两句话 吧?!这是一种互惠的策略,同时彰显自己多体贴,多关怀,并醉心于此。还有的同学指着自己的手表说:你看,已经过去好几分钟了,你一句话都没说,不管你说 不说话,钱我可是照收的。这则是一种威逼利诱。老师说,当他自己面对这样的来访者也会沉默不语,等着来访者自己打破沉默。这让我想起《心灵捕手》中的咨询 师西恩。在他与威尔最初的两次治疗中,威尔长时间地陷入沉默中。威尔沉默时,西恩也一样沉默。他绝不先开口,而是等待威尔开口。甚至在他面前打起了瞌睡。 这种沉默有两层意思:一是你有沉默的权利。二是我不会诱惑或者对你施加压力让你说话。在玩了很长时间的“瞪眼游戏”后,威尔主动开口讲话了。有的人觉得打 破沉默的这个时候治疗才开始,在我看来,当他们彼此沉默陪伴时,治疗已经开始了。

接着老师谈到他认识的一个人本主义心理咨询师面对沉默不语 的来访者是怎样做的,他对来访者说:也许你现在还没有准备好要说些什么?那也没有关系。我很高兴在这里陪着你。我听了也很受触动,单单这几句话就包含了共 情,无条件的接纳和耐心的陪伴。如果心理咨询师能做到这一点,我想单是他陪伴来访者坐着就能让来访者感到安心。

在《村上春树,去见河合隼 雄》一书,对心理咨询师河合隼雄的评价,用村上自己的话说:“不过,在那样的状态下,与河合先生面对面谈着各种事情时(几乎没有谈到小说的事),头脑里却 感觉到好像痒痒的逐渐放松似的不可思议的温柔感。要说是‘疗伤’或许太过于小题大做,总之好像整个松一口气。河合教授真是一位不可思议的人。和河合先生面 对面谈话,我每次都很佩服,他绝对不会像要以自己的想法去推动对方的样子。反而是很小心注意,不要去妨碍对方的思考和自发性动向。应该说,反而是配合对方 的动向,一点一点地在移动调整自己的位置。例如知道我那时正在写小说,便断然停止可能会诱导我(或我的作品)的发言。并几乎都在谈一些毫不相关的话题。因 此结果,为我启发提示了几种自然思考的可能性,让我可以在那前方,自己发现方向。因此我想在不知不觉间,已经受到他相当多的鼓励。”我对河合隼雄先生真心 佩服。后来,看了他的《心的栖止木》才明白他修炼了一颗安心。什么都不做,容易,但心安则极难。因为我们有那么多的抱负和欲望要满足,我们的心一刻都不曾 止息。真正的爱不是去努力做些什么,而是努力不去做些什么。河合先生努力不去做会诱导村上有关写作小说的发言,就是一种真正的爱。他在《幸福和安心》一文 中说道:与其思考“幸福”,不如“安心”更重要。能够做到“安心立命”的人,彷佛“实实在在扎根于大地之上,只要去到他身旁,他就会让你感到安心”。他又 说:我在美国就见到很多这种类型的人,他们对一切都充满自信。可是却完全缺乏“安心”。在他们身旁,好像连你也坐立不安起来,甚至焦躁慌张起来。

如 果你足够安心,当你什么都不说,什么都不做,也觉得安心时,无论你身边陪伴着的人是谁,你也能够让他感到安心。也许可以这么说:当你心中有光时,才能照亮 他人,点亮别人心中的光。所以,当沉默再次降临在你们之间时,请不要恐惧沉默,不要逃避沉默,试着不去打破这份沉默,试着不去做些什么,不去说些什么,而 只是选择沉默的彼此陪伴,试试看,也许你能感受到这沉默中蕴含的爱与安心,并在这其中“看见”自己,“修炼”自己,在沉默中修炼自己活在此时此刻的安心。

iFunbox备份照片
、先用相机拍一张照片,这个步骤是为了自动生成存放照片的100APPLE目录, 然后从任务管理栏中把 照
片 和 相机 两个程序彻底关闭;
2、4.0以前的照片备份时一般会直接保存100APPLE目录下的所有文件,同时该目录下还有一个,MISC 用于
存放照片对应的缩略图;而在4.0中,老乔把缩略图文件放在了 /var/mobile/Media/PhotoData/100APPLE
下了,所以我们恢复原先备份的时候就需要人工处理一下;
3、下面正式开始恢复备份:
4、用iFunbox把备份中100APPLE下除.MISC目录外的所有jpg和mov文件复制到手机
/var/mobile/Media/DCIM/100APPLE 目录下;
5、把备份中的 100APPLE中的 .MISC目录下的所有文件复制到手机
/var/mobile/Media/PhotoData/100APPLE 目录下;
6、然后把 /var/mobile/Media/PhotoData/ 下的 Photos.sqlite 和 PhotosAux.sqlite 两个文件删除;
7、最后运行 照片 程序,会显示重新建立索引,这样原先的照片和录像就都能显示出来了!
iFunbox备份通讯录/var/mobile/Library/Addressbook
iFunbox备份通短信/var/mobile/Library/SMS

2013年06月19日

日前,美国《Network World》通过读者调查,选出了最受读者欢迎的网络管理工具,我们也将它们推荐给国内的网管员们,希望能助他们一臂之力,使他们轻松排除网络故障。

工具名称:SolarWinds Engineer Edition

网址www.solarwinds.net

推荐理由:有读者说:”在不到一小时的时间内,我从网站上下载并安装了SolarWinds的授权版本。不久后,我就可以制作线路使用报告了,而且线路使用和基本响应时间功能非常棒,此外,数据还被保存下来,使我可以一个星期、一个月或一年后查看数据。”

工具名称:NetWatch套件

公司名称:Crannog Software

网址:www.crannog-software.com/netwatch.html

推荐理由:有读者认为这种软件由简单但却有效的点解决方案构成,这些解决方案在使用和效力上超过了他们所有的更大型的网络管理产品。NetFlow Monitor是另一种解决流量可见性问题的低成本解决方案,但NetWatch使网管员可以通过简捷的点击过程定制创建网络地图。而且,这种软件基本上不需要培训和维护。

工具名称:WhatsUp Gold

公司名称:Ipswitch

网址www.ipswitch.com

推荐理由:用户对它的评价是具有非常昂贵的产品才拥有的很多功能,而价格却非常低廉。还有读者称:”我们能够在几分钟之内安装好软件,自动发现大多数网络设备,并开始向我们的文本电话机发送状态报警。此外,我们还监测不应出现问题的服务和Web内容变化。”

另一位用户还利用它”报告简单的服务水平协议状况,让我的用户无法在真正发生了多少次故障上弄虚作假。”

工具名称:Etherpeek NX、Sniffer Distributed

公司名称:WildPackets、NAI

网址www.wildpackets.comwww.networkassociates.com

推荐理由:一位读者推荐Etherpeek NX 2.0作为一种”价格低廉、功能优秀”的协议分析仪。Etherpeek NX 2.0帮助他解决断续出现的、复杂的应用问题。

另一种读者推荐的工具是来自NAI的Sniffer Distributed。他觉得如果工具包中缺少这种工具,他将无法生存。

工具名称:Packeteer PacketShaper

网址www.packeteer.com

推荐理由:一位读者说:”当用于应用或主机上时,我们对报告和配置的粒度感到满意。它使我们可以找到一条完全拥塞的768K bit/s WAN链路,有效地从它里面得到更多的带宽。”

工具名称:NMIS(网络管理信息系统)

网址www.sins.com.au/nmis/

推荐理由:它可以通过开放源代码GPL许可证免费使用,可以运行在Linux上。有读者说,它提供的支持”比我得到的任何支持都好。”该工具受到欢迎的另一个原因在于它带有仪表板的用户友好的Web界面,支持”在一个页面中以一种简要的、分级的和色块方式显示我所有200台网络设备的状态,从而使我可以轻松地找到问题的根源和范围。”

工具名称:Observer

公司名称:Network Instruments

网址www.networkinstruments.net

推荐理由:这款工具由于”是目前功能最强和最多样化的平台”而成为读者的选择。

工具名称:xsight

公司名称:Aprisma Spectrum

网址www.aprisma.com

推荐理由:有读者喜欢用Aprisma Spectrum公司的xsight来进行故障隔离,他说:”xsight与Attention Software一起使用可以令人信服地解决报警问题并向他人发出寻呼。”他还使用CiscoWorks来管理和维护他们的Cisco网络的防火墙和配置。

工具名称:MRTG

网址:www.mrtg.it

推荐理由:据一位读者称,多路由流量图形工具(MRTG)是其最爱,他说:”MRTG在收集有关网络带宽使用的统计数据和服务器监控方面表现非常棒。”MRTG不仅是免费的,而且还是通过GNU(通用公用许可)提供的。

工具名称:PingPlotter、FREEPing

公司名称: Nessoft、Tool4ever

网址www.pingplotter.comwww.tools4ever.com

推荐理由:PingPlotter是读者推荐的一项价格仅为15美元的Ping和Traceroute工具。一旦出现问题,这位读者就启动该程 序来查找问题出在哪里。FREEping是另一项读者推荐的可以免费下载的Ping工具。一位读者反映,这项工具”虽然非常简单,但却在掌握网络对象的可 达性方面非常有用。”

工具名称:OpenView

公司名称:HP

网址:www.openview.hp.com

推荐理由:HP OpenView受到推荐是因为它可以提供”非常好且非常易好用的映像”。另一个原因是”可以对其进行编程,来做你想要做的任何事情”,尤其是在出现问题时将相关性信息通过E-mail进行报警。

工具名称:NetScout

公司名称:NetScout

网址www.netscout.com

推荐理由:一位读者推荐NetScout,是因为它具有良好的故障检测和性能管理功能。这位读者说:”虽然它是软件和硬件的融合体,但却能与大多数的网络元件(交换机和路由器)协调工作,而且,大家从一个视图就能了解企业的运行状况。”

工具名称:Servers Alive

公司名称:Woodstone

网址:www.woodstone.nu/salive/

推荐理由:一位读者称,它之所以喜欢Servers Alive,是因为它很简单,能够很好地完成网络事件任务和进行状态监控,此外,它

的安装相对来讲也很容易。他经营着一个小网络,发现这个简单而便宜的工具在他的小网络环境里运行得非常好,并可通过邮件组获得支持。

工具名称:SNMPc Enterprise

公司名称:Castlerock Computing

网址www.castlerock.com

推荐理由:一位用户在推荐SNMPc Enterprise时表示:”与其他的大家伙相比,它更加易用,而且相当便宜。它的可扩展性非常惊人,使用它的新版本更容易管理网络管理系统本身。”他 认为该工具的唯一不足就是,它只能在Windows下运行。但你只需花极少的时间就可以习惯这个软件包,一旦习惯了之后,用起来就更加容易了。

工具名称:NexVu

公司名称:NexVu

网址www.nexvu.com

推荐理由:有读者称NexVu”是我们曾使用过的工具之中最有趣的一项工具,它可以是性能监控工具、协议分析工具、RMON探头以及终端服务器……所有这些功能都融为一体”。作为探测工具的备份选择,它非常具有吸引力。此外,它还可以提供有关该读者的Siebel应用系统的实时性能报告。

工具名称:Qcheck、Chariot

公司名称:NetIQ

网址www.netiq.com

推荐理由:有一位读者在推荐NetIQ Qcheck和Chariot时称,Qcheck是一项免费工具,”它超级简单,能够极快地对两个主机之间的网络性能进行检查,与故障检修工具一样棒”。 他说他的求助台使用的就是这种工具。它要求在被测主机上安装endpoint代理。这些endpoint是免费的,而且可供各种各样的系统使用。他说:” 我曾要求在我们企业里的每台台式机和 服务器上装载这样的endpoint,从而减少了故障检修的次数。”关于Chariot,他说,Chariot”可以对我们所能想象得到的任何网络进行压 力测试。它在概念设计和论证方面表现的非常好。添加Sniffer插件之后,就可以使用实际数据对网络进行测试,更不用说它的易用性了。”提醒大家注意的 是,在把这种工具交给未经培训的新手之时,你必须格外小心,因为它”几乎可以把任何网络都给踩成碎片”。