2013年06月19日

1, 从网上下载perl
http://www.activestate.com/Products/ActivePerl/

2,从下面的网站下载MRTG的zip文件
http://mirrors.kingisme.com/MRTG/

3, 在所装的服务器上安装snmp服务:

4, 如果需要监控服务器,且服务器有防火墙,记得将所监控的服务器UDP 161端口打开!

步骤:

1,解压mrtg文件到D:\mrtg-2.13.2目录

2,cmd中cd 到:D:\mrtg-2.13.2\bin

3,运行以下语句,不出任何错时,表示OK了。

perl cfgmaker public@10.91.50.254 --global "WorkDir: D:\mrtgReport" --output mrtg.cfg

public缺省,不要随意改动;

10.91.50.254可设为自己的交换机地址;

workdir为报表生成的目录;

mrtg.cfg是cfgmaker生成的config文件,默认在bin目录

多个设备监控时,运行:

perl cfgmaker public@10.91.50.254 public@10.91.50.253 public@localhost --global "WorkDir: D:\mrtgReport" --output mrtg.cfg

4,为了让MRTG每个五分钟监视一次,在DOS下MRTG/bin目录用下面的命令:

echo runasDaemon:yes>>mrtg.cfg
echo Interval:5>>mrtg.cfg

5, 使用indexmaker生成报表首页:

perl indexmaker mrtg.cfg>D:\mrtgReport\index.htm

6, 运行MRTG:

perl mrtg --logging=mrtg.log mrtg.cfg

如果之前有做错,会提示很多文件找不到之类的错误,重复执行此语句3次左右,就可以清除。

7,将IIS打开,添加网站,将D:\mrtgReport路径设为主目录,连接http试试看!

将MRTG 配置为系统服务

使用windows 2003 resource kit中的Instsrv.exe和srvany.exe。首先安装win2003 rerouse kit

将srvany.exe拷贝到D:\mrtg-2.13.2\bin 目录
1.添加srvany.exe为服务

D:\mrtg-2.13.2\bin>instsrv MRTG "D:\mrtg-2.13.2\bin\srvany.exe"

2. 配置srvany:

在注册表HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/MRTG中,添加一个parameters子键。在该子键中添加以下项目:

Application的字串值,内容为c:\perl\bin\perl.exe —该值为perl程序目录。

AppDirectory的字串值,内容为D:\mrtg-2.13.2\bin\ —-该值为MRTG程序目录。

AppParameters的字串值,内容为mrtg –logging=mrtg.log mrtg.cfg

3.管理工具—服务中,找到MRTG服务,启用服务。

MRTG就可以全天监视制定主机的网络信息了。

最后,保存以上语句为txt文档,每次交换机端口有变或是需增加监控端,重复执行这些语句即可:

perl cfgmaker public@10.91.50.254 --global "WorkDir: D:\mrtgReport" --output mrtg.cfg
echo runasDaemon:yes>>mrtg.cfg
echo Interval:5>>mrtg.cfg
perl indexmaker mrtg.cfg>D:\mrtgReport\index.htm
perl mrtg --logging=mrtg.log mrtg.cfg
2013年06月05日

CISCO DHCP 复习一下

——————————————————————

1.配置DHCP Server
(1)开启DHCP 功能
r2(config)#service dhcp
(2)配置DHCP 地址池
r2(config)#ip dhcp pool ccie1 地址池名为ccie1
r2(dhcp-config)#network 10.1.1.0 255.255.255.0 可供客户端使用的地址段
r2(dhcp-config)#default-router 10.1.1.1 网关
r2(dhcp-config)#dns-server 10.1.1.1 10.1.1.2 DNS
r2(dhcp-config)#lease 1 1 1 租期为1 天1 小时1 分(默认为一天)
r2(config)#ip dhcp pool ccie2 地址池名为ccie1
r2(dhcp-config)#network 20.1.1.0 255.255.255.0 可供客户端使用的地址段
r2(dhcp-config)#default-router 20.1.1.1 网关
r2(dhcp-config)#dns-server 20.1.1.1 20.1.1.2 DNS
r2(dhcp-config)#lease 1 1 1 租期为1 天1 小时1 分(默认一天)
(3)去掉不提供给客户端的地址
注:因为某些IP 地址不希望提供给客户端,比如网关地址,所以我们要将这些地址
从地址池中移除,这样服务器就不会将这些地址发给客户端使用。
r2(config)#ip dhcp excluded-address 10.1.1.1 10.1.1.10 移除10.1.1.1 到10.1.1.10
r2(config)#ip dhcp excluded-address 20.1.1.1 20.1.1.10 移除20.1.1.1 到20.1.1.10
2.配置DHCP Client
(1)配置接口使用DHCP
r1(config)#int f0/1
r1(config-if)#ip address dhcp
3.查看命令:
(1)在服务器上查看哪些地址分配给了哪些主机:
R2#Show ip dhcp binding
4.查看结果
查看DHCP Client 会看到接口 F0/0 的IP 地址为10.1.1.11 并且产生一条指向
10.1.1.1 的默认路由(换成PC 就会变成网关是10.1.1.1),路由器并不需要得到DNS。
在这里,DHCP Server 上明明配了两个地址池,网段分别为 10.1.1.0/24 和
20.1.1.0/24,为什么客户端向服务器请求地址的时候,服务器就偏偏会把10.1.1.0/24
网段的地址发给客户,而不会错把20.1.1.0/24 网段的地址发给客户呢。这是因为服
务器从哪个接口收到DHCP 请求,就只能向客户端发送地址段和接收接口地址相同
的网段,如果不存在相同网段,就会丢弃请求数据包。图中接收接口地址为10.1.1.1,
而地址池ccie1 中的网段10.1.1.0/24 正好和接收接口是相同网段,所以向客户端发
送了IP 地址10.1.1.11。
DHCP 中继

2.png (47.99 KB)

2010-11-26 14:41

如图中所示,当R1 的接口配置为DHCP 获得地址后,那么将从F0/0 发出目的
地为255.255.255.255 的广播请求包,如果R2 为DHCP 服务器,便会响应客户端,
但它不是DHCP 服务器,因此R2 收到此广播包后便默认丢弃该请求包。而真正的
DHCP 服务器是R4,R1 的广播包又如何能到达R4 这台服务器呢,R4 又如何向R1
客户端发送正确的IP 地址呢。
路由器是不能够转发广播的,因此,除非能够让R2 将客户端的广播包单播发向
R4 这台服务器。我们的做法就是让R2 将广播包通过单播继续前转到R4 这台服务
器,称为DHCP 中继,通过IP help-address 功能来实现。
1.R2 配置
(1)配置将DHCP 广播前转到34.1.1.4
注:IP help-address 功能默认能够前转DHCP 协议,所以无需额外添加。
R2(config)#int f0/0
R2(config-if)#ip helper-address 34.1.1.4
2.配置DHCP Server:
(1)开启DHCP 功能
R4(config)#service dhcp
(2)配置DHCP 地址池
R4(config)#ip dhcp pool ccie1 地址池名为ccie1
R4(dhcp-config)#network 10.1.1.0 255.255.255.0 可供客户端使用的地址段
R4(dhcp-config)#default-router 10.1.1.1 网关
R4(config)#ip dhcp pool ccie2 地址池名为ccie1
R4(dhcp-config)#network 34.1.1.0 255.255.255.0 可供客户端使用的地址段
R4(dhcp-config)#default-router 34.1.1.4 网关
(3)去掉不提供给客户端的地址
R4(config)#ip dhcp excluded-address 10.1.1.1 10.1.1.10 移除10.1.1.1 到10.1.1.10
R4(config)#ip dhcp excluded-address 34.1.1.1 34.1.1.10 移除 20.1.1.1 到
20.1.1.10
(4)配置正确地址池的路由
R4(config)#ip route 10.1.1.0 255.255.255.0 34.1.1.3
注: R3 无需做任何配置!
3.查看结果
查看DHCP Client 会看到接口F0/0 的IP 地址为10.1.1.11,那么DHCP 服务器R4
又是根据什么来判断出客户端需要的是哪个网段的IP 地址呢,为什么还是没有错把
34.1.1.0/24 网段的地址发给客户呢。不是说服务器从哪个接口收到请求,就把这个
接口相同网段的地址发给客户端吗?按照之前的理论,应该是发送34.1.1.0/24 的地
址给客户啊。在这里,能够指导服务器发送正确IP 地址给客户端,是因为有一个被
称为option 82 的选项,这个选项只要DHCP 请求数据包被中继后便会自动添加,此
选项,中继路由器会在里面的giaddr 位置写上参数,这个参数,就是告诉服务器,客
户端需要哪个网段的IP地址才能正常工作。中继路由器从哪个接口收到客户的DHCP
请求,就在option 82 的giaddr 位置写上该接收接口的IP 地址,然后服务器根据giaddr
位置上的IP 地址,从地址池中选择一个与该IP 地址相同网段的地址给客户,如果
没有相应地址池,则放弃响应,所以,服务器R4 能够正确发送10.1.1.0/24 的地址
给客户,正是因为R2 在由于IP help-address 的影响下,将giaddr 的参数改成了自己
接收接口的地址,即将giaddr 参数改成了10.1.1.1,通过debug 会看到如下过程:
*Mar100:28:36.666: DHCPD: setting giaddr to 10.1.1.1.
*Mar100:28:36.666HCPD:BOOTREQUESTfrom0063.6973.636f.2d30.3031.322e.
6439.6639.2e63.3638.302d.4661.302f.30 forwarded to 34.1.1.4.
从上面debug 信息可以看到R2 是将giaddr 改成 10.1.1.1 后发中继发向34.1.1.4
的,需要知道的是,经过中继后发来的DHCP 请求包如果giaddr 位置不是某个IP 地
址而是0.0.0.0 的话,服务器是丢弃该请求而不提供IP 地址的。
注:当服务器上存在10.1.1.0/24 网段的地址池时,服务器要将该地址池发送给客户,
就必须存在到达10.1.1.0 网段的路由(默认路由也行),并且客户端必须位于该路由的
方向,如果方向不对,该地址池也是不能够发给客户使用的。
不同VLAN 分配不同地址

3.png (69.93 KB)

2010-11-26 14:41

如图3 中所示,两个DHCP 客户端分别位于交换机上两个不同的VLAN,交换机
上的VLAN 接口将作为他们的网关,R3 是DHCP 服务器,这两个客户端必须得到不
同网段的地址,否则无法与外网通信,在这种情况下,服务器R3 也必须正确为R1
分配10.1.1.0/24 网段的地址,必须为R2 分配20.1.1.0/24 的地址,配置如下:
1.配置DHCP Server
(1)开启DHCP 功能
R3(config)#service dhcp
(2)配置DHCP 地址池
R3(config)#ip dhcp pool ccie1 地址池名为ccie1
R3(dhcp-config)#network 10.1.1.0 255.255.255.0 可供客户端使用的地址段
R3(dhcp-config)#default-router 10.1.1.1 网关
R3(config)#ip dhcp pool ccie2 地址池名为ccie1
R3(dhcp-config)#network 20.1.1.0 255.255.255.0 可供客户端使用的地址段
R3(dhcp-config)#default-router 20.1.1.1 网关
(3)去掉不提供给客户端的地址
R3(config)#ip dhcp excluded-address 10.1.1.1 10.1.1.10 移除10.1.1.1 到10.1.1.10
R3(config)#ip dhcp excluded-address 20.1.1.1 20.1.1.10 移除 20.1.1.1 到
20.1.1.10
(4)配置正确地址池的路由
R3(config)#ip route 10.1.1.0 255.255.255.0 30.1.1.1
R3(config)#ip route 20.1.1.0 255.255.255.0 30.1.1.1
2.配置交换机
(1)配置相应接口信息
sw(config)#vlan 10
sw(config-vlan)#exit
sw(config)#vlan 20
sw(config-vlan)#exit
sw(config)#int f0/1
sw(config-if)#switchport mode access
sw(config-if)#switchport access vlan 10
sw(config-if)#exit
sw(config)#int f0/2
sw(config-if)#switchport mode access
sw(config-if)#switchport access vlan 20
sw(config-if)#exit
sw(config)#int vlan 10
sw(config-if)#ip address 10.1.1.1 255.255.255.0
sw(config-if)#ip helper-address 30.1.1.3 单播前转DHCP 广播到30.1.1.3
sw(config-if)#exit
sw(config)#int vlan 20
sw(config-if)#ip address 20.1.1.1 255.255.255.0
sw(config-if)#ip helper-address 30.1.1.3 单播前转DHCP 广播到30.1.1.3
3.配置DHCP Client
(1)配置R1
r1(config)#int f0/1
r1(config-if)#ip address dhcp
(2)配置R2
r2(config)#int f0/1
r1(config-if)#ip address dhcp
4.查看结果:
按上述配置完之后,客户端R1 的F0/0 便能够收到地址10.1.1.11,客户端R2 便
能够收到地址20.1.1.11,然后就可以全网通信。在上述的情况下,服务器R3 能够
正确为R1 分配10.1.1.0/24 网段的地址,能够正确为R2 分配20.1.1.0/24 网段的地址,
同样也是因为交换机在收到R1 的DHCP 广播包后,将giaddr 的参数改成了10.1.1.1,
收到R2 的广播包后,将giaddr 的参数改成了20.1.1.1,所以最后服务器R3 能够根
据 giaddr=10.1.1.1 的包分配10.1.1.0/24 的地址,根据giaddr=20.1.1.1 的包分配
20.1.1.0/24 的地址。
IP 与MAC 地址绑定
在配置DHCP 时,地址池中除了移除掉的IP 地址之外,所有的地址都会按顺序
分配给客户,所以客户机得到的 IP 地址是无法固定的,有时需要每次固定为某些
PC 分配相同的IP 地址,那么这时就可以配置DHCP 服务器以静态将IP 地址和某些
MAC 绑定,只有相应的MAC 地址才能获得相应的IP 地址。在Cisco 设备上静态将
IP 与MAC 绑定的方法为,需要将某个IP 地址绑定给MAC 地址,就为该IP 地址单独
创建地址池,称为host pool,地址池中需要注明IP 地址和掩码位数,并且附上一个
MAC 地址,以后这个IP 地址就只分配给这个MAC 地址,所以host pool 只能有一个
IP 地址和一个MAC 地址,如果需要为多个客户绑定IP 和MAC,就必须得单独为每
个客户都配置各自的host pool,还要注意的是,在host pool 中,MAC 地址的表示
方法和平常不一样,比如一个主机网卡的MAC 地址为aabb.ccdd.eeff,在地址池中,
需要在前面加上01 (01 表示为以太网类型),结果为01aa.bbcc.ddee.ff
1.配置host pool:
(1)配置pool 名
r1(config)#ip dhcp poo ccie
(2)配置IP 地址
r1(dhcp-config)#host 10.1.1.100 /24
(3)配置与该IP 地址对应的MAC 地址
r1(dhcp-config)#client-identifier 01aa.bbcc.ddee.ff
2.查看配置结果:
(1)查看服务器地址分配状态
r1#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
10.1.1.100 01aa.bbcc.ddee.ff Infinite Manual
r1#
说明:从以上结果可以看出,IP 地址10.1.1.100 已经手工与MAC 地址aabb.ccdd.eeff
做了绑定,以后只要MAC 地址为aabb.ccdd.eeff 的客户端请求IP 地址时,才能获得
IP 地址10.1.1.100。
DHCP 安全ARP

4.png (61.55 KB)

2010-11-26 14:41

Cisco 设计的DHCP 安全ARP 也许不是绝对的安全,但也起到了一定的作用,原
本设计为一个需要计费的公共热点PVLAN (公共无线场所),如图4 中所示,R3 为
DHCP 服务器,为付费的R1 提供正确IP 地址以提供网络服务,当服务器R3 为客户
端R1 提供IP 地址 10.1.1.2 之后,就已经记住了它的MAC 地址,在正常情况下,如
果R1 退出,服务器是不知道的,并且当网络中有欺骗者接入后,也可冒充10.1.1.2
这个地址进行上网,当然R1 和R2 的MAC 地址肯定是不一样的,如果这时服务器
R3 由于自动更新ARP 表的MAC 地址,就能够顺利让R2 上网。
基于上述原因,需要在服务器R3 和客户端R1 之间提供某种安全机制,即服务器
定期ARP 讯问10.1.1.2 是否还存在,在讯问时,只有R1 能够回答。
在完成这种机制,需要两个feature 来支持,第一个是Update Arp,在地址池模
式下开启,这个feature 便是定期讯问网络中DHCP 客户端的;第二个是Authorized
ARP (ARP 授权),只能在以太网接口下开启,功能是禁止该接口下通过ARP 自动更
新和学习MAC 地址,这样一来,接口下将不能有手动配置IP 的设备接入,因为手
工配置IP 接入后,服务器不会更新自己的ARP 表,也就无法完成到新设备的二层
MAC 地址封装,也就无法和新设备进行通信,只有合法的DHCP 客户端才能正常通
信,所以,如果为远程客户端分配IP 地址,就无法做这样的保护,并且到远程客户
端的下一跳必须是自己的客户端,因为如果不是,是无法通信的,因为ARP 不存在
到它的条目。
1.配置安全ARP:
(1)开启DHCP 功能
R3(config)#service dhcp
(2)配置DHCP 地址池
R3(config)#ip dhcp pool ccie1 地址池名为ccie1
R3(dhcp-config)#network 10.1.1.0 255.255.255.0 可供客户端使用的地址段
R3(dhcp-config)#default-router 10.1.1.1 网关
R3(dhcp-config)#update arp 开启定期ARP 讯问
(3)去掉不提供给客户端的地址
R3(config)#ip dhcp excluded-address 10.1.1.1 10.1.1.10 移除10.1.1.1 到10.1.1.10
(4)在接口下开启Authorized ARP
R3(config)#int f0/0
R3(config-if)#Router(config-if)# arp authorized 禁止动态更新ARP
R3(config-if)# arp timeout 60 60 秒客户无应答则删除ARP 条 目
说明:通过以上配置之后,当DHCP 客户端从服务器获得IP 地址后,服务器便会定
期查讯该IP 地址,如果60 秒没有回答,便从ARP 表中删除该条目。
DHCP 监听

5.png (61.6 KB)

2010-11-26 14:41

如图5 中所示,客户端R1 只有正确从服务器R3 中获得10.1.1.0/24 网段的IP
地址才能够正确上网,如果当网络中出现另外一台错误的DHCP 服务器(图中R2),
R2 向客户端R1 发出20.1.1.0/24 的地址,那么将导致R1 网络中断,在这样的情况下,
就需要禁止不合法的DHCP 服务器向网络中提供DHCP 服务,这就需要DHCP 监听
(DHCP Snooping)。DHCP Snooping 是在交换机上完成的,如上图中,只要告诉交换
机,只有F0/3 发来的DHCP 应答地址才转发给客户端,其它接口发来的应答地址统
统被丢弃。要做到这一点,就要告诉交换机,F0/3 接口是它可能信任的DHCP 地址,
其它接口都是不可信的,不能提供DHCP 应答,那么在实现这个功能时,就需要将
交换机上的接口分为可信任接口和不可信任接口两种,默认交换机全为不可信任接
口,也就是说交换机开启DHCP Snooping 之后,没有任何一个接口上的DHCP 服务
器能提供服务。在交换机上配置DHCP Snooping 时,必须指明在哪个VLAN 上进行
监听,其它没有监听的VLAN 不受上述规则限制。
1.交换机上配置DHCP Snooping
注:交换机上所有接口全部划入VLAN1
(1)在交换机上开启DHCP Snooping
sw(config)#ip dhcp snooping 开启DHCP Snooping
sw(config)#ip dhcp snooping vlan 1 在交换机上启用DHCP Snooping
(2)将相应接口变为信任接口(默认全部为不可信)
sw(config-if)#ip dhcp snooping trust
2.查看命令:
(1)查看dhcp snooping
Sw#sh ip dhcp snooping
说明:通过以上配置之后,只有交换机F0/3 接口上(信任接口)的设备能够应
答DHCP 请求,而其它所有接口,比如R2 过来的DHCP 应答是会被丢弃的。但是你
会发现,在这之后,R1 还是无法获得服务器R3 发来的DHCP 地址。这是因为开了
DHCP Snooping 的交换机默认会产生中继效果,即将DHCP 请求包的giaddr 的参数改
成0.0.0.0,交换机的这种中继效果是无法关闭的,当一个服务器收到中继后并且将
giaddr 设置为0.0.0.0 而不是IP 地址的请求包时,默认是要丢弃该数据包而不作应答
的,所以服务器R3 丢弃了该请求数据包。要让客户R1 能够正常收到DHCP 提供的
IP 地址,就要让DHCP 服务器对即使giaddr 为0.0.0.0 的请求包也作出应答。配置如
下:
R3(config-if)#ip dhcp relay information trusted
最后,从上图中,如果R3 本身还不是DHCP 服务器,如果DHCP 服务器还在远程
网络,需要R3 提供中继并转发该请求包到服务器的话,那么R3 除了在接口下配置
ip dhcp relay information trusted 之外,还必须配置ip helper-address,两者缺一不可。

2013年05月31日

现在世界上所有的黑客猜密码的时候,都会试试“对马电池订书钉”(correcthorsebatterystaple)这个密码。可能各位网友看了题图和这句话后,会有点懵。其实“对马电池订书钉”出自 XFCD 发表的漫画名为“密码强度”……

“对马电池订书钉”图解:

但是……这幅漫画显然太低估黑客们的实力了:

本周,Ars 网站邀请了三位黑客破解了16,000多个 hash 过的密码成功率90%!

黑客告诉你,你的密码不是因为又臭又长就安全,而是因为没人惦记你,所以暂时安全。
咳,然后是献给好学网友们的正文:

3月,博客作者 Nate Anderson,下载了一份侧漏的暴库密码表,内含超过16,000个 hash 过的真实密码,经过百度知道的简单培训,结果只花了大概能煎3个蛋的功夫,破解了其中一半的密码。这给所有人提了一个警醒:如果一个没有经过任何训练的网友,就能达到这个程度,想一下一个职业黑客能搞出多大动静。

不用自行脑补了,我们请来了三位职业黑客,使出浑身解数,来破解 Anderson 练手的那份密码表,展开了终极 PK。你会看到包括数字,大小写,标点符号的长密码是如何被快速破处出的。

这份密码表里总共有16,449个 hash 过(MD5)的密码。任何负责的网站,都不会明文存储用户的密码信息,而是用 MD5 加密,这种加密过程是不可逆的,也就是说,就算拿到MD5密文,也不可能直接“反求”出原文。比如“passwd” 被 hash 过以后,密文是“5f4dcc3b5aa765d61d8327deb882cf99”。

虽然 Anderson 的47%破解率已经非常不错,但对于职业黑客来说,还是不足挂齿。为了证明这点,我们请来他们来演示一下,说真的,他们没有让我们失望。就算三个里成绩最差的一个——他用最弱的硬件,花了一个小时,用最小的字典,中间还接受了一次采访,也搞定62%的密码,而最好成绩是90%。

这个三人黑客团队包括一名密码破解软件专家,一名安全顾问,和一名匿名自由黑客。其中最牛的一名黑客是来自S.C.G., 使用一台只配置一块 AMD 7970 GPU 的家用电脑,花了20小时破解了90%,共14,734个密码。免费 GPU 密码破解软件 oclHashcat-plus(参加测试的黑客都使用这款软件)的开发负责人,Jens Steube 也取得了不俗的成绩,他在一个多小时的时间里,用一台双 AMD 6690 GPU 的机器,搞定了 13,486个密码,占全部的82%!另外一名诨号 moniker radix 的黑客,用一块 AMD 7970,搞定62%的密码,也差不多花了1个小时,如果不是被我们打扰接受采访,他应该能取得更好的成绩。

黑客穷举破解密码所用的“字典”里,包括了很多密码明文,这些常用的密码字符组合,来自于很多大型网站的用户数据中,包括像“123456”,“password”之类,这些属于弱暴了的密码,还有稍微好一点的,像“p@$$word”、“123456789j”、“LETMEin3”等也同样不堪一击。在这些字典里,你还能找到一些理论上强悍的密码,比如“LOL1313le”、“1368555av”、[Oscar+emmy2]之类:

截图里展示了一部分黑客字典中的密码组合。像这次参与PK的黑客手里的字典,有接近1亿种常见密码。但像“momof3g8kids”、“Coneyisland9/”这样的密码,虽然不在他们的字典里,一样没能幸免,他们是怎么做到的呢?答案来自于两个方面:网站没能保护用户密码的 MD5 信息,和用户没有使用足够强壮的密码。
嗖嗖地,妥妥的

“这些弱暴的密码”radix说道,他不愿意透露真名,“说明他们真的不是很在乎自己的密码安全,别用 MD5 加密,这对他们来说其实并不难”。

MD5 算法,是一种快速简单的的“报文编译”方法,由它生成的密文,也是黑客最喜欢拿来练手的对象,一块 GPU 显卡,就能在1秒钟内遍历8亿个字符组合,比较起来看,加密过程就费时费力的多,比如在苹果 Mac OSX 系统,和大多数基于Unix的系统上采用的 SHA512 加密算法,一个明文密码需要经过5,000次 hash。这点小障碍也就让一块 GPU 每秒少跑了2,000次而已,类似的还有 bcrypt,scrypt,和 PDKDF2。

另外一个漏洞就是用户自己,选择好记的单词当作密码,好记就代表容易被破,比如“momof3g8kids”看上去好记又难猜,但实际上,“mom”、“kids”都是每一个黑客手里必备的破解词汇。越来越彪悍的硬件和软件,能让黑客轻而易举地不断尝试这些词汇的各种组合,除非用户细心设计,否则好记的密码就是正中黑客下怀。

而且必须指出,这次三名黑客并不知道这份密码表是从哪个网站得来的,这就等于封杀了他们的一项技能。一般,当得到一份 hash 过的密码表后,他们第一个步就是“去那个网站看看他们的密码设置要求和强度”radix说道,如果黑客知道这个网站的密码强度和其它约定,这就大大减小了他们的工作强度,让黑客可以有针对性地采取破解策略。
破解步骤

要细说他们是如何破解强密码的,那就需要对他们三个人的方法和策略进行比较分析,因为他们的硬件和方法都不太一样,也不能说得哪个人的水平更高一些,打个比方,这是一场游戏通关,那么一关定比一关难,第一轮破解,一般能搞定其中50%的密码,后面的成功率就越来越少,到最后的阶段,他们只能纯靠运气,得到几百个密码明文。

举例来讲,在 Goseney 动手的第一阶段,只花了16分钟,就干掉了10,233个 hash 密文,也就是62%的样子。他先用6位以内的密码开路,用暴力穷举法对付1~6个字符的密码组合由95个字符组成的密码,包括26个小写,26个大写,10个数字,33个符号。猜完一轮这样的排列组合(956 + 955 + 954 + 953 + 952+95 个),只花了2分32秒就得到了1,316个正确结果。

当密码长度超过6位,Gosney 开始改变策略,用精心挑选的字典进行穷举。因为随着密码长度的增加,字符组合成指数级增长。1小时能搞定所有6位密码,但要遍历更长的密码,可能要花费数周,甚至数年。所以,对于暴力穷举破解的方法,有一种说法叫:“长度防火墙”:

暴力穷举可以很好地对付6位以下的密码,但对于8位以上的密码,就算开动 Amazon 的 EC2 云计算也无能为力。

黑客当然不会一条道走到黑,Gosney 下一步的暴力穷举将只针对7~8位,全小写字母的情况。这将大大减少穷举所需时间,而且收获也不少,成功破解1,618个密码。接着他继续尝试7~8位全大写的情况,又得到了708个结果。因为他们的排列组合是268+267,每一步只许41秒。最后,他尝试全部由数字组成长度从1~12位的情况,得到312个密码,耗时3分21秒。

用光了以上入门级暴力破解法,黑客 Gosney 这才开始拉开架势,拿出自己潜心调教多年的“字典”,通过在 HashCat 软件中内置的“best64”规则(一种基于密码统计学的破解行为模式),他能在9分04秒内,跑完了6,228个 hash 密文,然后他利用上一步破解所得到的所有明文密码,通过另一组名叫“d3ad0ne”的规则过滤获得“字符组合特征”,让他在一秒钟内,又得到了51个密码明文。

“正常情况下,我先用暴力穷举法,完成1~6位的密码破解,因为就算是单 GPU,也能几乎瞬间完成用 MD5 加密的密码”。Gosney 在邮件中解释道:

因为这一步很快就能完成,所以,我的字典几乎都是6位以上的密码组合。这可以让我节省不少磁盘空间,也可以利用GPU的蛮力,加快我之后用字典破解的速度。对于数字组合也是这样,我可以很快破解纯数字的密码,所以在我的字典里没有任何数字组成的密码,然后才是我的字典文件+bast64规则文件。我们的目的就是先挑软柿子捏。

从简单密码下手对于被“掺盐”(cryptographic salt)的密码特别有用。“掺盐”是用来对付黑客的“彩虹表”(一种明文和密文对应的穷举表)和类似的字典技术,掺盐就是在用户密码后面,再加上随机字符,然后再 hash 的技术。除了防御彩虹表,掺盐也减慢了暴力穷举法的破解速度。

但“掺盐”的关键在于,只有在掺入不同的盐巴(字符)情况下,才能明显减慢破解速度。这就意味着,掺盐的效果,会随着破解的进行而逐渐降低。黑客可以通过破解简单密码的结果,逐渐排除盐巴的干扰。当然,这次PK活动使用的密码没有被掺盐。

经过第一轮的摧枯拉朽,10,233个hash密文已经告破,进入第二个阶段,黑客开始采用“混合破解的策略”。就和之前提到的游戏通关的比喻一样,随着难度的增大,第二阶段需要花费的时间会大大增加,而且战果也会减少,准确的说,只有2,702个密码告破,耗时5小时又12分钟。

就和名字一样“混合破解法”,结合了暴力穷举和字典破解两种路数,这大大拓展的字典所涵盖的组合种类,并且把组合数量控制在能接受的范围里。第一轮,黑客在所有字典条目的后面,加上两个随机字符包括符号和数字,这样在11分25秒内,有破获585个密码。第二轮加上3个随机字符,耗时58分钟,得到527个结果,第三轮再接再厉,加上四个随机数字,25分钟内又得到435个密码明文,第四轮,加上四个随机字符包括一个数字和三个小写字母,再斩获451个密码明文。

面对可观的战果,Gosney 认为,这只用了一张GPU卡的结果而已。

“你注意到我们只加上了2~3个长度的随机字符,但到4个长度,我们只能用数字了,因为只有1块显卡的 GPU,想要跑完+4位随机字符和数字的组合会耗费很长时间,所以我只能放弃。”

毫无疑问,说这话的 Gosney,已经用这台 25GPU 交火的怪兽机搞过更长的密码,他在去年10月透露了这台名叫“镭池”机器:

因为 GPU 的并行运算能力是随着运算单元的增加而线性增长,这让 Gosney 很好地利用这些资源,让他能在每秒获得350亿次的运算速度,去挑战微软的 NTLM 加密算法。

第二阶段,Gosney 继续采取差不多的战术。在这个阶段结束的时候,他总共斩获 12,935个密码明文,也就是完成了78.6%的破解工作,总共耗时5小时28分钟。

很多黑客都知道有一个有趣的现象,就是在同一个网站下,用户的密码会非常相似…尽管这些用户互天南海北,互相都不认识。通过已经得到大部分的密码,黑客开始分析这个未知网站的密码特征,来模仿这个网站用户的行为,去破解余下的密码。通过 Markov Chains(一种统计学模型),黑客用 HashCat 生成了一份新的密码词典,Gosney 认为,这本字典是高度优化和智能的,大大缩减了所需的字符组合数量。

初级的暴力穷举词典包含像“aaa”,“abb”这样的组合。但经过 Markov Chains 调教过的字典,通过分析已有密码明文,列举出了最有可能的密码组合。“Markov破解法”,可以把7位字符组合难度从 957降低到657,大概可以节省7个小时。一般来说,字符组合有“首字母大写,中间小写,数字在尾部”等显著特点,Markov 破解法的命中率,几乎可以和暴力穷举的命中率一样高。

“这让你的破解方法更具针对性,因为你对于具体的网站,有了具体的目标”,Gosney 说道,当你获得了这些组合特征,你就能顺藤摸瓜直捣黄龙。

Gosney 花了14小时59分钟,完成了第三阶段的破解工作,得到了1699个密码。有趣的是,在这个阶段,前962个密码花费了大概3个小时,但后面的737个密码却花费了12个小时。

黑客 radix 手里有2009年,线游戏服务商 RockYou 的被 SQL 注入攻击后,暴出的数据库,内含140万个密码明文,另外还有一份货真价实的更大的密码词典,但魔术师不会轻易透露机关,PK 中 radix 也没有拿出这份字典。

猎杀哈希

光用 RockYou 的暴库数据,radix就能取得和新手 Anderson 差不多的战绩,获得4900个密码明文,大概占总量的30%。接着,他用这份数据,切掉后四位,加上四位随机数字,HashCat预估需要2个小时才能跑完,这要比radix预计的长,但他跑了20分钟以后,也得到了2,136个密码明文。接着他又尝试了1~3位数字的组合,再次得到259个结果。

“分析,直觉,加一点点魔法”,radix 说道,“提取模式,测试组合,把结果放入字典继续尝试,等等”,如果你知道你手里的密文的来源网站,你就能猜到和那个网站有关的领域里的词汇,然后你就能搞到你想要的结果。

于是 radix 从已经得到的7,295个密码分析,发现了一些明显的特征,比如三分之一的密码由8个字符组成,19%的是9个字符,16%有6个字符,69%由“字母+数字”组成,他还发现62%的密码全是小写字母和数字组成。

这些信息给了他继续破解的阶梯。后面,他采用“掩码破解法”,这和之前的“混合破解法”颇为相似,但要比暴力穷举节约大量时间,尝试“全小写字母+数字”的1~6位密码组合,得到341个密码。但8位“全小写+数字”的组合所需时间,还是超出 radix 的期望,虽然复杂程度从528减到了268,就 radix 手头的机器来说,这就是6小时和1个小时的区别,但他还是跳过了这一步。

于是 radix 改变了策略,使用 HashCat 内置的5,120种特殊规则,例如把“e”替换成“3”,删掉每一个单词的第一个字母,或者每隔一个字母加一个数字……在38秒之内,又破了1,940个密码。

“这就是黑客的乐趣所在”他说,“就像打猎,但你找的不是动物,而是哈希密文”。但他也承认密码破解技术的阴暗面,游走在道德的边境,如果多走一步,后果严重。

当另一位黑客 Steube 发现了一个密码组合:“momof3g8kids”的时候,忍不住说道:“这就是用户的密码逻辑,但我们并不知道这种逻辑,这给了我一些灵感,这就是我们为什么要盯着屏幕看结果”。

“momof3g8kids”被破解的原因是,Steube 采用了“词典联合破解法”,他用多本词典的种的条目组合,发现了这个密码,其中,“momof3g”在一本1110万的大词典中收录,而“8kids”在另外一本较小的词典中。

“这太酷了!”他引用了本文开头,xkcd 的那副著名的漫画说道:“告诉“对马电池订书钉”,这不灵”。

PK 过程中,最让人惊异的就是某些破获的密码明文,包括:“k1araj0hns0n”,“Sh1a-labe0uf”,“Apr!1221973”,“Qbesancon321”,“DG091101%”……甚至包括了像“all of the light”这样包含空格的密码。Steube 还在结果中看到了“Philippians4:6-7”和“qeadzcwrsfxv1331”,他表示:“如果不是用暴力穷举,是不可能猜到这些密码的”。

GPU 通用计算出现以后,很少有黑客在攻击中采用“彩虹表”(rainbow tables),这种过时的方,需要容量巨大的表文件。

当Reputation.com看到从自己网站被攻击后泄露的用户信息后表示,虽然看上去用户的密码加密信息不可能被破解,但我们还是立即通知用户更改自己的密码。

所有公司都应该认识到,就算用户密码被 hash 过,但发生信息泄露以后,用户应该立即更换密码,特别是那些在不同网站,却用相同密码的用户。黑客通常能从被暴库的密文中,破解60%~90%的密码。

必须承认,采用“掺盐”hash用户密码的的网站确实能减缓大量 hash 信息被破解速度,但“掺盐”并不能阻挡对单个 hash 密文和少量密文的破解,换句话说,如果黑客针对的是具体的某个帐户,比如银行经理,某位名流,“掺盐”也无能为力。

这三位黑客的高超技艺,也指出用户需要加强自己的密码保护意识。许多世界500强企业,都对雇员邮件帐号,和访问公司网络的密码有严格的规定,这大大增加了黑客攻击的难度。

“在企业行业领域,这确实不容易”,radix 说道,“当我给一家企业做密码安全漏洞检查的时候,那简直了,我可能跑三天三夜也得不到一个字符。”

如果网站可以像那些大企业一样采取相同的安全策略,那用户密码就会安全很多。但这对于用户来说,要去记住11位的随机密码确实有点痛苦。

黑客破解 hash 密文的效率,与网站得知用户信息被泄露以后的反应,形成鲜明的对比。就在上个月,LivingSocial 披露黑客攻破了他们的数据库,暴出了了5千万个用户姓名,地址和密码信息的hash内容,但网站负责人显然低估了这所带来的风险。

网站 CEO Tim 说:“虽然用户的密码已经被加密,而且很难被破解,我们的预防措施也能保证用户的数据是安全的,但我们还是通知大家,更新自己的网站密码”。

事实上,几乎没有什么能阻止黑客去解密 hash 信息。LivingSocial 所用的 SHA1 算法,在黑客面前不堪一击。虽然他们也宣传用户的 hash 是被“掺盐”的,这也无法保证用户信息的安全。

由此课件,Intel 最近上线的一个网站,宣称能测试你的密码强度,是多么的不靠谱,它竟然评估说“BandGek2014”需要6年时间才能被破解,可笑的是,这个密码可能在黑客手里,大概是被首先拿下的。问题的关键在与,大部分网站的密码强度要求,正好落在黑客的能力范围之内。

“你们已经看到了,我们在1小时之内破出了82%的密码,意味着有13,000人没有选择一个好密码,他们总以为自己选了一个好密码,但正相反,那些密码太糟糕了”。

2013年05月24日

小玄纸:
我是你爹。
当你爹写这封信的时候,是你出生满月的这一天,你爹记住了你满月这一天,缺记错了你打防疫针的那天,你爹请好假了,准备带你出门的时候却发现记错日子了还有两天才可以去打防疫针。然后你妈妈就歇斯底里的咆哮了你爹一通,然后你爹也只能微笑着陪着你愤怒的妈妈,在妈妈心里,你爹的位置瞬间降到了第三位。
你爹现在30岁,你30岁的爹,突然想写一封信给的你。
你爹7年前遇到了你亲爱的妈妈,然后穿越920公里来到了上海这个传说中的著名的城市,然后娶了你妈妈。然后有了你。

在这之前你爹有过几个女朋友,最后都成了你爹记忆深处的魅影。偶尔会想起,但是看到你温柔的妈妈就瞬间温暖了。(其实这些都是违心写给你妈妈看的,你爹只想告诉你,没有失恋过的男人,不会成为成熟的男人;没有失恋过的女人,不会成为有韵味的女人。)
你是男人,应该可以理解你爹的痛苦,你爹不想掩饰什么,况且在你爹看来,父子即兄弟,咱哥俩无话不谈。我还打算你以后直接叫我名字就行。

你肯定遗传了你爹多情善感的基因,因此你结婚之前肯定会遇上很多恋爱。你会伤害一些女人,然后被一些女人伤害,然后在伤害与被伤害中学会爱情。
你爹把这些叫做成长,一个男人的成长。
24前修身,24后修行。
女人的武器是身材、胸、眉眼和脸蛋,男人的武器却是头脑。这一点,你要牢记。

关于女人和爱情
关于这一点,你爹必须多说两句,这纯粹是父子话题,记得不要让你妈看见。
女人是一种动物,她们有时候是猫,灵诡,多情,性感;有时候是狐狸,美艳,妖冶,充满魅惑。但大多数人时候,她们会变成未知生物,你不要试图用达尔文的进化理论或者单纯的生物学观点来判断她们的行为。那很危险。
她们渴望爱情,容易意乱情迷,却又能在关键的时候万分清醒。如果你偷看过你爹的博客就会发现,你爹总结出很多理论。比如:
女人突然爱上你和突然不爱你的速度一样快。
世界上根本没有第三者。
要挽回一个变心的女人要付出比失去她更惨重的代价。
处女心比处女身要重要得多。
世界上没有狠心的女人,只有变心的女人。(这句话是古龙说的,借来用下。)
当然,这些,你都要自己经历过才能真正理解。我绝对不会反对你早恋,只要在未婚之前,不搞大别家姑娘的肚子就好。顺便说下,你爹的初恋在17岁那年。那女孩是一个瘦瘦的体育生,有着当年你爹认为的最完美的笑容的女孩。
还有,你爹总结了一些守则,应该告诉你。
第一,永远不要伤害一个爱你的女人。不管你喜不喜欢她。这是道德层面的问题,也是我们家男人的优良传统,你记得告诉你儿子,也就是我孙子,世世代代传承下去。
第二,结婚前认认真真谈几次恋爱。这样的恋爱跟性无关,跟金钱无关,甚至跟婚姻无关。你好好爱她,她也会好好爱你。相爱本身就是功德。两个人在一起什么都对,两个人不在一起就什么都不对。
第三,爱情是什么?爱情是见面时欢喜,不见时想念,包容和慈悲。 最好的爱情,始终是温润的。

关于sex
你爹我基本上是自学成才。在我们那个年代,德艺双馨的苍井空是启蒙老师,马赛克是天敌,现在我比较喜欢Rio。哦,对了,这算是历史知识,你记下来。我也会帮你保留一些非物质文化遗产给你,写论文的时候用。
但是,作为你爹,我有责任告诉你你想知道的。
记住,一点,永远:在床上的时候,保护好你的女人,同时也是保护你自己。

关于读书
你爹喜欢读书。

你爹读的书从卡耐基的《人性的弱点》、到《怪诞行为学》、《我喜欢你你知道吗》都有,专业的比如《CISSP》《CCIE》、《Military toxicology》、到好玩的《悟空传》、《二号首长》可以看出你爹的确涉猎广泛,没事就读好多书。因为开卷有益,这点总不会错的。
你看,你爹总是这样充满斗志,这一点你要跟我学。
对于男人来讲,最重要的是爱情和家庭。
其次,是理想和事业。
最后才是下半身。
不要让下半身主导你的思维。牢记。
这一点,你只要读了足够多的书,我相信,绝对可以做到。

关于工作
你爹是工作狂。
没有女人的时候,我把工作当成女人;有女人的时候,我把工作当成另外一个女人。
有一天,我自己惊讶地发现,我真的达到了这样的境界。
你爹如今是个Engineer,而且是个Security Engineer,你爹从前一直把在某安全部门服务过当做荣誉。的确,你爹的那段经历是无数人所没有经历过的因为大家美国大片看多了,把那种人都当神人崇拜,其实也不过如此,你爹仍然要出来找工作赚钱养家。你爹有正式身份的地方有985高校和世界顶尖的网络公司,你爹也希望你自己努力进入最优秀的组织。
还有你爹要告诉你的是,在工作的世界里,你永远都是一颗螺丝钉,对于亲密的爱人,和挚爱的家人,你永远都是唯一的。你要对工作负责,但也要对自己的生活负责。

关于梦想
你爹我对你并无所求,我给你23条染色体,给你一个名字,把你养大。
没错,我是你爹。但你是你,我是我。。
我不会强加给你我的梦想,那是我的事,我也会自己完成它。
你要有你自己的梦想,我不管你励志要做总统还是流浪诗人,我都会尊重你。

我给了你生命,但我给了你之后,生命就是你的了。

我肯定不会跟你说“赢在起跑线上”之类的屁话,但还是希望你做一个四有新人:

有一颗坚定的内心,可以不畏世俗,

有一样适合泡女孩子的特长(比如吉他之类),

有一个败家的爱好(比如茶、红酒或者单反),

有一个你爱到肯为之放弃一切的女孩子。

你的梦想是你的梦想,不是你爹的,也不是你妈的。

你好好努力。
关于荣誉

你爹是个乐观的人,你爹最重视的是守护,忠诚,荣誉。

你爹在军队里学会的是,责任和荣誉有时候比生命更重要。

但是,儿子你为之付出之前请做理性的判断。当你做了正确的选择,我们都会支持你 。
你好好努力。
先说这么多吧。
生活就是如此。我们总得某种程度上试着去预见未来。
儿子,加油,我等着你骑在我脖子上撒尿那天。
我保证,那会是我最幸福的时刻。

爱你的老爹

2013年05月15日

Cisco 3750交换机配置DHCP服务器实例网络环境:一台3750交换机,划分三个vlan, vlan2 为服务器所在网络,命名为server,IP地址段为192.168.2.0,子网掩码:255.255.255.0,网关:192.168.2.1,域 服务器为Windwos/index.html’ target=’_blank’>windows 2003 advance server,同时兼作DNS服务器,IP地址为192.168.2.10,vlan3为客户机1所在网络,IP地址段为192.168.3.0,子网掩 码:255.255.255.0,网关:192.168.3.1命名为work01,vlan4为客户机2所在网络,命名为work02,IP地址段为 192.168.4.0,子网掩码:255.255.255.0,网关:192.168.4.1,3750作DHCP服务器,端口1-8划到VLAN 2,端口9-16划分到VLAN 3,端口17-24划分到VLAN 4.

DHCP服务器实现功能:

各VLAN保留2-10的IP地址不分配置,例如:192.168.2.0的网段,保留192.168.2.2至192.168.2.10的IP地

址段不分配.

安全要求:

VLAN 3和VLAN 4 不允许互相访问,但都可以访问服务器所在的VLAN 2,

默认访问控制列表的规则是拒绝所有包。

配置命令及步骤如下:

第一步:创建VLAN:

Switch>en

Switch#Vlan Database

Switch(Vlan)>Vlan 2 Name server

Switch(Vlan)>Vlan 3 Name work01

Switch(vlan)>Vlan 4 Name work02

第二步:设置VLAN IP地址:

Switch#Config T

Switch(Config)>Int Vlan 2

Switch(Config-vlan)Ip Address 192.168.2.1 255.255.255.0

Switch(Config-vlan)No Shut

Switch(Config-vlan)>Int Vlan 3

Switch(Config-vlan)Ip Address 192.168.3.1 255.255.255.0

Switch(Config-vlan)No Shut

Switch(Config-vlan)>Int Vlan 4

Switch(Config-vlan)Ip Address 192.168.4.1 255.255.255.0

Switch(Config-vlan)No Shut

Switch(Config-vlan)Exit

/*注意:由于此时没有将端口分配置到VLAN2,3,4,所以各VLAN会DOWN掉,待将端口分配到各VLAN后,VLAN会起来*/

第三步:设置端口全局参数

Switch(Config)Interface Range Fa 0/1 – 24

Switch(Config-if-range)Switchport Mode Access

Switch(Config-if-range)Spanning-tree Portfast

第四步:将端口添加到VLAN2,3,4中

/*将端口1-8添加到VLAN 2*/

Switch(Config)Interface Range Fa 0/1 – 8

Switch(Config-if-range)Switchport Access Vlan 2

/*将端口9-16添加到VLAN 3*/

Switch(Config)Interface Range Fa 0/9 – 16

Switch(Config-if-range)Switchport Access Vlan 3

/*将端口17-24添加到VLAN 4*/

Switch(Config)Interface Range Fa 0/17 – 24

Switch(Config-if-range)Switchport Access Vlan 4

Switch(Config-if-range)Exit

/*经过这一步后,各VLAN会起来*/

第五步:配置3750作为DHCP服务器

/*VLAN 2可用地址池和相应参数的配置,有几个VLAN要设几个地址池*/

Switch(Config)Ip Dhcp Pool Test01

/*设置可分配的子网*/

Switch(Config-pool)Network 192.168.2.0 255.255.255.0

/*设置DNS服务器*/

Switch(Config-pool)Dns-server 192.168.2.10

/*设置该子网的网关*/

Switch(Config-pool)Default-router 192.168.2.1

/*配置VLAN 3所用的地址池和相应参数*/

Switch(Config)Ip Dhcp Pool Test02

Switch(Config-pool)Network 192.168.3.0 255.255.255.0

Switch(Config-pool)Dns-server 192.168.2.10

Switch(Config-pool)Default-router 192.168.3.1

/*配置VLAN 4所用的地址池和相应参数*/

Switch(Config)Ip Dhcp Pool Test03

Switch(Config-pool)Network 192.168.4.0 255.255.255.0

Switch(Config-pool)Dns-server 192.168.2.10

Switch(Config-pool)Default-router 192.168.4.1

第六步:设置DHCP保留不分配的地址

Switch(Config)Ip Dhcp Excluded-address 192.168.2.2 192.168.2.10

Switch(Config)Ip Dhcp Excluded-address 192.168.3.2 192.168.3.10

Switch(Config)Ip Dhcp Excluded-address 192.168.4.2 192.168.4.10

第七步:启用路由

/*路由启用后,各VLAN间主机可互相访问*/

Switch(Config)Ip Routing

第八步:配置访问控制列表

Switch(Config)access-list 103 permit ip 192.168.2.0 0.0.0.255 192.168.3.0 0.0.0.255

Switch(Config)access-list 103 permit ip 192.168.3.0 0.0.0.255 192.168.2.0 0.0.0.255

Switch(Config)access-list 103 permit udp any any eq bootpc

Switch(Config)access-list 103 permit udp any any eq tftp

Switch(Config)access-list 103 permit udp any eq bootpc any

Switch(Config)access-list 103 permit udp any eq tftp any

Switch(Config)access-list 104 permit ip 192.168.2.0 0.0.0.255 192.168.4.0 0.0.0.255

Switch(Config)access-list 104 permit ip 192.168.4.0 0.0.0.255 192.168.2.0 0.0.0.255

Switch(Config)access-list 104 permit udp any eq tftp any

Switch(Config)access-list 104 permit udp any eq bootpc any

Switch(Config)access-list 104 permit udp any eq bootpc any

Switch(Config)access-list 104 permit udp any eq tftp any

第九步:应用访问控制列表

/*将访问控制列表应用到VLAN 3和VLAN 4,VLAN 2不需要*/

Switch(Config)Int Vlan 3

Switch(Config-vlan)ip access-group 103 out

Switch(Config-vlan)Int Vlan 4

Switch(Config-vlan)ip access-group 104 out

第十步:结束并保存配置

Switch(Config-vlan)End

Switch#write memory

实验内容:

一、配置DHCP服务器,可以为PC1与PC2分配IP地址及相关参数

二、配置DHCP服务器为PC1与PC2分配固定的IP地址

实验过程:

一、

实验步骤:

第一步:DHCPServer 路由器的初始化配置

Router>enable

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname DHCPServer

DHCPServer(config)#int f0/0

DHCPServer(config-if)#ip add 192.168.1.1 255.255.255.0

DHCPServer(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state

to up

DHCPServer(config-if)#exit

DHCPServer(config)#

第二步:开启路由器的DHCP功能

DHCPServer(config)#server dhcp //开启路由器的DHCP服务功能

第三步:创建DHCP的地址池和要分配的相关参数

DHCPServer(config)#ip dhcp pool Cisco //创建DHCP地址池并且命名为Cisco

DHCPServer(dhcp-config)#network 192.168.1.0 255.255.255.0 //创建可分配的地址段

DHCPServer(dhcp-config)#default-router 192.168.1.1 //定义可以分配的网关

DHCPServer(dhcp-config)#dns-server 8.8.8.8 //定义DNS服务器地址

DHCPServer(dhcp-config)#exit

第四步:排除不想分配出去的地址池

DHCPServer(config)#ip dhcp ex

DHCPServer(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10

//排除不想分配的IP地址

第五步:查看PC是否获得了IP地址

DHCPServer#show ip dhcp binding

//查看DHCP服务器分配IP地址的情况

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

192.168.1.11 0100.0d60.7fe6.1f Mar 03 1993 12:51 PM Automatic

192.168.1.12 0100.0d5e.41bb.b4 Mar 03 1993 12:51 PM Automatic

//其中红色的为PC机的标识信息

二、

实验步骤:

第一步:获取PC1与PC2 的MAC地址

1、在运行中输入CMD ,出现命令提示符

2、在命令提示符中输入IPconfig /all 查看相关网卡的MAC地址

在这里我们获取到了PC1与PC2的MAC地址

PC1:00-0D-60-7F-E6-1F

PC2:00-0D-5E-41-BB-B4

第二步:创建新的DHCP Pool

注意:不能在使用了network命令的dhcp pool中执行下面的命令,否则会出现错误提示。

解决办法就是创建一个新的DHCP pool 。

DHCPServer(config)#ip dhcp pool PC1

DHCPServer(dhcp-config)#host 192.168.1.111 255.255.255.0 //需要指配的IP地址

DHCPServer(dhcp-config)#client-identifier 0100.0d60.7fe6.1f //需要指定的MAC地址

DHCPServer(dhcp-config)#ip dhcp pool PC2

DHCPServer(dhcp-config)#host 192.168.1.101 255.255.255.0

DHCPServer(dhcp-config)#client-identifier 0100.0d5e.41bb.b4

DHCPServer(dhcp-config)#

第三步、在PC机上输入ipconfig /release 释放所获得的IP地址

1、运行中输入 CMD,打开命令提示符

2、在命令提示符中输入ipconfig /release 释放地址

3、在命令提示符中输入ipconfig /renew 重新获取IP地址

第四步:在DHCP服务器上查看已经分配出去的IP地址

DHCPServer#show ip dhcp binding

//查看DHCP服务器分配IP地址的情况

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

192.168.1.111 0100.0d60.7fe6.1f Infinite Manual

192.168.1.101 0100.0d5e.41bb.b4 Infinite Manual

// 手动

//其中红色的为PC机的标识信息

注:

Client-ID 由两部分组成,前面的01表示Ethernet介质类型,后面为主机的MAC地址。

2013年04月27日

小邮件 暗藏大心机

●E-mail是网络社交里见字如见面的个性名片。尤其是初识的两个人,除了电话联络,业务沟通更多依仗的是电子邮件。在与对方未曾谋面的情况下,我们通 常都会通过对方邮件里透露的点滴信息来做出各种判断。如,对方的态度是否积极、对于合作是否有诚意,以及是否尊重你的创意等。如果你是掌握了主动权的发件 一方,那么尤其是在E-mail的开头、结尾,乃至语气、措辞上都要多加小心了。

●E-mail是职场人际关系的“润滑剂”。和直白的交谈相比,文字是含蓄的、婉转的,即便是再犀利的辞藻只要是通过文字表达出来,也会生生去掉许多锐 气。再加上落笔之前,你总归会在心里打一个腹稿,那些冲撞的、鲁莽的、冒失的情绪很有可能就此被排除在外。这在职场的人际关系中可是有百利而无一害的。经 由这种安全系数极高的文字通道,你可以和对你的工作抱有成见的上司直抒胸臆,这样你的负面情绪得到宣泄、上司的想法你也有了一个综合而客观的了解。就像管 道一样,在复杂的人事环境中各种关系也需要得到及时而有效的疏通,否则会酿成大患。所以说,一场职业危机没准就是这样有惊无险地从你面前悄声而过。

●E-mail还可能是你日后邀功请赏的“功劳簿”。尤其是那些BOSS临时交办的工作,你自然是全力以赴,但如果你能将邮件设置成午夜时分发送出去,不 仅会给BOSS留下一个爱岗敬业的好印象,在对方心目当中你的职场表现也会因此加分哦!当然,如果你本来就是一个喜欢晚上处理工作的夜猫子,那可就要另当 别论喽。

●E-mail其实也可成为你职场生涯的“记事本”。当然,它既不是你某年某月做了哪几件事的流水账,也不是你何时何地获得过什么样荣耀的目录表。它其实 是一份只有你自己能看得懂的方程式,精准地记载着你对工作渐进式的理解与热爱。从刚入职时的热情有余、经验不足,到日后的老练果断、成竹在胸,假如你有兴 趣回头看看自己的E-mail,可能还是会感慨颇多的。这样的一路,自然有着不为人知的艰辛和挫败,但也一定会有柳暗花明的欣喜和愉悦。所以,这样的一个 记事本可是相当励志的。

●必要之时,你也可将E-mail视作最公允中立的“证明人”。有人说,职场就是一个热闹的江湖,实在是鱼龙混杂。古话说,明枪易躲,暗箭难防。如果你很 怕“鹬蚌相争,渔翁得利”或者“螳螂捕蝉,黄雀在后”的事情发生,利用E-mail搞点小伎俩实属上上策。比如添加抄送,甚至密送什么的,再说这本就是举 手之劳的事。

E-mail达人的十不法则

1 微醺之后或盛怒之下绝不打开邮箱。

小酌之后,你可能自己觉得浑身通泰,但大脑思维还在不在正常轨道上运转可不太好说。假如是怒火中烧那更是要命,提醒一下,邮箱可没有自动报警系统,对你的 失控情绪也没有主动屏障的能力。在这种情况下处理E-mail,很难保持客观冷静。没准哪封一气之下发出去的邮件就能让你追悔莫及、抱憾终生。虽说现在有 个什么设置可以在几秒钟之内让你改变主意,但你确定你的理智能在几秒之内恢复常态?

2 私人恩怨绝不在E-mail中提及。

在公司,通过网络聊私人事情本来就是一件很危险的事。公司可能有网络监控不说,还很容易被抓个“现形”。那换成E-mail难道就好很多吗?答案是NO! 这世上没有不透风的墙,如果你实在有个人恩怨需要一吐为快,茶水间、吸烟室,或者咖啡屋,虽然都不是什么最好的选择,但也总比你白纸黑字的给人留下证据 强。记住,作为职场的E-mail达人,“公私分明”绝对是最为明智的黄金法则。

3 绝不用E-mail来表达对别人的讥讽和嘲笑。

可能是你随性而致的一点幽默细胞起了作用,也可能是刚才走廊相遇时对方的会心一笑给了你胆量,你突然想在邮件里开对方一个小玩笑,或者就他(她)的一点失 误小小地嘲弄一下。对不起,除非对方是你职场的骨灰级密友,否则这样的玩笑最好还是不要开。或许下班后,那样的行为不会妨碍你们的情谊;但人在职场,适当 的礼仪还是要讲究的。何况,那样的E-mail很容易被人断章取义,如果因此而引火上身岂不是更不着调?

4 绝不会省略对对方的称呼,更不会乱称呼。

能用“您好”,绝不用“你好”,除非你确定自己是上级或长者。虽然收件人知道你是谁,但你的E-mail也不能省略对对方的称呼。如果对方有职位要称呼职 位,如果不清楚就用某某先生、某某女士来替代。如果是熟悉的双方可以用彼此习惯的称呼方式,但仅限于非正式邮件。“乱称呼”,指的是管谁都叫经理,请问, 真遇到比经理职位高的怎么办?还有就是称呼对方时可省去“副”字,不要跳级更不要给人降级。

5 绝不吝啬礼貌用语及适度赞美。

收发E-mail也需要一定的职场礼仪,有的时候,你觉得是客套、显生分,赞美别人也是多余的肉麻。但事实上,“请”“谢谢”“麻烦”这样的礼貌用语不仅是人际关系的敲门砖,对对方适度的恭维与肯定,还是人与人之间情感的“黏合剂”。

6 不会把老板也作为收件人之一。

这里其实是有一个写作技巧在里面。BOSS因为身份特殊,势必需要你谨慎对待。如果你希望了解一件事,可以在发送他人的同时抄送给你的老板;如果你有一个 提案需要征求大家意见,也可选择抄送老板;如果同时征求老板意见,则单独写给他(她),或在抄送的同时,在正文当中单独注明“请领导指教”。

7 不会眉毛胡子一把抓,没有层次、缺少重点。

邮件不是散文,最忌神散形也散。而且重点不突出的后果就是让人半天摸不着头脑,耽误正事不说,还容易给人留下一个办事不利索的印象,这可直接影响到你日后 的职场进阶啊!有话你可以一段段说,以递进的方式也好,以先主后次的方式也罢,做到条理清楚,对自己工作思路的清晰也是有帮助的。

8 不会忽略对对方的感谢。

还真有人对此专门做了调查,最后,统计显示邮件回复率低的一个主要原因就是因为有些人没有感谢的习惯。事实上,无论是寻求合作、请教问题、请人相助或哪怕 只是告知,都应该以诚挚的口吻感谢对方的善意配合与理解。那些将领导艺术拿捏得很好的人,即便是命令对方与自己合作,也会送上一句感谢来适时体现自己的个 人修养与内涵。 (来源:壹心理网www.xinli001.com)

9 结束语不会过于累赘或重复。

有时你可能是无心的,比如已经打算结束了,一句“祝好”刚写完,又觉得意犹未尽或者似乎有所遗漏,于是,又回到正题。再次收尾的时候,很可能不自觉地又顺 手补上一句“祝顺利”。殊不知,拖泥带水的后遗症就是这样留下的。解决办法是,在送上结束语之前仔细通读一遍邮件,看看有无遗漏、有无别字,其实花不了多 少时间,但省却了很多麻烦。

10 末尾不会不署名。

你可能觉得不用见外,署名能省就省了。但没准对方收到要找你的时候,正因为没有署名,还需要另花时间去查找这封邮件的出处以及你的联络方式。对方的工作效 率因此大打折扣不说,你可能也失去了在第一时间得到有效反馈的最佳时机。其实,署名不仅是尊重对方,也是尊重自己、宣传自己的方式。当然,事先设置好签名 档并附上自己所有的联络信息,那才是一劳永逸的聪明之举。

2013年03月28日
毕业典礼过后,闺蜜胡佳玮对沈佳宜说,真羡慕你,从国中到高中,都有那么多男生追你。沈佳宜答,被那么多人喜欢是很好,但是……她没有说出这个但是,而那一刻她的脸上,其实有着落寞的神情。一个女生,有很多男生追,如果还说自己不开心很受困扰,无疑会被其他女生嫉妒死,有得了便宜还卖乖的嫌疑。所以她只是说:”不,我觉得自己是一个很幸福的人。”确实很幸福。少年时的喜欢是学生时代最清新纯粹的一笔。但旁人不知道的是,这个世界上最还不起的是情债,这么多,她还不起。其实也知道,这些男生对自己的喜欢只不过是当时情绪,甚至只是盲目跟风而已。分别之后,他们会喜欢上别的女生,一如当初喜欢过自己。
沈佳宜其实并不是一个完美的人,她自己知道。这是她最可贵的地方。她对柯景腾说,我觉得你把我想得太好了,其实我只是个普通人。又说,恋爱最美好的时候是暧昧的时候。
是何等相通的小女生心情。从男生的角度来说,喜欢就是要靠近,要拥有,喜欢了就去追,不去想将来又何必要去想将来。简简单单,直截了当。但女生会想很多,会想在一起距离拉近之后,你看到我的缺点,就不会那么喜欢我了,那份感情就变了,还不如保留一份距离,给你我最好的模样。这就是女孩的成熟,也是她的自卑与怯懦。当所有人都以为她是意气风发的好学生,以为她是高傲矜持的乖乖女,她其实已经在喜欢的人面前低下头去,低下去,低到尘埃里去,只用矜持来伪装自己。柯景腾以为他已经够主动够勇敢,但他恰恰缺一点,那就是他与沈佳宜的心理年龄差,注定了他不懂沈佳宜。
那时候沈对柯说,你真的喜欢我吗?我觉得你喜欢的是你想象中的我。柯说,我没那么会想象。

看这段对话的时候我在心里笑了,也痛了。他不知道她在想什么,不知道她为什么这么说。

我觉得沈佳宜是对的。我觉得她是对的。成熟的女生应该会寻求比她更成熟的男生的保护,可是却偏偏对幼稚的男生动了心。她应该也很困扰与为难,不知道该怎么办。我一直想,如果她的身边还有一个高大帅气成熟沉稳的男生存在,她喜欢上柯景腾的几率应该会很小很小。她明显是喜欢成熟的人的,这从她日后选择跟她比较有共同语言的阿和以及成熟的丈夫就可以看出。喜欢与动心可能是被感动,不是真的爱,否则怎么会忍心错过。他幼稚地办一场格斗赛想要表现自己,却不知道这样对自己的不爱惜,只能破灭女孩的依赖感。幼稚的男生或许可爱,或许会逗女生笑,但是他不能带来安全感,而这恰恰是最要命的一点。
朋友看完电影后都说,他们没有在一起好可惜,问我,你觉得呢。我说不会,我觉得这是他们最好的结局。其实也是最现实的结局。沈佳宜成功了保持了这份距离,她促使柯景腾发奋,改变了一个男孩的命运轨迹。于是柯景腾在05年化身九把刀用她的名字写了一部小说,在11年又把它搬上大银幕,让全世界都知道了沈佳宜。
这就是结局,这才是结局。现实中的柯景腾和沈佳宜不是帅哥美女,现实中的柯景腾和沈佳宜都已人至中年,然后让无数个柯景腾和沈佳宜们在他们的故事里找寻共鸣,回忆过去。
之前和一个朋友聊起来的时候她说,每一届基本上都会有那么几个沈佳宜。我说,每个地域每个时代都有沈佳宜。
多得是幼稚的柯景腾,多得是优秀的沈佳宜,但少的是勇敢去追去表白的柯景腾,少的是会喜欢上你的幼稚的沈佳宜。现实生活中,好学生与坏学生的差距,是第一排到最后一排的距离,是同窗期间说话不超过十句,是不敢表白没有交集,是思想的鸿沟与差距。所以只会在毕业即将分离的时候才选择表明心意,哪怕她以前从未注意过你,你也觉得她不可能会喜欢上你。
两个世界的人,很难交汇,这是真的。哪怕在一起终究也会因为价值观差异而分开。

所以错过,也是宿命。

2013年03月24日

想起曾经偶然看过的一期《非诚勿扰》里,有女嘉宾斥责当今的男人自己不求上进却一味抱怨女人的势利和拜金,孟非当时说:“这世上最佩服两种人,一种是年轻 时陪你吃苦的女人,一种是年老时陪你享福的男人”,想到假期耳闻目睹一些家庭闹剧,忽觉这真的是恰当到不能再恰当的评价。

表姨和表姨夫在 大学时就认识了,恋爱长跑超过七年,两人博士生毕业后顺理成章的结婚了,才子佳人,一时传为佳话。表姨夫后来留在了中大当老师,表姨为了陪他扎根广州,拒 绝了当时内地一所著名大学邀请,选择了广州一所非211高校。表姨跟表姨夫都不是广州人,刚工作的时候,房贷车贷的压力很大。为了尽心照顾表姨夫的生活, 表姨放弃了出国做访问学者的机会;为了全力支持表姨夫的事业,表姨放弃了自己的科研去帮他做项目。最初工作忙又没时间没钱,两人也不敢要孩子,怀表弟的时 候,表姨已经是高龄产妇,生产时碰到难产,差点从鬼门关前走了一遭。

如 若一直如此下去,倒也是一个平凡简单的知识分子家庭的故事。前两年表姨夫事业发展很快,升了职称提了领导,心态也开始活跃了起来。作为博导,他手下带个年 轻漂亮的女博士,跟着他出了两次差,两人就自热而然的搅和到了一起。表姨夫一面在广州另外购置了一处房产,和女学生过起了同居生活,还把女学生的母亲也接 到广州来当岳母一样孝敬着,一面单方面对表姨提出了离婚,派人把离婚的出庭告示张贴在表姨的学院门口。表姨夫的母亲特地赶来了广州,给他下跪,求他看在表 弟年纪尚幼的份上浪子回头,表姨夫却关门把她挡在了门外。事情折腾了一年多,总算是在年底的时候协议离婚。过年期间去表姨家拜访,又听说当初答应的抚养费 并没有如实支付,表姨一脸的凄然,只期盼着这件事能够快些尘埃落定。

在旧东家上班的时候,同层楼隔壁部门有个男人,二十七八岁的样子,年 纪轻轻就做到经理。男人很早就结婚了,妻子是他复旦的师妹,两人相识于上海,结婚后相约一起北上来帝都打拼,只是去了不同的公司。隔壁部门后来新进了一个 女孩,女孩长得不算很漂亮,毕业于牛津,挺有气质的样子,是公司当时在争取的一家客户老总的女儿。女孩进来后客户很自然地就和公司签了约,男人跟那个女孩 都是当时那家客户项目组的主要成员,因此也越来越熟悉,关系突飞猛进。年底项目结项的时候部门总监请客户吃饭,女孩的爸爸应邀出席,席间女孩的爸爸不解地 询问,为什么公司总是派他的女儿出差跟加班。总监一惊,答复说项目虽然紧张,但是女孩倒是从来没有加过班,更别提出差了。于是众人才知道两人的关系早已非 比寻常。

女孩的爸爸大怒,把男人抓来见了一面,威胁说让他拿着离婚证来家里娶他的女儿,不然就别想在北京混下去。男人的速度倒是快,不到 一个月就和女孩举办了婚宴,客户动用了关系,男人一下在公司连升了几级,女孩结婚后也就离开了公司做起了全职太太。只是男人原本的妻子,从一开始就没见他 出现过,只听男人的朋友说是个特别小家碧玉的女人,在男人提出离婚后也没过多挣扎,手续办妥之后就一个人回了上海。

负心的倒也未必都是男子。

熟 悉的人也许会记得我曾经提过的大姑姑与大姑父的故事。大姑父年轻时有了外遇,大姑姑很决绝了用了一种最极端的方式结束了自己的生命。当年外遇的那个小三, 后来也打着爱情的名义登堂入室成了正牌妻子。女人虽然是以一种不受欢迎的方式进门,结婚后也算是安分守己,对几个表哥表姐还算是客气,过了几年又育有一 子,除了花钱大手大脚一点之外也没什么其他的过错。

只是这几年,姑父年纪大了身体越来越差,又生了一场大病需要常年住在医院里,家里的钱 也因此所剩无几。女人心思便开始活泛了,经常把小儿子丢在医院照看姑父就外出消失不见,流连于各种娱乐场所,声色犬马。姑父原有高血压,经常被气得病发。 表姐实在是看不过,找人把女人找了回来,答应每月支付她一笔钱,拜托他好好照料姑父跟那个才念初中的小弟弟。谈判了许久女人最后倒是答应了,只是心里仍旧 是不安分,每日都要闹上几次,不是为了生活费跟表姐争吵,就是诅咒姑父早日过世,不曾有过一天的安宁日子。

年轻气盛,挥斥方遒的时候,总 觉得人一定要有那样一段情感或经历,明明只有几个月,却像是要把一生都走完了。之后是再见,还是再也不见,都不重要了。年纪大了就只想有个人,能让自己心 甘情愿为他熬完一生。只是这愿望,怕是也不容易实现吧。朋友失恋的时候哭诉:那个人说“是我负了你,但请你还是一定要相信”,只是连那个人都不能够让我相 信,我又该去相信谁呢。

当初说要,地老天荒,现在想想,确实太长。(文/張君雅)

2013年03月22日

我添加的是一块SCSI的硬盘, 所以新加的硬盘应该是以da0,1….开头. 如果是添加IDE的硬盘, 貌似应该是以ad0,1… 开头的了.

一、默认安装完freebsd系统后,可执行df -h命令查看当前硬盘信息:
[root@www.unixnotes.net /] #df -h

Filesystem     Size    Used   Avail Capacity  Mounted on  /dev/
da0s1a
    140G    2.9G    126G     2%    /  devfs          1.0K    1.0K      0B   100%    /dev  

从以上信息可知硬盘是
ad0
,好,接下来关机,接上第二个硬盘,开机登陆freebsd系统,执行dmesg命令:
[root@www.unixnotes.net /]#dmesg
显示以下信息:

......................................  .........省略部份..................  .........................  ppi0:  on ppbus0  da0
: 139205MB  [79656/16/63] at ata0-master UDMA100  da1
: 38166MB  [77545/16/63] at ata1-master UDMA100  Mounting root from ufs:/dev/ad0s1a  

从以上信息可以看到新加的硬盘是
da1,

二、建立newdirectory目录用于挂载第二个硬盘
[root@www.unixnotes.net /]#cd /
[root@www.unixnotes.net /]#mkdir newdirectory
情况一,新增加的硬盘是没有数据的,或新增加的硬盘数据是不要的了!

先格式化一下硬盘:
[root@www.unixnotes.net /]#dd if=/dev/zero of=/dev/da1 bs=1k count=1

始化新磁盘
[root@www.unixnotes.net /]#fdisk -BI da1

加上标签
[root@www.unixnotes.net /]#disklabel -B -w -r da1s1 auto

现在编辑你刚才创建的磁盘分区
[root@www.unixnotes.net /]#disklabel -e da1s1

为你创建的每个分区重复这个操作
[root@www.unixnotes.net /]#newfs /dev/da1s1c

挂上分区
[root@www.unixnotes.net /]#mount /dev/da1s1c /newdirectory
情况二,要增加的硬盘是有数据的,而且数据是要保留的,到时要挂载到netdirectory目录的!

加上标签
[root@www.unixnotes.net /]#disklabel -B -w -r ad2s1 auto

现在编辑你刚才创建的磁盘分区
[root@www.unixnotes.net /]#disklabel -e ad2s1

挂上分区
[root@www.unixnotes.net /]#mount /dev/ad2s1c /newdirectory

三、编辑/etc/fstab 文件,添加合适的记录到你的/etc/fstab文件。如我的是增加以下信息:

/dev/ad2s1c             /netdirectory          ufs     rw              2       2

以上空白处用tab键隔开,不是空格,我的是ad2,具体根据dmesg显示的信息修改!如下是我的fstab文件内容:
[root@www.unixnotes.net /]#vi /etc/fstab

# Device                Mountpoint      FStype  Options         Dump    Pass#  /dev/ad0s1b             none            swap    sw              0       0  /dev/ad0s1a             /               ufs     rw              1       1  /dev/ad0s1f             /tmp            ufs     rw              2       2  /dev/ad0s1g             /usr            ufs     rw              2       2  /dev/ad0s1e             /var            ufs     rw              2       2  /dev/acd0c              /cdrom          cd9660  ro,noauto       0       0  proc                    /proc           procfs  rw              0       0  /dev/ad2s1c             /netdirectory          ufs     rw              2       2  

五、OK完成!

Source:http://blog.163.com/liulina_517@126/blog/static/37661983201191411221176/

2013年03月18日

一、科普

紧急联系人,是指当事人遇到事故、疾病或突发事件或出现意外时会第一时间会出现,帮助解决后续系列问题的人。

2008年7月23日  国际电信联盟星期一建议全球统一使用数字代码在手机电话簿中标记紧急联系人,例如,以“01父亲”(01father)、“02妻子”(02wife)等方式,以便在手机持有人发生紧急情况时,救援人员能够迅速与其亲友取得联系。

在一些讲英语的国家,“ICE”这三个英文字母组合表示“当紧急情况发生时”(In Case of Emergency),因此许多人利用这个英文代码在手机电话簿中标记自己的紧急联系人,但是,对于不熟悉英文或罗马字母的人来说,这样的标示就失去了效果。

因此,国际电联建议全球统一使用阿拉伯数字来标记紧急联系人。尽管世界各地的语言文字千差万别,但人们普遍认识阿拉伯数字。

国际电联表示,用数字代码标记紧急联系人这一做法简单易行,同时又能够为急救人员的工作带来很大便利,国际电联将与其他相关组织和机构合作,积极推广这一概念。

紧急联系卡
Emergency Contacts
姓 名 樱桃 性 别
Name YingTao Sex Male
生 日 2012年 血 型 O RH+
Date of Birth 2012 Blood Group
国 籍 中国
Nationality Chinese
过敏史
Allergies None
其他疾病
Other Illnesses None
紧急联系人 电话 所在地
Emergency Contacts Tel. City
李若 0086-12345678999 上海
Mr.Li Ruo(Friend) ShangHai

注意事项及补充

1.紧急联系人最好是你的至亲或最好的朋友,能在你最危难的时刻帮助你。最好在你常去的城市至少有一个联系人。

2.除了最必要的信息,不透漏更多个人情况。要求你的联系人有识别骗子的能力。建议告知你的联系人将他作为你的紧急联系人了,万一有情况要进行必要的核查,比如跟当地警察求助。

3.如果不想把联系人的真名信息暴漏,可与联系人约定好他的名字,让他听到别人叫你们约定的名字就知道有紧急情况了。

4.记录的卡片材质可以是普通纸卡,放到防水袋里,放到身上。

二、谁是你的紧急联系人

这事儿的确挺伤脑筋。

联系人首先不可以是父母亲,独自在外父母亲不在身边,有心无力阿。父母在身边的话除了问题也不好让他们担惊受怕血压升高折腾来去对吧。

谁是紧急联系人的最佳人选呢?

这个人一定跟自己的关系很亲密;

这个人一定是自己最信任的人;

这个人一定是个靠谱的人;

这个人一定是那个你坚信他会为了你能放下一切的人;(一个人能在一个人的心里有这个位置,那劝你们在一起吧)

除此之外,相关的配件也是必要条件,有车(紧急时候能出动)、有人脉(中国是个靠人脉说话的地)、有银子(有时候钱是万能的)

能够有好几个紧急联系人可以填写,应该很值得开心的吧,有那么些人会在紧急关头让你想到,会帮助你,让你觉得一切都不用畏惧,不管发生什么,都会有人在你身后支持着你。

如果有人把你写成紧急联系人,对你也是充满信任和关心的吧,如果不能做到,会不会让人很失望,自己显得很没担当,好像可能我曾经让别人失望过,如果再有这种情况,我一定努力去做好。

我们见过太多的人,接触太多的人,擦肩而过太多的人……

电话本里有数百个电话号码,真正在联系的又有几人?

前几日朋友跟我感叹:曾经有人是你生活的一部分,在那段时间里你觉得这辈子都不会分开。但可能只过去了一两年,你回头看,发现这个人如此陌生,好似从未出现过一样。

好似从未出现过一样!

身边的朋友很多,但谁是那个满足跟你关系亲密、最信任、靠谱、为了你能放下一切的人?

我至今认为自己做过最浪漫的事情莫过于——在她出行前,在她的背包里,钱包里,塞上了我亲手做的卡片,里面工整的填写好了我的24小时联系方式,再写一句:如有紧急情况,请联系……

Tags: .