2004年09月30日

什么时候,我们可以不再骗人…从低价管理软件看程序人生
什么时候,我们可以不再骗人…从低价管理软件看程序人生

很早就想写这篇文章了,呵呵,只是一直觉得没什么必要。曾经和朋友也讨论过这个问题,但是终归是几个技术人员的牢骚。不过又看到某些公司打着“高”科技的幌子骗人,有点¥%·¥%¥%¥%…………(此处省略国骂若干)。至于具体问题如何,先请看下文。公司,都是大公司,我就不点出来名字横加指责。我只是就此说点我对ERP的理解和国内ERP行业的看法。

http://www.csdn.net/news/newstopic/16/16887.shtml

“8月20日,速达公司隆重推出一款面向小型企业的“杀手级”应用软件———速达1000,市场定价在600元左右,是国内软件历史上价格最低的企业管理软件。”

我其实挺无言的,600元,那么这个软件的开发周期是多少呢?它需要卖出多少套才可以回收成本?它需要卖出多少套才可以赢利?一个大“?”。那么有谁受益?客户?开发者?都不是。客户用到的是一套粗制滥造的低成本软件,唯一的收益就是“我们也用ERP了”(关于这个ERP,暂放下不说。)而由于600元的管理软件上市,对于其他中小软件公司来说当然是冲击。降价成为不得已的选择。而受害的就是软件的开发人员。降低成本,开发人员的薪资必然降低。而技术好的开发人员必然流失。低的薪资只能招来技术一般的开发人员,从而生产出质量更差的软件。质量差的软件只能低价贱卖……恶性循环,长此以往,开发将不开发(此句来源于“长此以往,国将不国”)。记得几年前国内的彩电价格大战,商家、媒体、政府都为之关注——“这种价格大战将损害我们的彩电产业!”而如今的软件价格大战呢?“低价推倒市场门槛”我无言……谁来保佑我们可怜的软件产业,谁又来保佑我们这些可怜的程序员……

“3年至5年以内,中小企业管理软件市场会出现‘井喷’,但前提是大家要放下‘高科技’的架子,打破市场壁垒,让企业主首先用得上软件。而速达1000系列就是为推倒市场壁垒做出的革命性举措。”速达主席岑安滨日前说。这是继上半年推出2万元超低价5000Quick-ERP在中型企业市场引起强烈震荡以来又一重大市场举措。

什么是ERP?http://tools.icxo.com/htmlnews/2003/05/08/3278.htm大家请看这个。ERP就是Enterprise Resource Planning,企业资源计划系统。这不是一个简单的概念,更不是在企业内部部署一套管理软件就完成了的。它需要管理理念、制度、人员的多方配合。而计算机和软件在其中只是一个辅助工具,就好比汽车可以让我们走得更快,但是没有汽车,我们一样可以走一样。但是现在一些别有用心的企业打着高科技的幌子,向企业高价兜售ERP(其实只是软件)。而当企业真正使用这些软件的时候,并感觉不到软件节约的成本,于是这些别有用心的企业又提出“3年至5年以内,中小企业管理软件市场会出现‘井喷’,但前提是大家要放下‘高科技’的架子,打破市场壁垒,让企业主首先用得上软件。”如此“打破壁垒”必将是打碎客户与开发人员的心。

其实我上面说的这些道理,那些在国内搞管理软件的龙头企业何尝又不知道呢?但是抛弃对开发人员的认可、放弃对核心技术的研究,专注于市场操作与斗争。打价格战、数量战,而企业对真正在后面默默开发的程序员的待遇与认可度却越来越低。这也是为什么很多龙头软件公司这些年经常暴出开发人员集体出走等等一系列危机。而所有人都众口一词,国内技术力量匮乏,人员不稳定。这又是谁造成的呢?曾经有一个程序员自嘲的笑话“程序员 VS 妓女”,其实看到这个笑话真正应该脸红的是那些在IT行业专注于市场份额,贱卖一切的人(除了软件,还有人格、信任、激情……)。

尊重市场,尊重开发,尊重客户,则是肯定自己。什么时候,我们的心血可以不被贱卖;什么时候,我们是值得尊重的人。

 
    昨天传来腾讯的捷报—–2004年09月18日最高同时在线人数突破700万!我们的QQ正在壮大,我们的论坛正如少年般在茁壮,在生长他的四肢.我以为这正是QQ的春天.我们仿佛可见那胖胖的企鹅,在不远处曼妙它的舞姿.这样时刻,是腾讯的伟大时刻,是我们这一群QQ的用户的伟大时刻,是我们这些为腾讯用户服务的人的伟大时刻.
    一起过来骄傲吧,QQ们!

    作为中国最早的互联网即时通信软件开发商之一,中国的互联网服务及移动增值服务供应商,腾讯公司于1998年成立以来,最关注的就是用户服务。在产品方面,腾讯围绕互联网、无线网与固网等三大通信平台,为用户开发出更多的创新产品和增值服务,使用户不仅可以传输文本信息、图像、视频、音频及电子邮件,还可以获得更多各种提高网上社区体验的互联网及移动增值服务,包括移动游戏、交友、娱乐信息下载等各种娱乐资讯服务。

自从腾讯进军互动娱乐以来,腾讯提供的各种卓越的服务已经得到了市场的肯定和广大用户的热情欢迎。QQ游戏中心、QQ秀、QQ家园、网络在线游戏-凯旋等多种娱乐服务,将娱乐功能和时尚结合得更为紧密。

    2004年腾讯公司再接再厉。在这个金秋,在“十一”这个举国欢庆的日子里,由腾讯公司自主研发的中型休闲类网络游戏—《QQ堂》将要开始内部测试了。

   《QQ堂》是以风靡的电视游戏“炸弹人”为蓝本进行设计和改进,在赋予了它网络对抗功能的同时,一些别出心裁的设计更能让玩家在游戏中重新体会童年的那份快乐。

    游戏以《QQ堂》命名不仅代表它是腾讯QQ的同胞兄弟。游戏中的QQ糖是很有嚼劲和韧性的糖,其爆炸后如弹性地向四周以十字形伸展,玩家遇到就被弹出的糖,粘住向其聚合成一果冻样子,将玩家包围变成果冻。

    玩家可以使用QQ号码直接的登录游戏,无需重复注册。在《QQ堂》还可以显示玩家的QQ秀,游戏卡通休闲趣味十足,充分满足个性的表现欲望。同时,QQ堂支持一台电脑双人游戏的模式。

   《QQ堂》游戏画面精美、人物造型可爱、操作简单、容易上手、对机器配置要求低。并率先引入让您千变万化的变身系统,还支持双人用一台电脑共玩,并肩作战、合作无间,实是情侣同玩、亲子共乐的最佳选择。《QQ堂》必将成为大众休闲网络游戏的首选。

    在游戏即将推出之际,为了完善游戏,提供优质的网络服务,《QQ堂》的内部测试即将开始。

    同时为了繁荣游戏文化,给长期以来关注腾讯产品的用户、给我们有写作才华的Q民以及对《QQ堂》感兴趣玩家施展自己的空间。QQ堂记者团也将成立了。记者团的宗旨是给用户一个抒写心情、交流经验、报道游戏热点的平台。

    现QQ堂记者团正式开始第一期记者招募,请有兴趣、有能力、有经验的用户按照下面的格式跟贴报名。记者的试用期为一个月,在试用期间每个月需要提交至少四篇有效的文章。

    第一批试用记者招聘15名,每一名记者都将获得QQ堂珍贵内测帐号一个。

2004年09月29日

Tencent Messenger(简称TM)是腾讯公司推出的一款面向
个人的的即时通迅软件,面向在办公环境中有使用IM需求
的用户,较侧重于熟人间的沟通和联系
News:使用TM可完全免费发送150条手机短信/天,接收免费

特色功能

  1、精湛界面,全新打造

  腾讯TM2.0 BETA版本,在界面上了全面优化和持续的完善,具体的面板和IM窗口如下图所示,婉如五月的风,清新扑面而来。让我们在细微之处感受到精益求精!

  2、QQ/TM两相切换,轻松一键

  大家使用自己手中的任何QQ号码都可以直接登陆TM。而且从QQ2004版本开始更是可以在登陆QQ之后,只需一键就轻松切换到TM,同时在TM上也可以随心所欲一键切换到QQ,如下图3、4所示!从而免去二次登陆、甚至还需输入密码的麻烦。细微之处、显关怀。

 

  3、信息到达,标签提示,更体贴,更人性

  工作忙时,对于朋友发过来的消息我们有时无法及时选择查看,但是看着头像一直闪动多少也有些打扰,为此,TM增加了信息到达的标签提示,方便用户无须手工选取,可以从浮动的标签中及时了解收到的消息的发送人、消息的前部分内容、和这是该用户的第几条未读消息。

  如图5所示,收到来自同事“夏冰”的第4条消息,内容是:最近,工作进展的如何?这个标签提示出现在屏幕右下角,几秒钟然后自动消失;同样,当TM上有未查看消息时,屏幕右小角TM的标志“”将暂时显示为“”,鼠标双击“”,将进一步打开该用户的IM窗口,方便查看完整的消息。

  另外在TM面板的上,可以查看到各好友之前发送过来,但还未查看的信息条数,帮助大家在工作中使有事离开再回来后,不再会错过任一条重要信息。

  4、新面板,新分组,快捷更方便

  很多朋友都有这样的感受,当自己面板上的好友越来越多,腾讯推出了好友分组的概念,这样可以通过设置不同的组,如“高中同学”、“同事”、“供应商”等,从而把好友分门别类,更加便于管理。

  但是,如果有时候不小心把IM窗口关闭后,即使是直接去某个分组里长长的列表中找刚才的联系人也还是有些麻烦。

  TM2.0版本全新完善,独立推出了“最近联系人”分栏!如图7的TM面板上的“最近联系人”分组,在这里面可以找到最近和我们联系过的IM好友、手机好友、群以及互动空间里的服务商。

  5、接名片,递名片,片片常联系

  为了辅助商务方面的沟通,TM第一个版本开始就为大家提供了通过在名片编辑器中填写相关资料,来自动生成名片的功能,还可以将内容设置为公开从而方便其他用户在行业查找中对自己的资料进行浏览。

  TM2.0版本从人性化出发,对名片的设置、发送及索取进行了全方位的完善和提高。

  可选择的公开
  在名片编辑器中,黄页资料以外的名片资料部分为用户提供了是否公开的选择,如果不希望被别人查看到电话、电子邮件等个人信息,则只要不选择“在行业黄页中公开”即可。如图8所示。此外在名片资料中还提供了对公司Logo的显示。

  6、重中之重“互动空间”闪亮登场

  在TM中可以和朋友谈工作、聊生活,洽谈业务、请教问题,有没有想过在它上面可以得到更多的受益,让我们的网络生活从此更加精彩起来呢?
  TM2.0版本在第三面板中增加了“互动空间”,打开服务商列表中,如图12,有“小I机器人”、“在线金山词霸”、“CCW导购专家”、“RTX腾讯通”等出现在我们的视野!
http://qqdl.tencent.com/tm3.0build0928.exe

  现在随着电脑应用知识的普及,我想,很多朋友对WINDOWS注册表的修改已经有不少经验和心得。在图形界面下对注册表的维护和修改,就不必再提了,但有时候,我们可能会遇到更辣手的事情,如由于人为错误操作或者恶性病毒感染而使系统切底崩溃,不能进入WINDOWS图形界面时,我们对此是否只有重装这种方法呢?本文将就在DOS下面尽量挽救系统这方面作出阐述。

  一、使用scanreg/restore

  我想这种方法大家也比较熟悉了,只要在DOS界面下输入该命令,就可以在最近的5个注册表备份里恢复,如果幸运的话,系统就可以马上恢复。但,事实上,用这种方法有个致命的缺陷就是你只有最近5天的注册表备份可以选择。因为控制着自动备份的scanreg.exe只会在每天第一次启动电脑时备份,如果哪天你安装的程序或者对注册表的修改比较多,那么你的努力就大多白费了。这种方法就正如是眉毛胡子一起抓,正确和错误的都一起改掉,是否能为恢复系统帮上忙,总有一种听天由命的感觉。所以,笔者鼓励大家使用第二种方法。

  二、使用DOS界面的regedit.exe

  如果把scanreg/restore比作是一刀切的话,这种方法更像是一次高明的外科手术,只一矢中的地针对病,把错误修复而完全不影响注册表的其他健康部分。这样,我们就能在最大限度上保留我们的工作成果了。使用regedit.exe对注册表实行局部修改的思路是:首先,把注册表里有嫌疑的分支导出;然后,使用edit对它进行分析和修改;最后,把健康的分支重新导入注册表里。好了,我们来看看整个过程的具体操作。

  1 导出注册表分支

  在DOS下导出注册表分支的命令格式是:Rrcedit[/L:system] [/R:user] /E filename [regpath1]。/L:system是指定system.dat的路径,/R:user是指定user.dat的路径,如果不说明,系统就会在默认的路径下找;/E:是导出注册表分支的文件名,regpath1是要导出的注册表分支。比如,我们要导出默认注册表关于控制系统启动的分支到test.reg里,命令如下:regedit /e test.reg HKEY-LOCAL-MACHINE\Software\Microsoft\Windows\CurrentVersion\Run。

  2 对注册表进行分析、修改

  在DOS下面只要运行edit就能对*.reg文件进行编辑了,因为我们导出的注册表实际上就是文本文件。不过,要正确找出引起错误的地方并修改,需要我们平时对注册表积累的经验。下面,我们看一下它的基本结构,以使我们在对它的修改时可以有的放矢。
  我们知道,注册表里面有6个主分支,其中容易引起致命错误而使WINDOWS不能正常启动的分支有:  [HKEY_LOCAL_MACHINE],记录着本地机器的硬件配置以及安装的相应软件,特别是[HKEY-LOCAL-MACHINE\Enum\PCI]这个分支下面的主键值,一旦出错,WINDOWS往往不能启动。如[HKEY-LOCAL-MACHINE\Enum\PCI\VEN_8086&DEV-7111&SUBSYS_00000000&REV-01\BUS_00&DEV_07&FUNC-01]记录的是硬盘控制器的详细信息,下面的Logconfig记录着它的各种参数;[HKEY_LOCAL-MACHINE\Enum\PCI\VEN-1002&DEV-4C42&SUBSYS_4C421071&REV-DC\000800]记录的则是显示卡的重要资料和参数,一旦这里出错,往往会导致WINDOWS在启动时黑屏,然后死掉。
  另外还有[HKEY-LOCAL-M ACHINE\Software\Microsoft\Windows\CurrentVersio]里记录着WINDOWS当前版本的信息以及启动时执行的程序等,这是病毒最爱攻击和修改的地方。
  至于还有[HKEY-CLASS-ROOT]是记录文件种类及其关联信息的,[HKEY-CURRENT-USER]里记录着当前用户的各种信息,包括登陆的密码和各方面的设置等,这些一般不会引起WINDOWS的致命错误,这里也不再详细分析了。
  当我们对这些键值分析和修改时,如果碰到什么不清处的地方,可以通过第1点的导出注册表方法,把一些备份注册表的相应分支导出,进行比较。WINDOWS的注册表备份都放在C:\windows\sysbackup里面,如我们要导出第一个注册表备份的[HKEY_LOCAL_MACHINE]分支,那么我们可以先进入该目录,然后键入命令:extract /e rb000.cab *.*,先把system.dat和user.dat解压出来,再键入命令:regedit /L:system.dat /R:user.dat /e backup.reg HKEY-LOCAL-MACHINE。 笔者在这里提醒一下,这是一个很好的解决问题的方法,再用上一些文件比较软件可以很快的找出错误的,请诸位慢慢体会。

  3 把修改好的注册表分支重新导入

  命令的格式为:regedit /L:system /R:user file1.reg file2.reg。我们一般都要修改默认的注册表文件,所以在实际使用中只需键入:regedit file1.reg就行了。  好了,讲了这么久,我们看看一个具体的案例。
  学院机房里的一台机器在重新启动后,无论用正常模式或者安全模式都不能进入WINDOWS界面,表现为启动过程中硬盘突然不读。用SCANDISK检查过硬盘,并没有发现问题。在启动过程中选择生成BOOTLOG.TXT文件,发现启动到硬盘控制器后就断掉了。本来想用scanreg/restore恢复备份的注册表,可是该机器为了加快启动,并没有自动备份。于是,用regedit把[HKEY-LOCAL-MACHINE\Enum\PCI]分支导出,键入:regedit /e hdc.reg HKEY-LOCAL-MACHINE\Enum\PCI;接着用EDIT查看关于硬盘控制器的部分,发现有”ChannelOptions”=hex:00,问题到这里终于发现了,原来是有人把IDE控制器设置成不使用,造成在加载硬盘控制器后,系统不能访问硬盘,所以把它改为:hex:02;再键入命令:regedit hdc.reg,把修改后的信息导入。重新启动机器,一切正常运行了。
  这样,在不损坏任何数据的情况下,就把问题解决了。希望这个例子能给大家带来这种DOS下维护注册表技巧的启发,毕竟,我们硬盘上面有很多都是无价的数据。

VPN客户端在公网上连接远程的VPN服务器一切正常,但在PIX防火墙内的VPN客户端接不上外面的VPN服务器?PIX防火墙上只做了NAT转换,没有做其它任何限制。请各位高手帮忙!
------------------------------

sysopt connection tcpmss 1500
sysopt connection permit-ipsec
domain-name cisco.com
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map cisco 1 set transform-set myset
crypto map dyn-map 20 ipsec-isakmp dynamic cisco
crypto map dyn-map interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp client configuration address-pool local clientpool outside
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup user address-pool clientpool
vpngroup user split-tunnel acl_vpn
vpngroup user idle-time 1800
vpngroup user password ********

如何配置Cisco PIX防火墙 (转载自无限矩阵 作者:verve)

任何企业安全策略的一个主要部分都是实现和维护防火墙,因此防火墙在网络安全的实现当中扮演着重要的角色。防火墙通常位于企业网络的边缘,这使得内部网络与Internet之间或者与其他外部网络互相隔离,并限制网络互访从而保护企业内部网络。设置防火墙目的都是为了在内部网与外部网之间设立唯一的通道,简化网络的安全管理。
在众多的企业级主流防火墙中,Cisco PIX防火墙是所有同类产品性能最好的一种。Cisco PIX系列防火墙目前有5种型号PIX506,515,520,525,535。其中PIX535是PIX 500系列中最新,功能也是最强大的一款。它可以提供运营商级别的处理能力,适用于大型的ISP等服务提供商。但是PIX特有的OS操作系统,使得大多数管理是通过命令行来实现的,不象其他同类的防火墙通过Web管理界面来进行网络管理,这样会给初学者带来不便。本文将通过实例介绍如何配置Cisco PIX防火墙。

在配置PIX防火墙之前,先来介绍一下防火墙的物理特性。防火墙通常具有至少3个接口,但许多早期的防火墙只具有2个接口;当使用具有3个接口的防火墙时,就至少产生了3个网络,描述如下:
? 内部区域(内网)。 内部区域通常就是指企业内部网络或者是企业内部网络的一部分。它是互连网络的信任区域,即受到了防火墙的保护。
? 外部区域(外网)。 外部区域通常指Internet或者非企业内部网络。它是互连网络中不被信任的区域,当外部区域想要访问内部区域的主机和服务,通过防火墙,就可以实现有限制的访问。
? 停火区(DMZ)。 停火区是一个隔离的网络,或几个网络。位于停火区中的主机或服务器被称为堡垒主机。一般在停火区内可以放置Web服务器,Mail服务器等。停火区对于外部用户通常是可以访问的,这种方式让外部用户可以访问企业的公开信息,但却不允许他们访问企业内部网络。注意:2个接口的防火墙是没有停火区的。

由于PIX535在企业级别不具有普遍性,因此下面主要说明PIX525在企业网络中的应用。

PIX防火墙提供4种管理访问模式:
2 非特权模式。 PIX防火墙开机自检后,就是处于这种模式。系统显示为pixfirewall>
2 特权模式。 输入enable进入特权模式,可以改变当前配置。显示为pixfirewall#
2 配置模式。 输入configure terminal进入此模式,绝大部分的系统配置都在这里进行。显示为pixfirewall(config)#
2 监视模式。 PIX防火墙在开机或重启过程中,按住Escape键或发送一个“Break”字符,进入监视模式。这里可以更新操作系统映象和口令恢复。显示为monitor>

配置PIX防火墙有6个基本命令:nameif,interface,ip address,nat,global,route.
这些命令在配置PIX是必须的。以下是配置的基本步骤:
1. 配置防火墙接口的名字,并指定安全级别(nameif)。
Pix525(config)#nameif ethernet0 outside security0
Pix525(config)#nameif ethernet1 inside security100
Pix525(config)#nameif dmz security50
提示:在缺省配置中,以太网0被命名为外部接口(outside),安全级别是0;以太网1被命名为内部接口(inside),安全级别是100.安全级别取值范围为1~99,数字越大安全级别越高。若添加新的接口,语句可以这样写:
Pix525(config)#nameif pix/intf3 security40 (安全级别任取)

2. 配置以太口参数(interface)
Pix525(config)#interface ethernet0 auto(auto选项表明系统自适应网卡类型 )
Pix525(config)#interface ethernet1 100full(100full选项表示100Mbit/s以太网全双工通信 )
Pix525(config)#interface ethernet1 100full shutdown (shutdown选项表示关闭这个接口,若启用接口去掉shutdown )

3. 配置内外网卡的IP地址(ip address)
Pix525(config)#ip address outside 61.144.51.42 255.255.255.248
Pix525(config)#ip address inside 192.168.0.1 255.255.255.0
很明显,Pix525防火墙在外网的ip地址是61.144.51.42,内网ip地址是192.168.0.1

4. 指定要进行转换的内部地址(nat)
网络地址翻译(nat)作用是将内网的私有ip转换为外网的公有ip.Nat命令总是与global命令一起使用,这是因为nat命令可以指定一台主机或一段范围的主机访问外网,访问外网时需要利用global所指定的地址池进行对外访问。nat命令配置语法:nat (if_name) nat_id local_ip [netmark]
其中(if_name)表示内网接口名字,例如inside. Nat_id用来标识全局地址池,使它与其相应的global命令相匹配,local_ip表示内网被分配的ip地址。例如0.0.0.0表示内网所有主机可以对外访问。[netmark]表示内网ip地址的子网掩码。
例1.Pix525(config)#nat (inside) 1 0 0
表示启用nat,内网的所有主机都可以访问外网,用0可以代表0.0.0.0
例2.Pix525(config)#nat (inside) 1 172.16.5.0 255.255.0.0
表示只有172.16.5.0这个网段内的主机可以访问外网。

5. 指定外部地址范围(global)
global命令把内网的ip地址翻译成外网的ip地址或一段地址范围。Global命令的配置语法:global (if_name) nat_id ip_address-ip_address [netmark global_mask]
其中(if_name)表示外网接口名字,例如outside.。Nat_id用来标识全局地址池,使它与其相应的nat命令相匹配,ip_address-ip_address表示翻译后的单个ip地址或一段ip地址范围。[netmark global_mask]表示全局ip地址的网络掩码。
例1. Pix525(config)#global (outside) 1 61.144.51.42-61.144.51.48
表示内网的主机通过pix防火墙要访问外网时,pix防火墙将使用61.144.51.42-61.144.51.48这段ip地址池为要访问外网的主机分配一个全局ip地址。
例2. Pix525(config)#global (outside) 1 61.144.51.42
表示内网要访问外网时,pix防火墙将为访问外网的所有主机统一使用61.144.51.42这个单一ip地址。
例3. Pix525(config)#no global (outside) 1 61.144.51.42
表示删除这个全局表项。

6. 设置指向内网和外网的静态路由(route)
定义一条静态路由。route命令配置语法:route (if_name) 0 0 gateway_ip [metric]
其中(if_name)表示接口名字,例如inside,outside。Gateway_ip表示网关路由器的ip地址。[metric]表示到gateway_ip的跳数。通常缺省是1。
例1. Pix525(config)#route outside 0 0 61.144.51.168 1
表示一条指向边界路由器(ip地址61.144.51.168)的缺省路由。
例2. Pix525(config)#route inside 10.1.1.0 255.255.255.0 172.16.0.1 1
Pix525(config)#route inside 10.2.0.0 255.255.0.0 172.16.0.1 1
如果内部网络只有一个网段,按照例1那样设置一条缺省路由即可;如果内部存在多个网络,需要配置一条以上的静态路由。上面那条命令表示创建了一条到网络10.1.1.0的静态路由,静态路由的下一条路由器ip地址是172.16.0.1

OK,这6个基本命令若理解了,就可以进入到pix防火墙的一些高级配置了。

A. 配置静态IP地址翻译(static)
如果从外网发起一个会话,会话的目的地址是一个内网的ip地址,static就把内部地址翻译成一个指定的全局地址,允许这个会话建立。static命令配置语法:static (internal_if_name,external_if_name) outside_ip_address inside_ ip_address 其中internal_if_name表示内部网络接口,安全级别较高。如inside.
external_if_name为外部网络接口,安全级别较低。如outside等。outside_ip_address为正在访问的较低安全级别的接口上的ip地址。inside_ ip_address为内部网络的本地ip地址。
例1. Pix525(config)#static (inside, outside) 61.144.51.62 192.168.0.8
表示ip地址为192.168.0.8的主机,对于通过pix防火墙建立的每个会话,都被翻译成61.144.51.62这个全局地址,也可以理解成static命令创建了内部ip地址192.168.0.8和外部ip地址61.144.51.62之间的静态映射。
例2. Pix525(config)#static (inside, outside) 192.168.0.2 10.0.1.3
例3. Pix525(config)#static (dmz, outside) 211.48.16.2 172.16.10.8
注释同例1。通过以上几个例子说明使用static命令可以让我们为一个特定的内部ip地址设置一个永久的全局ip地址。这样就能够为具有较低安全级别的指定接口创建一个入口,使它们可以进入到具有较高安全级别的指定接口。

B. 管道命令(conduit)
前面讲过使用static命令可以在一个本地ip地址和一个全局ip地址之间创建了一个静态映射,但从外部到内部接口的连接仍然会被pix防火墙的自适应安全算法(ASA)阻挡,conduit命令用来允许数据流从具有较低安全级别的接口流向具有较高安全级别的接口,例如允许从外部到DMZ或内部接口的入方向的会话。对于向内部接口的连接,static和conduit命令将一起使用,来指定会话的建立。
conduit命令配置语法:
conduit permit | deny global_ip port[-port] protocol foreign_ip [netmask]
permit | deny 允许 | 拒绝访问
global_ip 指的是先前由global或static命令定义的全局ip地址,如果global_ip为0,就用any代替0;如果global_ip是一台主机,就用host命令参数。
port 指的是服务所作用的端口,例如www使用80,smtp使用25等等,我们可以通过服务名称或端口数字来指定端口。
protocol 指的是连接协议,比如:TCP、UDP、ICMP等。
foreign_ip 表示可访问global_ip的外部ip。对于任意主机,可以用any表示。如果foreign_ip是一台主机,就用host命令参数。
例1. Pix525(config)#conduit permit tcp host 192.168.0.8 eq www any
这个例子表示允许任何外部主机对全局地址192.168.0.8的这台主机进行http访问。其中使用eq和一个端口来允许或拒绝对这个端口的访问。Eq ftp 就是指允许或拒绝只对ftp的访问。
例2. Pix525(config)#conduit deny tcp any eq ftp host 61.144.51.89
表示不允许外部主机61.144.51.89对任何全局地址进行ftp访问。
例3. Pix525(config)#conduit permit icmp any any
表示允许icmp消息向内部和外部通过。
例4. Pix525(config)#static (inside, outside) 61.144.51.62 192.168.0.3
Pix525(config)#conduit permit tcp host 61.144.51.62 eq www any
这个例子说明static和conduit的关系。192.168.0.3在内网是一台web服务器,现在希望外网的用户能够通过pix防火墙得到web服务。所以先做static静态映射:192.168.0.3->61.144.51.62(全局),然后利用conduit命令允许任何外部主机对全局地址61.144.51.62进行http访问。

C. 配置fixup协议
fixup命令作用是启用,禁止,改变一个服务或协议通过pix防火墙,由fixup命令指定的端口是pix防火墙要侦听的服务。见下面例子:
例1. Pix525(config)#fixup protocol ftp 21
启用ftp协议,并指定ftp的端口号为21
例2. Pix525(config)#fixup protocol http 80
Pix525(config)#fixup protocol http 1080
为http协议指定80和1080两个端口。
例3. Pix525(config)#no fixup protocol smtp 80
禁用smtp协议。

D. 设置telnet
telnet有一个版本的变化。在pix OS 5.0(pix操作系统的版本号)之前,只能从内部网络上的主机通过telnet访问pix。在pix OS 5.0及后续版本中,可以在所有的接口上启用telnet到pix的访问。当从外部接口要telnet到pix防火墙时,telnet数据流需要用ipsec提供保护,也就是说用户必须配置pix来建立一条到另外一台pix,路由器或vpn客户端的ipsec隧道。另外就是在PIX上配置SSH,然后用SSH client从外部telnet到PIX防火墙,PIX支持SSH1和SSH2,不过SSH1是免费软件,SSH2是商业软件。相比之下cisco路由器的telnet就作的不怎么样了。
telnet配置语法:telnet local_ip [netmask]
local_ip 表示被授权通过telnet访问到pix的ip地址。如果不设此项,pix的配置方式只能由console进行。

说了这么多,下面给出一个配置实例供大家参考。

Welcome to the PIX firewall

Type help or ‘?’ for a list of available commands.
PIX525> en
Password:
PIX525#sh config
: Saved
:
PIX Version 6.0(1) —— PIX当前的操作系统版本为6.0
Nameif ethernet0 outside security0
Nameif ethernet1 inside security100 —— 显示目前pix只有2个接口
Enable password 7Y051HhCcoiRTSQZ encrypted
Passed 7Y051HhCcoiRTSQZ encrypted —— pix防火墙密码在默认状态下已被加密,在配置文件中不会以明文显示,telnet 密码缺省为cisco
Hostname PIX525 —— 主机名称为PIX525
Domain-name 123.com —— 本地的一个域名服务器123.com,通常用作为外部访问
Fixup protocol ftp 21
Fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060 —— 当前启用的一些服务或协议,注意rsh服务是不能改变端口号
names —— 解析本地主机名到ip地址,在配置中可以用名字代替ip地址,当前没有设置,所以列表为空
pager lines 24 —— 每24行一分页
interface ethernet0 auto
interface ethernet1 auto —— 设置两个网卡的类型为自适应
mtu outside 1500
mtu inside 1500 —— 以太网标准的MTU长度为1500字节

ip address outside 61.144.51.42 255.255.255.248
ip address inside 192.168.0.1 255.255.255.0 —— pix外网的ip地址61.144.51.42,内网的ip地址192.168.0.1
ip audit info action alarm
ip audit attack action alarm —— pix入侵检测的2个命令。当有数据包具有攻击或报告型特征码时,pix将采取报警动作(缺省动作),向指定的日志记录主机产生系统日志消息;此外还可以作出丢弃数据包和发出tcp连接复位信号等动作,需另外配置。
pdm history enable —— PIX设备管理器可以图形化的监视PIX
arp timeout 14400 —— arp表的超时时间
global (outside) 1 61.144.51.46 —— 如果你访问外部论坛或用QQ聊天等等,上面显示的ip就是这个
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside, outside) 61.144.51.43 192.168.0.8 netmask 255.255.255.255 0 0
conduit permit icmp any any
conduit permit tcp host 61.144.51.43 eq www any
conduit permit udp host 61.144.51.43 eq domain any
—— 用61.144.51.43这个ip地址提供domain-name服务,而且只允许外部用户访问domain的udp端口
route outside 0.0.0.0 0.0.0.0 61.144.51.61 1 —— 外部网关61.144.51.61
timeout xlate 3:00:00 —— 某个内部设备向外部发出的ip包经过翻译(global)后,在缺省3个小时之后此数据包若没有活动,此前创建的表项将从翻译表中删除,释放该设备占用的全局地址
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute —— AAA认证的超时时间,absolute表示连续运行uauth定时器,用户超时后,将强制重新认证
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius —— AAA服务器的两种协议。AAA是指认证,授权,审计。Pix防火墙可以通过AAA服务器增加内部网络的安全
no snmp-server location
no snmp-server contact
snmp-server community public —— 由于没有设置snmp工作站,也就没有snmp工作站的位置和联系人
no snmp-server enable traps —— 发送snmp陷阱
floodguard enable —— 防止有人伪造大量认证请求,将pix的AAA资源用完
no sysopt route dnat
telnet timeout 5
ssh timeout 5 —— 使用ssh访问pix的超时时间
terminal width 80
Cryptochecksum:a9f03ba4ddb72e1ae6a543292dd4f5e7
PIX525#
PIX525#write memory —— 将配置保存

上面这个配置实例需要说明一下,pix防火墙直接摆在了与internet接口处,此处网络环境有十几个公有ip,可能会有朋友问如果我的公有ip很有限怎么办?你可以添加router放在pix的前面,或者global使用单一ip地址,和外部接口的ip地址相同即可。另外有几个维护命令也很有用,show interface查看端口状态,show static查看静态地址映射,show ip查看接口ip地址,ping outside | inside ip_address确定连通性。

本文只是对pix防火墙的基本配置做了相关描述,pix其他的一些功能例如AAA服务器,vpn等等限于篇幅,不再一一介绍。希望本文能够抛砖引玉,

 如何做人?八个问题.

    问题一:如果你家附近有一家餐厅,东西又贵又难吃,桌上还爬着蟑螂,你会因为它很近很方便,就一而再、再而三地光临吗?

  回答:你一定会说,这是什么烂问题,谁那么笨,花钱买罪受?

  可同样的情况换个场合,自己或许就做类似的蠢事。

  不少男女都曾经抱怨过他们的情人或配偶品性不端,三心二意,不负责任。明知在一起没什么好的结果,怨恨已经比爱还多,但却“不知道为什么”还是要和他搅和下去,分不了手。荡┝耍皇俏瞬桓剩讼肮撸獠灰埠凸饬俨吞谎?

  ——做人,为什么要过于执著?!

——————————————–

  问题二:如果你不小心丢掉100块钱,只知道它好像丢在某个你走过的地方,你会花200块钱的车费去把那100块找回来吗?

  回答:一个超级愚蠢的问题。

  可是,相似的事情却在人生中不断发生。做错了一件事,明知自己有问题,却怎么也不肯认错,反而花加倍的时间来找藉口,让别人对自己的印象大打折扣。被人骂了一句话,却花了无数时间难过,道理相同。为一件事情发火,不惜损人不利已,不惜血本,不惜时间,只为报复,不也一样无聊?

  失去一个人的感情,明知一切已无法挽回,却还是那么伤心,而且一伤心就是好几年,还要借酒浇愁,形销骨立。其实这样一点用也没有,只是损失更多。

  ——做人,干吗为难自己?!

——————————————–

  问题三:你会因为打开报纸发现每天都有车祸,就不敢出门吗?

  回答:这是个什么烂问题?当然不会,那叫因噎废食。

  然而,有不少人却曾说:现在的离婚率那么高,让我都不敢谈恋爱了。说得还挺理所当然。也有不少女人看到有关的诸多报道,就对自己的另一半忧心忡忡,这不也是类似的反应?所谓乐观,就是得相信:虽然道路多艰险,我还是那个会平安过马路的人,只要我小心一点,不必害怕过马路。

  ——做人,先要相信自己。

——————————————–

  问题四:你相信每个人随便都可以成功立业吗?

  回答:当然不会相信。

  但据观察,有人总是在听完成功人士绞尽脑汁的建议,比如说,多读书,多练习之后,问了另一个问题?那不是很难?

  我们都想在3分钟内学好英文,在5分钟内解决所有难题,难道成功是那么容易的吗?改变当然是难的。成功只因不怕困难,所以才能出类拔萃。

  有一次坐在出租车上,听见司机看到自己前后都是高档车,兀自感叹:“唉,为什么别人那么有钱,我的钱这么难赚?”

  我心血来潮,问他:“你认为世上有什么钱是好赚的?”他答不出来,过了半晌才说:好像都是别人的钱比较好赚。

  其实任何一个成功者都是艰辛取得。我们实在不该抱怨命运。

  ——做人,依*自己!

——————————————–

  问题五:你认为完全没有打过篮球的人,可以当很好的篮球教练吗?

  回答:当然不可能,外行不可能领导内行。

  可是,有许多人,对某个行业完全不了解,只听到那个行业好赚钱,就马上开起业来了。

  我看过对穿着没有任何口味、或根本不在乎穿着的人,梦想却是开间服装店;不知道电脑怎么开机的人,却想在网上聊天,结果道听途说,却不反省自己是否专业能力不足,只抱怨时不我与。

  ——做人,量力而行。

——————————————–

  问题六:相似但不相同的问题:你是否认为,篮球教练不上篮球场,闭着眼睛也可以主导一场完美的胜利?

  回答:有病啊,当然是不可能的。

  可是却有不少朋友,自己没有时间打理,却拼命投资去开咖啡馆,开餐厅,开自己根本不懂的公司,火烧屁股一样急着把辛苦积攒的积蓄花掉,去当一个稀里糊涂的投资人。亏的总是比赚的多,却觉得自己是因为运气不好,而不是想法出了问题。

  ——做人,记得反省自己。

——————————————–

  问题七:你宁可永远后悔,也不愿意试一试自己能否转败为胜?

  解答:恐怕没有人会说:“对,我就是这样的孬种”吧。

  然而,我们却常常在不该打退堂鼓时拼命打退堂鼓,为了恐惧失败而不敢尝试成功。

  以关颖珊赢得2000年世界花样滑冰冠军时的精彩表现为例:她一心想赢得第一名,然而在最后一场比赛前,她的总积分只排名第三位,在最后的自选曲项目上,她选择了突破,而不是少出错。在4分钟的长曲中,结合了最高难度的三周跳,并且还大胆地连跳了两次。她也可能会败得很难看,但是她毕竟成功了。

  她说:“因为我不想等到失败,才后悔自己还有潜力没发挥。”

  一个中国伟人曾说;胜利的希望和有利情况的恢复,往往产生于再坚持一下的努力之中。

  ——做人,何妨放手一搏。

——————————————–

  问题八:你的时间无限,长生不老,所以最想做的事,应该无限延期?

  回答:不,傻瓜才会这样认为。

  然而我们却常说,等我老了,要去环游世界;等我退休,就要去做想做的事情;等孩子长大了,我就可以……

  我们都以为自己有无限的时间与精力。其实我们可以一步一步实现理想,不必在等待中徒耗生命。如果现在就能一步一步努力接近,我们就不会活了半生,却出现自己最不想看到的结局。

  ——做人,要活在当下。

2004年09月26日

品葡萄酒的艺术

品酒是一种艺术,同时也是一个专业的领域,尤其属于艺术方面的成分多,而属于科学方面的成分少。科学与艺术的最大分别,在于科学能用数的计算葡萄酒量之多寡,色之深浅,香或味之浓淡;而品酒则只可心领神会而不能定其数量。譬如有一幅价值连城之名画,若使用科学方法分析名画美的程度如何,虽画师本人,亦将瞠目莫知所对;反之,若想知道一块贵重金属中的含量如何,就容易许多,只须应用定量分析的法则,虽经由不同专家检测,只要分析的方法正确无误,其所得结果必皆相等,科学与艺术的界限,由此可见其端倪。

  葡萄酒的色、香、味

  葡萄酒为液体的饮料,具有特殊的颜色和香气。颜色是从葡萄皮所含的色素,及梗实内所含的单宁(tannin)结合而成,借液汁中酸性物体的存在,使得葡萄酒光泽分外鲜明。香气的来源,是由于各种挥发性物质,纯酒精几乎完全无臭,酸与酒精结合所成的脂类,是葡萄酒香气的首要成分;此外,还多了几种化学成分的香素,其含量极微,但号称佳酿的葡萄酒,多含有此种特殊的香素,为某一地域或某一葡萄园所产的葡萄专有,不是人工的巧妙所能仿造而得的。

  讲到葡萄酒的味道,是一个更复杂的问题。一般言之,我们拟想葡萄酒给予口的感应,来自于味觉,生理学家只承认有四种基本的味儿存在,即酸、甜、苦、咸。涩味和金属味,都不过是两种基本味道的合成。

  但不论是谁,能把一小口葡萄酒饮入口中后,立刻会感到四种简单的基本味道,去表示这酒的复杂性,可能性很低。生理学家麦考-佛斯特说:“品尝葡萄酒的味道,实际是嗅酒之香”。如果把两个鼻孔捏住去喝葡萄酒,将感到索然无味。那么,享受葡萄酒的佳妙者,无疑为的是嗅觉而非味觉了。自然界有无数芳香气味,呈现于人们的嗅觉,就是因为这些芳香物质种类的变化,才使法国葡萄酒成为世界之最。

  品葡萄酒的两种方法

  品酒的方式有两种,一是水平式品酒法,另一是垂直式品酒法,两种品酒方法,让品酒人体会同中求异,异中求同的乐趣。以同一年份,但不同酒庄或产区之葡萄酒作为相互比较之品酒方式,称为水平式品酒法。以同一酒庄或同一品牌之葡萄酒,但不同年份之品酒方式,称为垂直式品酒法。

  通常水平式品酒法,初学者比较可能接受,垂直式品酒法,对专业品酒人比较适合。不过,若是以交叉式品酒法来进行,可能最经济实惠,例如:假设品酒的酒款有六种,不妨三种酒款以水平式品酒法进行,另外三种酒款以垂直式品酒法,如此,品酒的实务经验可达到事半功倍之效果。

  品酒前之准备

  酒杯:使用郁金香之酒杯(ISO葡萄酒杯最佳),无色透明之水晶或玻璃材质。

  光源:以阳光之光源最佳,一般人造之光源(日光灯)会影响酒的颜色及色调之判断。

  温度:于室温下进行(约16-18度左右),场内不可吸烟,或有异常之香味(如香水、古龙水)。

  不提示品酒法(盲品)练习:以限定品酒之目标开始,并很清楚所品尝的是什么葡萄酒?当然品酒后是无法一次即能马上就指出葡萄酒的品种、地区、品质、成熟度、及酒的价钱。以葡萄酒之颜色作为年份及葡萄品种的线索。品酒前先行将每一杯酒闻过。先于静止时做一次闻气之步骤,然后再闻经摇动后的葡萄酒气味。鼻子是判断葡萄品种最佳的利器,而葡萄品种是品酒中非常重要的线索。于口、舌搜寻酒精/酒酸/单宁的均衡性,这些是寻找葡萄地理地域重要的线索。体会酒质粗细之结构,在口、舌发展的情形与余韵之长度,这是获得葡萄品质的最佳线索。通常第一印象是最可靠的。

  无提示品酒法(盲品)练习:以不同的杯子盛装不同的葡萄酒(假如是一个人自己进行,最好于杯子底端贴上颜色或号码,于相对的瓶子也做同样步骤,以免混淆不清)经品尝后,需判别是什么样的葡萄酒,并尽可能的把它形容出来。注意每一呈现出来的特征,如不甜/甜、酒酸、单宁、酒精(高或低)及每个特别难忘的气味特色。

  品酒实务练习

  视觉:从杯子正上方观察看:观看酒的清澈度、干净度、颜色的深度,以及是否有二氧化碳。从杯子45°斜角观看:观察酒〖眼〗的色调,酒缘的宽度,及颜色细微的差别。从杯子的侧面观察:观察酒的粘度,如泪珠状、腿状或拱状,以流速及形状判断酒的质量。

  嗅觉:摇酒前,先闻静置下的气味:闻葡萄酒各种原始气味的结构性、纯度,此时有些比较封闭的气味可能尚未凝聚成明显的气味。摇酒后,迅速的深闻从杯内释出的气味:比较静态下与摇动后气味的相异处,气味是否较先前重,气味的发展是否更集中稳定。闻酒气、酒香时,可从杯子不同的位置寻找最明显的气味(杯口之中央位置、背口上缘及下缘),或葡萄酒典型之气息。由于杯子里的葡萄酒液,经过摇动后,酒液与空气接触,会唤醒隐藏的气息,此时更容易判断从杯子里所释出气味。

  上下震荡:当怀疑所品鉴的葡萄酒,有瑕疵或异味时,可将杯子以上下震荡的方式,唤醒隐藏及不易释出的杂味,并且印证察觉不佳的气味。

  味觉:喝一小口,约一茶匙左右之量:感受原始口感,柔和或坚实的,酸及单宁之粗涩感出两年时间有多快,是否感受到二氧化碳的存在。

  以舌头搅动含在嘴里的葡萄酒:气味是否恰到好处,感受味道的特性,酸、甜、苦、辣、咸,以及酒的均衡度。

  吐出含在口中的葡萄酒:感受残留在口中的余味和余韵的长度、均衡度,并将嗅觉及味觉的印象综合在记忆中。

  葡萄酒能给予饮者不可思议的美感,古来诗人墨客,常藉此为遣愁助兴,它的功用,在不超过一定限度的时候,可使神志清明,身心舒适,增进血液的循环,促进精神的兴奋。专家们将此作用归于酒精的作用,然而葡萄酒的品质,却不尽在酒精含量的多寡。科学之日新月异和进步,蒸馏机的改良,95%以上的纯酒精随时可以蒸馏获得。然而极为优异的葡萄酒,含酒精量大多不超过15%,足见酒精并非优异葡萄酒之主要条件,纯酒精不等于佳酿,亦犹如名画,虽由水彩颜料构成,可是不能解释为有水彩颜料即可成为名画,事虽不同,但其道理是一样的。因此,欲鉴别一种葡萄酒的优劣,其关系十分复杂,一方面固然需要相当品酒的学识,同时亦须具有长期品酒的经验。

2004年09月25日

你那里下雨了吗??

YES!!

不过这次落下的可是货真价实的金币雨哦。

不相信吗?那就做以下的三件事吧:

  • 登陆www.51ttup.com

  • 注册网站会员 [ 进入注册 ]
  • 点击广告进入金币系统,登陆
  • 点击网站界面随即出现的金币或白金币

就这么简单,收集金币数目最多的会员可以获得时尚摄象手机一部。

另外将设置而二等将2名:高档MP3一部

三等奖99名:芙蓉学子纪念套装(帽子+T恤+杯子)

四等奖199名:T恤+杯子

五等奖999名:杯子一个

惊喜奖99名:随机出现的白金币一枚即可换取杯子一个。

千份大礼等你来拿,好礼多多,机会多多,现在就行动吧!

天上掉馅饼的神话就在这个初秋时分发生在你我身边…………

活动时间:2004年9月25日至10月25日

网站地址在右边的联里面.

相关连接http://bbs.51ttup.com/Dispbbs.asp?boardid=6&ID=1560&replyID=15356&skin=1

相当多的证据表明.Google正在开发浏览器http://www.donews.net/uiokyu/archive/2004/09/24/108849.aspx

Google正在投重金进行JavaScript桌面程序的开发。Google可以利用它在这方面的优势去开发Mozilla程序,象内置的网络日志工具,内置Gmail邮件工具,内置的搜索工具等等..

免费网络电子邮件Gmail 我正用着

搜索工具GoogleDeskbar 我试过

购物搜索引擎Froogle 看了看

书籍搜索服务GooglePrint 也看了

还有传言称,Google可能将最终推出一种即时通讯软件 gg? 和qq对抗?

还有消息说,Google正在开发一种瘦客户的操作系统 google-xp?

技术人士甚至还谈到了Google有可能成为一种文件存储系统。 fxgo?

 

Google不断让人们对它产生好奇