2007年01月10日

      随着网络硬件性能的不断提高、成本的不断降低,目前新建立的校园网基本上都采用了性能先进的千兆网技术,其核心交换机采用三层交换机,它能很好地支持虚拟局域网(VLAN)技术,这对方便校园网的管理、保证校园网的高速可靠运行起到了非常重要的作用。

         什么是VLAN

         VLAN(VirtualLocalAreaNetwork)又称虚拟局域网,是指在交换局域网的基础上,采用网络管理软件构建的可跨越不同网段、不同网络的端到端的逻辑网络。一个VLAN组成一个逻辑子网,即一个逻辑广播域,它可以覆盖多个网络设备,允许处于不同地理位置的网络用户加入到一个逻辑子网中。

        组建VLAN的条件

         VLAN是建立在物理网络基础上的一种逻辑子网,因此建立VLAN需要相应的支持VLAN技术的网络设备。当网络中的不同VLAN间进行相互通信时,需要路由的支持,这时就需要增加路由设备——要实现路由功能,既可采用路由器,也可采用三层交换机来完成。

         划分VLAN的基本策略

         从技术角度讲,VLAN的划分可依据不同原则,一般有以下三种划分方法:

        1、基于端口的VLAN划分

         这种划分是把一个或多个交换机上的几个端口划分一个逻辑组,这是最简单、最有效的划分方法。该方法只需网络管理员对网络设备的交换端口进行重新分配即可,不用考虑该端口所连接的设备。

         2、基于MAC地址的VLAN划分

         MAC地址其实就是指网卡的标识符,每一块网卡的MAC地址都是惟一且固化在网卡上的。MAC地址由12位16进制数表示,前8位为厂商标识,后4位为网卡标识。网络管理员可按MAC地址把一些站点划分为一个逻辑子网。

         3、基于路由的VLAN划分

         路由协议工作在网络层,相应的工作设备有路由器和路由交换机(即三层交换机)。该方式允许一个VLAN跨越多个交换机,或一个端口位于多个VLAN中。

     就目前来说,对于VLAN的划分主要采取上述第1、3种方式,第2种方式为辅助性的方案。

        使用VLAN优点

        使用VLAN具有以下优点:

        1、控制广播风暴

         一个VLAN就是一个逻辑广播域,通过对VLAN的创建,隔离了广播,缩小了广播范围,可以控制广播风暴的产生。

        2、提高网络整体安全性

         通过路由访问列表和MAC地址分配等VLAN划分原则,可以控制用户访问权限和逻辑网段大小,将不同用户群划分在不同VLAN,从而提高交换式网络的整体性能和安全性。

        3、网络管理简单、直观

         对于交换式以太网,如果对某些用户重新进行网段分配,需要网络管理员对网络系统的物理结构重新进行调整,甚至需要追加网络设备,增大网络管理的工作量。而对于采用VLAN技术的网络来说,一个VLAN可以根据部门职能、对象组或者应用将不同地理位置的网络用户划分为一个逻辑网段。在不改动网络物理连接的情况下可以任意地将工作站在工作组或子网之间移动。利用虚拟网络技术,大大减轻了网络管理和维护工作的负担,降低了网络维护费用。在一个交换网络中,VLAN提供了网段和机构的弹性组合机制。

         三层交换技术

         传统的路由器在网络中有路由转发、防火墙、隔离广播等作用,而在一个划分了VLAN以后的网络中,逻辑上划分的不同网段之间通信仍然要通过路由器转发。由于在局域网上,不同VLAN之间的通信数据量是很大的,这样,如果路由器要对每一个数据包都路由一次,随着网络上数据量的不断增大,路由器将不堪重负,路由器将成为整个网络运行的瓶颈。

      在这种情况下,出现了第三层交换技术,它是将路由技术与交换技术合二为一的技术。三层交换机在对第一个数据流进行路由后,会产生一个MAC地址与IP地址的映射表,当同样的数据流再次通过时,将根据此表直接从二层通过而不是再次路由,从而消除了路由器进行路由选择而造成网络的延迟,提高了数据包转发的效率,消除了路由器可能产生的网络瓶颈问题。可见,三层交换机集路由与交换于一身,在交换机内部实现了路由,提高了网络的整体性能。

      在以三层交换机为核心的千兆网络中,为保证不同职能部门管理的方便性和安全性以及整个网络运行的稳定性,可采用VLAN技术进行虚拟网络划分。VLAN子网隔离了广播风暴,对一些重要部门实施了安全保护;且当某一部门物理位置发生变化时,只需对交换机进行设置,就可以实现网络的重组,非常方便、快捷,同时节约了成本。

二层交换技术是发展比较成熟,二层交换机属数据链路层设备,可以识别数据包中的MAC地址信息,根据MAC地址进行转发,并将这些MAC地址与对应的端口记录在自己内部的一个地址表中。具体的工作流程如下:

(1)当交换机从某个端口收到一个数据包,它先读取包头中的源MAC地址,这样它就知道源MAC地址的机器是连在哪个端口上的;

(2)再去读取包头中的目的MAC地址,并在地址表中查找相应的端口;

(3)如表中有与这目的MAC地址对应的端口,把数据包直接复制到这端口上;

(4)如表中找不到相应的端口则把数据包广播到所有端口上,当目的机器对源机器回应
时,交换机又可以学习一目的MAC地址与哪个端口对应,在下次传送数据时就不再需要对所
有端口进行广播了。

不断的循环这个过程,对于全网的MAC地址信息都可以学习到,二层交换机就是这样建立和
维护它自己的地址表。

从二层交换机的工作原理可以推知以下三点:

(1)由于交换机对多数端口的数据进行同时交换,这就要求具有很宽的交换总线带宽,
如果二层交换机有N个端口,每个端口的带宽是M,交换机总线带宽超过N×M,那么这交换机就可以实现线速交换;

(2)学习端口连接的机器的MAC地址,写入地址表,地址表的大小(一般两种表示方式:
一为BEFFER RAM,一为MAC表项数值),地址表大小影响交换机的接入容量;

(3) 还有一个就是二层交换机一般都含有专门用于处理数据包转发的ASIC (Applicati
on specific Integrated Circuit)芯片,因此转发速度可以做到非常快。由于各个厂家
采用ASIC不同,直接影响产品性能。

以上三点也是评判二三层交换机性能优劣的主要技术参数,这一点请大家在考虑设备选型
时注意比较。

(二)路由技术

路由器工作在OSI模型的第三层—网络层操作,其工作模式与二层交换相似,但路由器工作在第三层,这个区别决定了路由和交换在传递包时使用不同的控制信息,实现功能的方式就不同。工作原理是在路由器的内部也有一个表,这个表所标示的是如果要去某一个地方,下一步应该向那里走,如果能从路由表中找到数据包下一步往那里走,把链路层信息加上转发出去;如果不能知道下一步走向那里,则将此包丢弃,然后返回一个信息交给源地址。

路由技术实质上来说不过两种功能:决定最优路由和转发数据包。路由表中写入各种信息由路由算法计算出到达目的地址的最佳路径,然后由相对简单直接的转发机制发送数据包。接受数据的下一台路由器依照相同的工作方式继续转发,依次类推,直到数据包到达目的路由器。

而路由表的维护,也有两种不同的方式。一种是路由信息的更新,将部分或者全部的路由信息公布出去,路由器通过互相学习路由信息,就掌握了全网的拓扑结构,这一类的路由协议称为距离矢量路由协议;另一种是路由器将自己的链路状态信息进行广播,通过互相学习掌握全网的路由信息,进而计算出最佳的转发路径,这类路由协议称为链路状态路由协议。

由于路由器需要做大量的路径计算工作,一般处理器的工作能力直接决定其性能的优劣。当然这一判断还是对中低端路由器而言,因为高端路由器往往采用分布式处理系统体系设
计。

(三)三层交换技术

近年来的对三层技术的宣传,耳朵都能起茧子,到处都在喊三层技术,有人说这是个非常新的技术,也有人说,三层交换嘛,不就是路由器和二层交换机的堆叠,也没有什么新的玩意,事实果真如此吗?下面先来通过一个简单的网络来看看三层交换机的工作过程。

组网比较简单

使用IP的设备A————————三层交换机————————使用IP的
设备B

比如A要给B发送数据,已知目的IP,那么A就用子网掩码取得网络地址,判断目的IP是否与
自己在同一网段。

如果在同一网段,但不知道转发数据所需的MAC地址,A就发送一个ARP请求,B返回其MAC地
址,A用此MAC封装数据包并发送给交换机,交换机起用二层交换模块,查找MAC地址表,将
数据包转发到相应的端口。

如果目的IP地址显示不是同一网段的,那么A要实现和B的通讯,在流缓存条目中没有对应
MAC地址条目,就将第一个正常数据包发送向一个缺省网关,这个缺省网关一般在操作系统
中已经设好,对应第三层路由模块,所以可见对于不是同一子网的数据,最先在MAC表中放
的是缺省网关的MAC地址;然后就由三层模块接收到此数据包,查询路由表以确定到达B的
路由,将构造一个新的帧头,其中以缺省网关的MAC地址为源MAC地址,以主机B的MAC地址
为目的MAC地址。通过一定的识别触发机制,确立主机A与B的MAC地址及转发端口的对应关
系,并记录进流缓存条目表,以后的A到B的数据,就直接交由二层交换模块完成。这就通
常所说的一次路由多次转发。

以上就是三层交换机工作过程的简单概括,可以看出三层交换的特点:

由硬件结合实现数据的高速转发。

这就不是简单的二层交换机和路由器的叠加,三层路由模块直接叠加在二层交换的高速背
板总线上,突破了传统路由器的接口速率限制,速率可达几十Gbit/s。算上背板带宽,这
些是三层交换机性能的两个重要参数。

简洁的路由软件使路由过程简化。

大部分的数据转发,除了必要的路由选择交由路由软件处理,都是又二层模块高速转发,
路由软件大多都是经过处理的高效优化软件,并不是简单照搬路由器中的软件。

结论

二层交换机用于小型的局域网络。这个就不用多言了,在小型局域网中,广播包影响不大
,二层交换机的快速交换功能、多个接入端口和低谦价格为小型网络用户提供了很完善的
解决方案。

路由器的优点在于接口类型丰富,支持的三层功能强大,路由能力强大,适合用于大型的
网络间的路由,它的优势在于选择最佳路由,负荷分担,链路备份及和其他网络进行路由
信息的交换等等路由器所具有功能。

三层交换机的最重要的功能是加快大型局域网络内部的数据的快速转发,加入路由功能也
是为这个目的服务的。如果把大型网络按照部门,地域等等因素划分成一个个小局域网,
这将导致大量的网际互访,单纯的使用二层交换机不能实现网际互访;如单纯的使用路由
器,由于接口数量有限和路由转发速度慢,将限制网络的速度和网络规模,采用具有路由
功能的快速转发的三层交换机就成为首选。

一般来说,在内网数据流量大,要求快速转发响应的网络中,如全部由三层交换机来做这
个工作,会造成三层交换机负担过重,响应速度受影响,将网间的路由交由路由器去完成
,充分发挥不同设备的优点,不失为一种好的组网策略,当然,前提是客户的腰包很鼓,
不然就退而求其次,让三层交换机也兼为网际互连。

第四层交换的一个简单定义是:它是一种功能,它决定传输不仅仅依据MAC地址(第二层网
桥)或源/目标IP地址(第三层路由),而且依据TCP/UDP(第四层) 应用端口号。第四层交换功
能就象是虚IP,指向物理服务器。它传输的业务服从的协议多种多样,有HTTP、FTP、NFS
、Telnet或其他协议。这些业务在物理服务器基础上,需要复杂的载量平衡算法。在IP世
界,业务类型由终端TCP或UDP端口地址来决定,在第四层交换中的应用区间则由源端和终
端IP地址、TCP和UDP端口共同决定。
 在第四层交换中为每个供搜寻使用的服务器组设立虚IP地址(VIP),每组服务器支持
某种应用。在域名服务器(DNS)中存储的每个应用服务器地址是VIP,而不是真实的服务
器地址。
 当某用户申请应用时,一个带有目标服务器组的VIP连接请求(例如一个TCP SYN包)发
给服务器交换机。服务器交换机在组中选取最好的服务器,将终端地址中的VIP用实际服务
器的IP取代,并将连接请求传给服务器。这样,同一区间所有的包由服务器交换机进行映
射,在用户和同一服务器间进行传输。
第四层交换的原理
  OSI模型的第四层是传输层。传输层负责端对端通信,即在网络源和目标系统之间协调
通信。在IP协议栈中这是TCP(一种传输协议)和UDP(用户数据包协议)所在的协议层。

 在第四层中,TCP和UDP标题包含端口号(portnumber),它们可以唯一区分每个数据包
包含哪些应用协议(例如HTTP、FTP等)。端点系统利用这种信息来区分包中的数据,尤其
是端口号使一个接收端计算机系统能够确定它所收到的IP包类型,并把它交给合适的高层
软件。端口号和设备IP地址的组合通常称作“插口(socket)”。
  1和255之间的端口号被保留,他们称为“熟知”端口,也就是说,在所有主机TCP/I

P协议栈实现中,这些端口号是相同的。除了“熟知”端口外,标准UNIX服务分配在256到
1024端口范围,定制的应用一般在1024以上分配端口号.
   分配端口号的最近清单可以在RFc1700”Assigned Numbers”上找到。TCP/UDP端

口号提供的附加信息可以为网络交换机所利用,这是第4层交换的基础。
   "熟知"端口号举例:
  
       应用协议     端口号
       FTP        20(数据)
                  21(控制)
       TELNET    23
       SMTP      25
       HTTP       80
       NNTP      119
       NNMP      16
                  162(SNMP traps)
  TCP/UDP端口号提供的附加信息可以为网络交换机所利用,这是第四层交换的基础。

 具有第四层功能的交换机能够起到与服务器相连接的“虚拟IP”(VIP)前端的作用。

每台服务器和支持单一或通用应用的服务器组都配置一个VIP地址。这个VIP地址被发送出
去并在域名系统上注册。
 在发出一个服务请求时,第四层交换机通过判定TCP开始,来识别一次会话的开始。然
后它利用复杂的算法来确定处理这个请求的最佳服务器。一旦做出这种决定,交换机就将
会话与一个具体的IP地址联系在一起,并用该服务器真正的IP地址来代替服务器上的VIP地
址。

 每台第四层交换机都保存一个与被选择的服务器相配的源IP地址以及源TCP 端口相

关联的连接表。然后第四层交换机向这台服务器转发连接请求。所有后续包在客户机与服
务器之间重新影射和转发,直到交换机发现会话为止。
 在使用第四层交换的情况下,接入可以与真正的服务器连接在一起来满足用户制定的规
则,诸如使每台服务器上有相等数量的接入或根据不同服务器的容量来分配传输流。

如何选用合适的第四层交换
   a,速度
 为了在企业网中行之有效,第四层交换必须提供与第三层线速路由器可比拟的性能。也
就是说,第四层交换必须在所有端口以全介质速度操作,即使在多个千兆以太网连接上亦
如此。千兆以太网速度等于以每秒1488000 个数据包的最大速度路由(假定最坏的情形,即
所有包为以及网定义的最小尺寸,长64字节)。
   b,服务器容量平衡算法
  
 依据所希望的容量平衡间隔尺寸,第四层交换机将应用分配给服务器的算法有很多种,
有简单的检测环路最近的连接、检测环路时延或检测服务器本身的闭环反馈。在所有的预
测中,闭环反馈提供反映服务器现有业务量的最精确的检测。
   c,表容量
 应注意的是,进行第四层交换的交换机需要有区分和存贮大量发送表项的能力。交换机
在一个企业网的核心时尤其如此。许多第二/ 三层交换机倾向发送表的大小与网络设备的
数量成正比。对第四层交换机,这个数量必须乘以网络中使用的不同应用协议和会话的数
量。因而发送表的大小随端点设备和应用类型数量的增长而迅速增长。第四层交换机设计
者在设计其产品时需要考虑表的这种增长。大的表容量对制造支持线速发送第四层流量的
高性能交换机至关重要.
   d,冗余
 第四层交换机内部有支持冗余拓扑结构的功能。在具有双链路的网卡容错连接时,就可
能建立从一个服务器到网卡,链路和服务器交换器的完全冗余系统。

 
   一、概述

   交换技术是一个具有简化、低价、高性能和高端口密集特点的交换产品,体现了桥接技术的复杂交换技术在OSI参考模型的第二层操作。与桥接器一样,交换机按每一个包中的MAC地址相对简单地决策信息转发。而这种转发决策一般不考虑包中隐藏的更深的其他信息。与桥接器不同的是交换机转发延迟很小,操作接近单个局域网性能,远远超过了普通桥接互联网络之间的转发性能。

   交换技术允许共享型和专用型的局域网段进行带宽调整,以减轻局域网之间信息流通出现的瓶颈问题。现在已有以太网、快速以太网、FDDI和ATM技术的交换产品。

   交换机能经济地将网络分成小的冲突网域,为每个工作站提供更高的带宽。协议的透明性使得交换机在软件配置简单的情况下直接安装在多协议网络中;交换机使用现有的电缆、中继器、集线器和工作站的网卡,不必作高层的硬件升级;交换机对工作站是透明的,这样管理开销低廉,简化了网络节点的增加、移动和网络变化的操作。

   利用专门设计的集成电路可使交换机以线路速率在所有的端口并行转发信息,提供了比传统桥接器高得多的操作性能。专用集成电路技术使得交换器在更多端口的情况下以上述性能运行,其端口造价低于传统型桥接器。

   二、三种交换技术

   1.端口交换

   端口交换技术最早出现在插槽式的集线器中,这类集线器的背板通常划分有多条以太网段(每条网段为一个广播域),不用网桥或路由连接,网络之间是互不相通的。以大主模块插入后通常被分配到某个背板的网段上,端口交换用于将以太模块的端口在背板的多个网段之间进行分配、平衡。根据支持的程度,端口交换还可细分为:

   模块交换:将整个模块进行网段迁移。

   端口组交换:通常模块上的端口被划分为若干组,每组端口允许进行网段迁移。

   端口级交换:支持每个端口在不同网段之间进行迁移。这种交换技术是基于OSI第一层上完成的,具有灵活性和负载平衡能力等优点。如果配置得当,那么还可以在一定程度进行客错,但没有改变共享传输介质的特点,自而未能称之为真正的交换。

   2.帧交换

   帧交换是目前应用最广的局域网交换技术,它通过对传统传输媒介进行微分段,提供并行传送的机制,以减小冲突域,获得高的带宽。一般来讲每个公司的产品的实现技术均会有差异,但对网络帧的处理方式一般有以下几种:

   直通交换:提供线速处理能力,交换机只读出网络帧的前14个字节,便将网络帧传送到相应的端口上。 

  存储转发:通过对网络帧的读取进行验错和控制。 

  前一种方法的交换速度非常快,但缺乏对网络帧进行更高级的控制,缺乏智能性和安全性,同时也无法支持具有不同速率的端口的交换。因此,各厂商把后一种技术作为重点。

   有的厂商甚至对网络帧进行分解,将帧分解成固定大小的信元,该信元处理极易用硬件实现,处理速度快,同时能够完成高级控制功能(如美国MADGE公司的LET集线器)如优先级控制。

   3.信元交换

   ATM技术代表了网络和通讯技术发展的未来方向,也是解决目前网络通信中众多难题的一剂“良药”,ATM采用固定长度53个字节的信元交换。由于长度固定,因而便于用硬件实现。ATM采用专用的非差别连接,并行运行,可以通过一个交换机同时建立多个节点,但并不会影响每个节点之间的通信能力。ATM还容许在源节点和目标、节点建立多个虚拟链接,以保障足够的带宽和容错能力。ATM采用了统计时分电路进行复用,因而能大大提高通道的利用率。ATM的带宽可以达到25M、155M、622M甚至数Gb的传输能力。

   三、局域网交换机的种类和选择

   局域网交换机根据使用的网络技术可以分为:

   以大网交换机;

   令牌环交换机;

   FDDI交换机;

   ATM交换机;

   快速以太网交换机等。

   如果按交换机应用领域来划分,可分为: 

  台式交换机;

   工作组交换机;

   主干交换机;

   企业交换机;

   分段交换机;

   端口交换机;

   网络交换机等。 

  局域网交换机是组成网络系统的核心设备。对用户而言,局域网交换机最主要的指标是端口的配置、数据交换能力、包交换速度等因素。因此,在选择交换机时要注意以下事项:

   (1)交换端口的数量;

   (2)交换端口的类型;

   (3)系统的扩充能力;

   (4)主干线连接手段;

   (5)交换机总交换能力;

   (6)是否需要路由选择能力;

   (7)是否需要热切换能力;

   (8)是否需要容错能力;

   (9)能否与现有设备兼容,顺利衔接;

   (10)网络管理能力。

   四、交换机应用中几个值得注意的问题

   1.交换机网络中的瓶颈问题

   交换机本身的处理速度可以达到很高,用户往往迷信厂商宣传的Gbps级的高速背板。其实这是一种误解,连接入网的工作站或服务器使用的网络是以大网,它遵循CSMA/CD介质访问规则。在当前的客户/服务器模式的网络中多台工作站会同时访问服务器,因此非常容易形成服务器瓶颈。有的厂商已经考虑到这一点,在交换机中设计了一个或多个高速端口(如3COM的Linkswitch1000可以配置一个或两个100Mbps端口),方便用户连接服务器或高速主干网。用户也可以通过设计多台服务器(进行业务划分)或追加多个网卡来消除瓶颈。交换机还可支持生成树算法,方便用户架构容错的冗余连接。

   2.网络中的广播帧

 目前广泛使用的网络操作系统有Netware、Windows NT等,而Lan Server的服务器是通过发送网络广播帧来向客户机提供服务的。这类局域网中广播包的存在会大大降低交换机的效率,这时可以利用交换机的虚拟网功能(并非每种交换机都支持虚拟网)将广播包限制在一定范围内。

   每台文交换机的端口都支持一定数目的MAC地址,这样交换机能够“记忆”住该端口一组连接站点的情况,厂商提供的定位不同的交换机端口支持MAC数也不一样,用户使用时一定要注意交换机端口的连接端点数。如果超过厂商给定的MAC数,交换机接收到一个网络帧时,只有其目的站的MAC地址不存在于该交换机端口的MAC地址表中,那么该帧会以广播方式发向交换机的每个端口。

   3.虚拟网的划分

   虚拟网是交换机的重要功能,通常虚拟网的实现形式有三种:

   (1)静态端口分配

  静态虚拟网的划分通常是网管人员使用网管软件或直接设置交换机的端口,使其直接从属某个虚拟网。这些端口一直保持这些从属性,除非网管人员重新设置。这种方法虽然比较麻烦,但比较安全,容易配置和维护。

   (2)动态虚拟网

   支持动态虚拟网的端口,可以借助智能管理软件自动确定它们的从属。端口是通过借助网络包的MAC地址、逻辑地址或协议类型来确定虚拟网的从属。当一网络节点刚连接入网时,交换机端口还未分配,于是交换机通过读取网络节点的MAC地址动态地将该端口划入某个虚拟网。这样一旦网管人员配置好后,用户的计算机可以灵活地改变交换机端口,而不会改变该用户的虚拟网的从属性,而且如果网络中出现未定义的MAC地址,则可以向网管人员报警。

   (3)多虚拟网端口配置

 该配置支持一用户或一端口可以同时访问多个虚拟网。这样可以将一台网络服务器配置成多个业务部门(每种业务设置成一个虚拟网)都可同时访问,也可以同时访问多个虚拟网的资源,还可让多个虚拟网间的连接只需一个路由端口即可完成。但这样会带来安全上的隐患。虚拟网的业界规范正在制定当中,因而各个公司的产品还谈不上互操作性。Cisco公司开发了Inter-Switch Link(ISL)虚拟网络协议,该协议支持跨骨干网(ATM、FDDI、Fast Ethernet)的虚拟网。但该协议被指责为缺乏安全性上的考虑。传统的计算机网络中使用了大量的共享式Hub,通过灵活接入计算机端口也可以获得好的效果。

   4.高速局域网技术的应用

   快速以太网技术虽然在某些方面与传统以大网保持了很好的兼容性,但100BASE-TX、100BASAE-T4及100BASE-FX对传输距离和级连都有了比较大的限制。通过100Mbps的交换机可以打破这些局限。同时也只有交换机端口才可以支持双工高速传输。

   目前也出现了CDDI/FDDI的交换技术,另外该CDDI/FDDI的端口价格也呈下降趋势,同时在传输距离和安全性方面也有比较大的优势,因此它是大型网络骨干的一种比较好的选择。

   3COM的主要交换产品有Linkswitch系列和LANplex系列;BAY的主要交换产品有LattisSwitch2800,BAY stack workgroup、System3O00/5000(提供某些可选交换模块);Cisco的主要交换产品有Catalyst 1000/2000/3000/5000系列。

   三家公司的产品形态看来都有相似之处,产品的价格也比较接近,除了设计中要考虑网络环境的具体需要(强调端口的搭配合理)外,还需从整体上考虑,例如网管、网络应用等。随着ATM技术的发展和成熟以及市场竞争的加剧,帧交换机的价格将会进一步下跌,它将成为工作组网的重要解决方案。

    交换机之所以能够直接对目的节点发送数据包,而不是像集线器一样以广播方式对所有节点发送数据包,最关键的技术就是交换机可以识别连在网络上的节点的网卡MAC地址,并把它们放到一个叫做MAC地址表的地方。这个MAC地址表存放于交换机的缓存中,并记住这些地址,这样一来当需要向目的地址发送数据时,交换机就可在MAC地址表中查找这个MAC地址的节点位置,然后直接向这个位置的节点发送。所谓MAC地址数量是指交换机的MAC地址表中可以最多存储的MAC地址数量,存储的MAC地址数量越多,那么数据转发的速度和效率也就就越高。
    但是不同档次的交换机每个端口所能够支持的MAC数量不同。在交换机的每个端口,都需要足够的缓存来记忆这些MAC地址,所以Buffer(缓存)容量的大小就决定了相应交换机所能记忆的MAC地址数多少。通常交换机只要能够记忆1024个MAC地址基本上就可以了,而一般的交换机通常都能做到这一点,所以如果对网络规模不是很大的情况下,这参数无需太多考虑。当然越是高档的交换机能记住的MAC地址数就越多,这在选择时要视所连网络的规模而定了。

     简单地说,三层交换技术就是:二层交换技术+三层转发技术。它解决了局域网中网段划分之后,网段中子网必须依赖路由器进行管理的局面,解决了传统路由器低速、复杂所造成的网络瓶颈问题。 

什么是三层交换 

三层交换(也称多层交换技术,或IP交换技术)是相对于传统交换概念而提出的。众所周知,传统的交换技术是在OSI网络标准模型中的第二层——数据链路层进行操作的,而三层交换技术是在网络模型中的第三层实现了数据包的高速转发。简单地说,三层交换技术就是:二层交换技术+三层转发技术。  

三层交换技术的出现,解决了局域网中网段划分之后,网段中子网必须依赖路由器进行管理的局面,解决了传统路由器低速、复杂所造成的网络瓶颈问题。 

 三层交换原理 

一个具有三层交换功能的设备,是一个带有第三层路由功能的第二层交换机,但它是二者的有机结合,并不是简单地把路由器设备的硬件及软件叠加在局域网交换机上。 

 其原理是:假设两个使用IP协议的站点A、B通过第三层交换机进行通信,发送站点A在开始发送时,把自己的IP地址与B站的IP地址比较,判断B站是否与自己在同一子网内。若目的站B与发送站A在同一子网内,则进行二层的转发。若两个站点不在同一子网内,如发送站A要与目的站B通信,发送站A要向“缺省网关”发出ARP(地址解析)封包,而“缺省网关”的IP地址其实是三层交换机的三层交换模块。当发送站A对“缺省网关”的IP地址广播出一个ARP请求时,如果三层交换模块在以前的通信过程中已经知道B站的MAC地址,则向发送站A回复B的MAC地址。否则三层交换模块根据路由信息向B站广播一个ARP请求,B站得到此ARP请求后向三层交换模块回复其MAC地址,三层交换模块保存此地址并回复给发送站A,同时将B站的MAC地址发送到二层交换引擎的MAC地址表中。从这以后,当A向B发送的数据包便全部交给二层交换处理,信息得以高速交换。由于仅仅在路由过程中才需要三层处理,绝大部分数据都通过二层交换转发,因此三层交换机的速度很快,接近二层交换机的速度,同时比相同路由器的价格低很多。   

三层交换机种类 

三层交换机可以根据其处理数据的不同而分为纯硬件和纯软件两大类。    

(1)       纯硬件的三层技术相对来说技术复杂,成本高,但是速度快,性能好,带负载能力强。其原理是,采用ASIC芯片,采用硬件的方式进行路由表的查找和刷新。如图1所示。 

图1 纯硬件三层交换机原理

 当数据由端口接口芯片接收进来以后,首先在二层交换芯片中查找相应的目的MAC地址,如果查到,就进行二层转发,否则将数据送至三层引擎。在三层引擎中,ASIC芯片查找相应的路由表信息,与数据的目的IP地址相比对,然后发送ARP数据包到目的主机,得到该主机的MAC地址,将MAC地址发到二层芯片,由二层芯片转发该数据包。 

(2)基于软件的三层交换机技术较简单,但速度较慢,不适合作为主干。其原理是,采用CPU用软件的方式查找路由表。如图2所示。 

图2 软件三层交换机原理

 当数据由端口接口芯片接收进来以后,首先在二层交换芯片中查找相应的目的MAC地址,如果查到,就进行二层转发否则将数据送至CPU。CPU查找相应的路由表信息,与数据的目的IP地址相比对,然后发送ARP数据包到目的主机得到该主机的MAC地址,将MAC地址发到二层芯片,由二层芯片转发该数据包。因为低价CPU处理速度较慢,因此这种三层交换机处理速度较慢。 

 市场产品选型 

近年来宽带IP网络建设成为热点,下面以适合定位于接入层或中小规模汇聚层的第三层交换机产品为例,介绍一些三层交换机的具体技术。在市场上的主流接入第三层交换机,主要有Cisco的Catalyst 2948G-L3、Extreme的Summit24和AlliedTelesyn的Rapier24等,这几款三层交换机产品各具特色,涵盖了三层交换机大部分应用特性。当然在选择第三层交换机时,用户可根据自己的需要,判断并选择上述产品或其他厂家的产品,如北电网络的Passport/Acceler系列、原Cabletron的SSR系列(在Cabletron一分四后,大部分SSR三层交换机已并入Riverstone公司)、Avaya的Cajun M系列、3Com的Superstack3 4005系列等。此外,国产网络厂商神州数码网络、TCL网络、上海广电应确信、紫光网联、首信等都已推出了三层交换机产品。下面就其中三款产品进行介绍,使您能够较全面地了解三层交换机,并针对自己的情况选择合适的机型。 

    Cisco Catalyst 2948G-L3交换机结合业界标准IOS提供完整解决方案,在版本12.0(10)以上全面支持IOS访问控制列表 ACL,配合核心Catalyst 6000,可完成端到端全面宽带城域网的建设(Catalyst 6000使用MSFC模块完成其多层交换服务,并已停止使用RSM路由交换模块,IOS版本6.1以上全面支持ACL)。 

     Extreme公司三层交换产品解决方案,能够提供独特的以太网带宽分配能力,切割单位为500kbps或200kbps,服务供应商可以根据带宽使用量收费,可实现音频和视频的固定延迟传输。 

     AlliedTelesyn公司Rapier24三层交换机提供的PPPoE特性,丰富和完善了用户认证计费手段,可适合多种接入网络,应用灵活,易于实现业务选择,同时又保护目前用户的已有投资,另可配合NAT(网络地址转换)和DHCP的Server等功能,为许多服务供应商看好。 

    总之,三层交换机从概念的提出到今天的普及应用,虽然只历经了几年的时间,但其扩展的功能也不断结合实际应用得到丰富。随着ASIC硬件芯片技术的发展和实际应用的推广,三层交换的技术与产品也会得到进一步发展。

2007年01月09日

      背板带宽,是交换机接口处理器或接口卡和数据总线间所能吞吐的最大数据量。一台交换机的背板带宽越高,所能处理数据的能力就越强,但同时设计成本也会上去。
      但是,我们如何去考察一个交换机的背板带宽是否够用呢?显然,通过估算的方法是没有用的,我认为应该从两个方面来考虑:
1、)所有端口容量X端口数量之和的2倍应该小于背板带宽,可实现全双工无阻塞交换,证明交换机具有发挥最大数据交换性能的条件。
2、)满配置吞吐量(Mbps)=满配置GE端口数×1.488Mpps其中1个千兆端口在包长为64字节时的理论吞吐量为1.488Mpps。例如,一台最多可以提供64个千兆端口的交换机,其满配置吞吐量应达到 64×1.488Mpps = 95.2Mpps,才能够确保在所有端口均线速工作时,提供无阻塞的包交换。如果一台交换机最多能够提供176个千兆端口,而宣称的吞吐量为不到261.8Mpps(176 x 1.488Mpps = 261.8),那么用户有理由认为该交换机采用的是有阻塞的结构设计。

一般是两者都满足的交换机才是合格的交换机。

      背板相对大,吞吐量相对小的交换机,除了保留了升级扩展的能力外就是软件效率/专用芯片电路设计有问题;背板相对小。吞吐量相对大的交换机,整体性能比较高。不过背板带宽是可以相信厂家的宣传的,可吞吐量是无法相信厂家的宣传的,因为后者是个设计值,测试很困难的并且意义不是很大

 

      随着网络硬件性能的不断提高、成本的不断降低,目前新建立的校园网基本上都采用了性能先进的千兆网技术,其核心交换机采用三层交换机,它能很好地支持虚拟局域网(VLAN)技术,这对方便校园网的管理、保证校园网的高速可靠运行起到了非常重要的作用。
   
     什么是VLAN
   
      VLAN(VirtualLocalAreaNetwork)又称虚拟局域网,是指在交换局域网的基础上,采用网络管理软件构建的可跨越不同网段、不同网络的端到端的逻辑网络。一个VLAN组成一个逻辑子网,即一个逻辑广播域,它可以覆盖多个网络设备,允许处于不同地理位置的网络用户加入到一个逻辑子网中。
   
      组建VLAN的条件
   
      VLAN是建立在物理网络基础上的一种逻辑子网,因此建立VLAN需要相应的支持VLAN技术的网络设备。当网络中的不同VLAN间进行相互通信时,需要路由的支持,这时就需要增加路由设备——要实现路由功能,既可采用路由器,也可采用三层交换机来完成。
   
      划分VLAN的基本策略
   
     从技术角度讲,VLAN的划分可依据不同原则,一般有以下三种划分方法:
   
     1、基于端口的VLAN划分
   
     这种划分是把一个或多个交换机上的几个端口划分一个逻辑组,这是最简单、最有效的划分方法。该方法只需网络管理员对网络设备的交换端口进行重新分配即可,不用考虑该端口所连接的设备。
   
      2、基于MAC地址的VLAN划分
   
      MAC地址其实就是指网卡的标识符,每一块网卡的MAC地址都是惟一且固化在网卡上的。MAC地址由12位16进制数表示,前8位为厂商标识,后4位为网卡标识。网络管理员可按MAC地址把一些站点划分为一个逻辑子网。
   
      3、基于路由的VLAN划分
   
      路由协议工作在网络层,相应的工作设备有路由器和路由交换机(即三层交换机)。该方式允许一个VLAN跨越多个交换机,或一个端口位于多个VLAN中。
      就目前来说,对于VLAN的划分主要采取上述第1、3种方式,第2种方式为辅助性的方案。
   
      使用VLAN优点
   
      使用VLAN具有以下优点:
    
      1、控制广播风暴
   
      一个VLAN就是一个逻辑广播域,通过对VLAN的创建,隔离了广播,缩小了广播范围,可以控制广播风暴的产生。
   
      2、提高网络整体安全性
   
      通过路由访问列表和MAC地址分配等VLAN划分原则,可以控制用户访问权限和逻辑网段大小,将不同用户群划分在不同VLAN,从而提高交换式网络的整体性能和安全性。
   
      3、网络管理简单、直观
   
      对于交换式以太网,如果对某些用户重新进行网段分配,需要网络管理员对网络系统的物理结构重新进行调整,甚至需要追加网络设备,增大网络管理的工作量。而对于采用VLAN技术的网络来说,一个VLAN可以根据部门职能、对象组或者应用将不同地理位置的网络用户划分为一个逻辑网段。在不改动网络物理连接的情况下可以任意地将工作站在工作组或子网之间移动。利用虚拟网络技术,大大减轻了网络管理和维护工作的负担,降低了网络维护费用。在一个交换网络中,VLAN提供了网段和机构的弹性组合机制。
   
      三层交换技术
   
      传统的路由器在网络中有路由转发、防火墙、隔离广播等作用,而在一个划分了VLAN以后的网络中,逻辑上划分的不同网段之间通信仍然要通过路由器转发。由于在局域网上,不同VLAN之间的通信数据量是很大的,这样,如果路由器要对每一个数据包都路由一次,随着网络上数据量的不断增大,路由器将不堪重负,路由器将成为整个网络运行的瓶颈。
      在这种情况下,出现了第三层交换技术,它是将路由技术与交换技术合二为一的技术。三层交换机在对第一个数据流进行路由后,会产生一个MAC地址与IP地址的映射表,当同样的数据流再次通过时,将根据此表直接从二层通过而不是再次路由,从而消除了路由器进行路由选择而造成网络的延迟,提高了数据包转发的效率,消除了路由器可能产生的网络瓶颈问题。可见,三层交换机集路由与交换于一身,在交换机内部实现了路由,提高了网络的整体性能。
      在以三层交换机为核心的千兆网络中,为保证不同职能部门管理的方便性和安全性以及整个网络运行的稳定性,可采用VLAN技术进行虚拟网络划分。VLAN子网隔离了广播风暴,对一些重要部门实施了安全保护;且当某一部门物理位置发生变化时,只需对交换机进行设置,就可以实现网络的重组,非常方便、快捷,同时节约了成本。

      所谓典型局域网就是指由一台具备三层交换功能的核心交换机接几台分支交换机(不一定具备三层交换能力)。我们假设核心交换机名称为:com;分支交换机分别为:par1、par2、par3,分别通过port 1的光线模块与核心交换机相连;并且假设vlan名称分别为counter、market、managing……

   需要做的工作:
  1、设置vtp domain(核心、分支交换机上都设置)
  2、配置中继(核心、分支交换机上都设置)
  3、创建vlan(在server上设置)
  4、将交换机端口划入vlan
  5、配置三层交换

  1、设置vtp domain。 vtp domain 称为管理域。

  交换vtp更新信息的所有交换机必须配置为相同的管理域。如果所有的交换机都以中继线相连,那么只要在核心交换机上设置一个管理域,网络上所有的交换机都加入该域,这样管理域里所有的交换机就能够了解彼此的vlan列表。

  com#vlan database 进入vlan配置模式
  com(vlan)#vtp domain com 设置vtp管理域名称 com
  com(vlan)#vtp server 设置交换机为服务器模式

  par1#vlan database 进入vlan配置模式
  par1(vlan)#vtp domain com 设置vtp管理域名称com
  par1(vlan)#vtp client 设置交换机为客户端模式

  par2#vlan database 进入vlan配置模式
  par2(vlan)#vtp domain com 设置vtp管理域名称com
  par2(vlan)#vtp client 设置交换机为客户端模式

  par3#vlan database 进入vlan配置模式
  par3(vlan)#vtp domain com 设置vtp管理域名称com
  par3(vlan)#vtp client 设置交换机为客户端模式

  注意:这里设置核心交换机为server模式是指允许在该交换机上创建、修改、删除vlan及其他一些对整个vtp域的配置参数,同步本vtp域中其他交换机传递来的最新的vlan信息;client模式是指本交换机不能创建、删除、修改vlan配置,也不能在nvram中存储vlan配置,但可同步由本vtp域中其他交换机传递来的vlan信息。

  2、配置中继为了保证管理域能够覆盖所有的分支交换机,必须配置中继。

  cisco交换机能够支持任何介质作为中继线,为了实现中继可使用其特有的isl标签。isl(inter-switch link)是一个在交换机之间、交换机与路由器之间及交换机与服务器之间传递多个vlan信息及vlan数据流的协议,通过在交换机直接相连的端口配置isl封装,即可跨越交换机进行整个网络的vlan分配和进行配置。

  在核心交换机端配置如下:

  com(config)#interface gigabitethernet 2/1
  com(config-if)#switchport
  com(config-if)#switchport trunk encapsulation isl 配置中继协议
  com(config-if)#switchport mode trunk

  com(config)#interface gigabitethernet 2/2
  com(config-if)#switchport
  com(config-if)#switchport trunk encapsulation isl 配置中继协议
  com(config-if)#switchport mode trunk

  com(config)#interface gigabitethernet 2/3
  com(config-if)#switchport
  com(config-if)#switchport trunk encapsulation isl 配置中继协议
  com(config-if)#switchport mode trunk

  在分支交换机端配置如下:

  par1(config)#interface gigabitethernet 0/1
  par1(config-if)#switchport mode trunk

  par2(config)#interface gigabitethernet 0/1
  par2(config-if)#switchport mode trunk

  par3(config)#interface gigabitethernet 0/1
  par3(config-if)#switchport mode trunk

  此时,管理域算是设置完毕了。
 3、创建vlan一旦建立了管理域,就可以创建vlan了。

  com(vlan)#vlan 10 name counter 创建了一个编号为10 名字为counter的 vlan
  com(vlan)#vlan 11 name market 创建了一个编号为11 名字为market的 vlan
  com(vlan)#vlan 12 nam

   e managing 创建了一个编号为12 名字为managing的 vlan

  ……

  注意,这里的vlan是在核心交换机上建立的,其实,只要是在管理域中的任何一台vtp 属性为server的交换机上建立vlan,它就会通过vtp通告整个管理域中的所有的交换机。但如果要将具体的交换机端口划入某个vlan,就必须在该端口所属的交换机上进行设置。

  4、将交换机端口划入vlan

  例如,要将par1、par2、par3……分支交换机的端口1划入counter vlan,端口2划入market vlan,端口3划入managing vlan……

  par1(config)#interface fastethernet 0/1 配置端口1
  par1(config-if)#switchport access vlan 10 归属counter vlan

  par1(config)#interface fastethernet 0/2 配置端口2
  par1(config-if)#switchport access vlan 11 归属market vlan

  par1(config)#interface fastethernet 0/3 配置端口3
  par1(config-if)#switchport access vlan 12 归属managing vlan

  par2(config)#interface fastethernet 0/1 配置端口1
  par2(config-if)#switchport access vlan 10 归属counter vlan

  par2(config)#interface fastethernet 0/2 配置端口2
  par2(config-if)#switchport access vlan 11 归属market vlan

  par2(config)#interface fastethernet 0/3 配置端口3
  par2(config-if)#switchport access vlan 12 归属managing vlan

  par3(config)#interface fastethernet 0/1 配置端口1
  par3(config-if)#switchport access vlan 10 归属counter vlan

  par3(config)#interface fastethernet 0/2 配置端口2
  par3(config-if)#switchport access vlan 11 归属market vlan

  par3(config)#interface fastethernet 0/3 配置端口3
  par3(config-if)#switchport access vlan 12 归属managing vlan

  ……
  
  5、配置三层交换

  到这里,vlan已经基本划分完毕。但是,vlan间如何实现三层(网络层)交换呢?这时就要给各vlan分配网络(ip)地址了。给vlan分配ip地址分两种情况,其一,给vlan所有的节点分配静态ip地址;其二,给vlan所有的节点分配动态ip地址。下面就这两种情况分别介绍。

  假设给vlan counter分配的接口ip地址为172.16.58.1/24,网络地址为:172.16.58.0,
  vlan market 分配的接口ip地址为172.16.59.1/24,网络地址为:172.16.59.0,
  vlan managing分配接口ip地址为172.16.60.1/24, 网络地址为172.16.60.0
  ……
  如果动态分配ip地址,则设网络上的dhcp服务器ip地址为172.16.1.11。

  (1)给vlan所有的节点分配静态ip地址。

  首先在核心交换机上分别设置各vlan的接口ip地址。核心交换机将vlan做为一种接口对待,就象路由器上的一样,如下所示:

  com(config)#interface vlan 10
  com(config-if)#ip address 172.16.58.1 255.255.255.0 vlan10接口ip

  com(config)#interface vlan 11
  com(config-if)#ip address 172.16.59.1 255.255.255.0 vlan11接口ip

  com(config)#interface vlan 12
  com(config-if)#ip address 172.16.60.1 255.255.255.0 vlan12接口ip

  ……

  再在各接入vlan的计算机上设置与所属vlan的网络地址一致的ip地址,并且把默认网关设置为该vlan的接口地址。这样,所有的vlan也可以互访了。

  (2)给vlan所有的节点分配动态ip地址。

  首先在核心交换机上分别

  设置各vlan的接口ip地址和同样的dhcp服务器的ip地址,如下所示:

  com(config)#interface vlan 10
  com(config-if)#ip address 172.16.58.1 255.255.255.0 vlan10接口ip
  com(config-if)#ip helper-address 172.16.1.11 dhcp server ip

  com(config)#interface vlan 11
  com(config-if)#ip address 172.16.59.1 255.255.255.0 vlan11接口ip
  com(config-if)#ip helper-address 172.16.1.11 dhcp server ip
  
  com(config)#interface vlan 12
  com(config-if)#ip address 172.16.60.1 255.255.255.0 vlan12接口ip
  com(config-if)#ip helper-address 172.16.1.11 dhcp server ip

  ……

  再在dhcp服务器上设置网络地址分别为172.16.58.0,172.16.59.0,172.16.60.0的作用域,并将这些作用域的“路由器”选项设置为对应vlan的接口ip地址。这样,可以保证所有的vlan也可以互访了。

  最后在各接入vlan的计算机进行网络设置,将ip地址选项设置为自动获得ip地址即可。

局域网实现VLAN实例计算机网络技术的发展犹如戏剧舞台,你方唱罢我登台。从传统的以太网(10Mb/s)发展到快速以太网(100Mb/s)和千兆以太网(1000Mb/s)也不过几年的时间,其迅猛的势头实在令人吃惊。而现在中大型规模网络建设中,以千兆三层交换机为核心的所谓“千兆主干跑、百兆到桌面”的主流网络模型已不胜枚举。 现在,网络业界对“三层交换”和VLAN这两词已经不感到陌生了。

一、什么是三层交换和VLAN要回答这个问题我们还是先看看以太网的工作原理。以太网的工作原理是利用二进制位形成的一个个字节组合成一帧帧的数据(其实是一些电脉冲)在导线中进行传播。

首先,以太网网段上需要进行数据传送的节点对导线进行监听,这个过程称为CSMA/CD(Carrier Sense Multiple Access with Collision Detection带有冲突监测的载波侦听多址访问)的载波侦听。如果,这时有另外的节点正在传送数据,监听节点将不得不等待,直到传送节点的传送任务结束。如果某时恰好有两个工作站同时准备传送数据,以太网网段将发出“冲突”信号。这时,节点上所有的工作站都将检测到冲突信号,因为这时导线上的电压超出了标准电压。这时以太网网段上的任何节点都要等冲突结束后才能够传送数据。也就是说在CSMA/CD方式下,在一个时间段,只有一个节点能够在导线上传送数据。而转发以太网数据帧的联网设备是集线器,它是一层设备,传输效率比较低。冲突的产生降低了以太网的带宽,而且这种情况又是不可避免的。所以,当导线上的节点越来越多后,冲突的数量将会增加。显而易见的解决方法是限制以太网导线上的节点,需要对网络进行物理分段。将网络进行物理分段的网络设备用到了网桥与交换机。网桥和交换机的基本作用是只发送去往其他物理网段的信息。所以,如果所有的信息都只发往本地的物理网段,那么网桥和交换机上就没有信息通过。这样可以有效减少网络上的冲突。网桥和交换机是基于目标MAC(介质访问控制)地址做出转发决定的,它们是二层设备。

我们已经知道了以太网的缺点及物理网段中冲突的影响,现在,我们来看看另外一种导致网络降低运行速度的原因:广播。广播存在于所有的网络上,如果不对它们进行适当的控制,它们便会充斥于整个网络,产生大量的网络通信。广播不仅消耗了带宽,而且也降低了用户工作站的处理效率。由于各种各样的原因,网络操作系统(NOS)使用了广播,TCP/IP使用广播从IP地址中解析MAC地址,还使用广播通过RIP和IGRP协议进行宣告,所以,广播也是不可避免的。网桥和交换机将对所有的广播信息进行转发,而路由器不会。所以,为了对广播进行控制,就必须使用路由器。路由器是基于第3层报头、目标IP寻址、目标IPX寻址或目标Appletalk寻址做出转发决定。路由器是3层设备。

在这里,我们就容易理解三层交换技术了,通俗地讲,就是将路由与交换合二为一的技术。路由器在对第一个数据流进行路由后,将会产生一个MAC地址与IP地址的映射表,当同样的数据流再次通过时,将根据此映射表直接从二层进行交换而不是再次路由,提供线速性能,从而消除了路由器进行路由选择而造成网络的延迟,提高了数据包转发的效率。采用此技术的交换机我们常称为三层交换机。

那么,什么是VLAN呢?VLAN(Virtual Local Area Network)就是虚拟局域网的意思。VLAN可以不考虑用户的物理位置,而根据功能、应用等因素将用户从逻辑上划分为一个个功能相对独立的工作组,每个用户主机都连接在一个支持VLAN的交换机端口上并属于一个VLAN。同一个VLAN中的成员都共享广播,形成一个广播域,而不同VLAN之间广播信息是相互隔离的。这样,将整个网络分割成多个不同的广播域(VLAN)。一般来说,如果一个VLAN里面的工作站发送一个广播,那么这个VLAN里面所有的工作站都接收到这个广播,但是交换机不会将广播发送至其他VLAN上的任何一个端口。如果要将广播发送到其它的VLAN端口,就要用到三层交换机。

二、如何配置三层交换机创建VLAN

以下的介绍都是基于Cisco交换机的VLAN。Cisco的VLAN实现通常是以端口为中心的,与节点相连的端口将确定它所驻留的VLAN。将端口分配给VLAN的方式有两种,分别是静态的和动态的.
形成静态VLAN的过程是将端口强制性地分配给VLAN的过程。即我们先在VTP (VLAN Trunking Protocol)Server上建立VLAN,然后将每个端口分配给相应的VLAN的过程。这是我们创建VLAN最常用的方法。
动态VLAN形成很简单,由具体的机器决定自己属于哪个VLAN。即我们先建立一个VMPS(VLAN Membership Policy Server)VLAN管理策略服务器,里面包含一个文本文件,文件中存有与VLAN映射的MAC地址表。交换机根据这个映射表决定将端口分配给何种VLAN。这种方法有很大的优势,但创建数据库是一项非常艰苦而且非常繁琐的工作。

下面以实例说明如何在一个典型的快速以太局域网中实现VLAN。

所谓典型局域网就是指由一台具备三层交换功能的核心交换机接几台分支交换机(不一定具备三层交换能力)。我们假设核心交换机名称为:COM;分支交换机分别为:PAR1、PAR2、PAR3,分别通过Port 1的光线模块与核心交换机相连;并且假设VLAN名称分别为COUNTER、MARKET、MANAGING……

需要做的工作:
1、设置VTP DOMAIN(核心、分支交换机上都设置)
2、配置中继(核心、分支交换机上都设置)
3、创建VLAN(在server上设置)
4、将交换机端口划入VLAN
5、配置三层交换

1、设置VTP DOMAIN。 VTP DOMAIN 称为管理域。

交换VTP更新信息的所有交换机必须配置为相同的管理域。如果所有的交换机都以中继线相连,那么只要在核心交换机上设置一个管理域,网络上所有的交换机都加入该域,这样管理域里所有的交换机就能够了解彼此的VLAN列表。

COM#vlan database 进入VLAN配置模式
COM(vlan)#vtp domain COM 设置VTP管理域名称 COM
COM(vlan)#vtp server 设置交换机为服务器模式

PAR1#vlan database 进入VLAN配置模式
PAR1(vlan)#vtp domain COM 设置VTP管理域名称COM
PAR1(vlan)#vtp Client 设置交换机为客户端模式

PAR2#vlan database 进入VLAN配置模式
PAR2(vlan)#vtp domain COM 设置VTP管理域名称COM
PAR2(vlan)#vtp Client 设置交换机为客户端模式

PAR3#vlan database 进入VLAN配置模式
PAR3(vlan)#vtp domain COM 设置VTP管理域名称COM
PAR3(vlan)#vtp Client 设置交换机为客户端模式

注意:这里设置核心交换机为Server模式是指允许在该交换机上创建、修改、删除VLAN及其他一些对整个VTP域的配置参数,同步本VTP域中其他交换机传递来的最新的VLAN信息;Client模式是指本交换机不能创建、删除、修改VLAN配置,也不能在NVRAM中存储VLAN配置,但可同步由本VTP域中其他交换机传递来的VLAN信息。

2、配置中继为了保证管理域能够覆盖所有的分支交换机,必须配置中继。

Cisco交换机能够支持任何介质作为中继线,为了实现中继可使用其特有的ISL标签。ISL(Inter-Switch Link)是一个在交换机之间、交换机与路由器之间及交换机与服务器之间传递多个VLAN信息及VLAN数据流的协议,通过在交换机直接相连的端口配置ISL封装,即可跨越交换机进行整个网络的VLAN分配和进行配置。

在核心交换机端配置如下:

COM(config)#interface gigabitEthernet 2/1
COM(config-if)#switchport
COM(config-if)#switchport trunk encapsulation isl 配置中继协议
COM(config-if)#switchport mode trunk

COM(config)#interface gigabitEthernet 2/2
COM(config-if)#switchport
COM(config-if)#switchport trunk encapsulation isl 配置中继协议
COM(config-if)#switchport mode trunk

COM(config)#interface gigabitEthernet 2/3
COM(config-if)#switchport
COM(config-if)#switchport trunk encapsulation isl 配置中继协议
COM(config-if)#switchport mode trunk

在分支交换机端配置如下:

PAR1(config)#interface gigabitEthernet 0/1
PAR1(config-if)#switchport mode trunk

PAR2(config)#interface gigabitEthernet 0/1
PAR2(config-if)#switchport mode trunk

PAR3(config)#interface gigabitEthernet 0/1
PAR3(config-if)#switchport mode trunk

……

此时,管理域算是设置完毕了。

3、创建VLAN一旦建立了管理域,就可以创建VLAN了。

COM(vlan)#Vlan 10 name COUNTER 创建了一个编号为10 名字为COUNTER的 VLAN
COM(vlan)#Vlan 11 name MARKET 创建了一个编号为11 名字为MARKET的 VLAN
COM(vlan)#Vlan 12 name MANAGING 创建了一个编号为12 名字为MANAGING的 VLAN

……

注意,这里的VLAN是在核心交换机上建立的,其实,只要是在管理域中的任何一台VTP 属性为Server的交换机上建立VLAN,它就会通过VTP通告整个管理域中的所有的交换机。但如果要将具体的交换机端口划入某个VLAN,就必须在该端口所属的交换机上进行设置。

4、将交换机端口划入VLAN

例如,要将PAR1、PAR2、PAR3……分支交换机的端口1划入COUNTER VLAN,端口2划入MARKET VLAN,端口3划入MANAGING VLAN……

PAR1(config)#interface fastEthernet 0/1 配置端口1
PAR1(config-if)#switchport access vlan 10 归属COUNTER VLAN

PAR1(config)#interface fastEthernet 0/2 配置端口2
PAR1(config-if)#switchport access vlan 11 归属MARKET VLAN

PAR1(config)#interface fastEthernet 0/3 配置端口3
PAR1(config-if)#switchport access vlan 12 归属MANAGING VLAN

PAR2(config)#interface fastEthernet 0/1 配置端口1
PAR2(config-if)#switchport access vlan 10 归属COUNTER VLAN

PAR2(config)#interface fastEthernet 0/2 配置端口2
PAR2(config-if)#switchport access vlan 11 归属MARKET VLAN

PAR2(config)#interface fastEthernet 0/3 配置端口3
PAR2(config-if)#switchport access vlan 12 归属MANAGING VLAN

PAR3(config)#interface fastEthernet 0/1 配置端口1
PAR3(config-if)#switchport access vlan 10 归属COUNTER VLAN

PAR3(config)#interface fastEthernet 0/2 配置端口2
PAR3(config-if)#switchport access vlan 11 归属MARKET VLAN

PAR3(config)#interface fastEthernet 0/3 配置端口3
PAR3(config-if)#switchport access vlan 12 归属MANAGING VLAN

……
5、配置三层交换

到这里,VLAN已经基本划分完毕。但是,VLAN间如何实现三层(网络层)交换呢?这时就要给各VLAN分配网络(IP)地址了。给VLAN分配IP地址分两种情况,其一,给VLAN所有的节点分配静态IP地址;其二,给VLAN所有的节点分配动态IP地址。下面就这两种情况分别介绍。

假设给VLAN COUNTER分配的接口Ip地址为172.16.58.1/24,网络地址为:172.16.58.0,
VLAN MARKET 分配的接口Ip地址为172.16.59.1/24,网络地址为:172.16.59.0,
VLAN MANAGING分配接口Ip地址为172.16.60.1/24, 网络地址为172.16.60.0
……
如果动态分配IP地址,则设网络上的DHCP服务器IP地址为172.16.1.11。

(1)给VLAN所有的节点分配静态IP地址。

首先在核心交换机上分别设置各VLAN的接口IP地址。核心交换机将vlan做为一种接口对待,就象路由器上的一样,如下所示:

COM(config)#interface vlan 10
COM(config-if)#ip address 172.16.58.1 255.255.255.0 VLAN10接口IP

COM(config)#interface vlan 11
COM(config-if)#ip address 172.16.59.1 255.255.255.0 VLAN11接口IP

COM(config)#interface vlan 12
COM(config-if)#ip address 172.16.60.1 255.255.255.0 VLAN12接口IP

……

再在各接入VLAN的计算机上设置与所属VLAN的网络地址一致的IP地址,并且把默认网关设置为该VLAN的接口地址。这样,所有的VLAN也可以互访了。

(2)给VLAN所有的节点分配动态IP地址。

首先在核心交换机上分别设置各VLAN的接口IP地址和同样的DHCP服务器的IP地址,如下所示:

COM(config)#interface vlan 10
COM(config-if)#ip address 172.16.58.1 255.255.255.0 VLAN10接口IP
COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP

COM(config)#interface vlan 11
COM(config-if)#ip address 172.16.59.1 255.255.255.0 VLAN11接口IP
COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP

COM(config)#interface vlan 12
COM(config-if)#ip address 172.16.60.1 255.255.255.0 VLAN12接口IP
COM(config-if)#ip helper-address 172.16.1.11 DHCP Server IP

……

再在DHCP服务器上设置网络地址分别为172.16.58.0,172.16.59.0,172.16.60.0的作用域,并将这些作用域的“路由器”选项设置为对应VLAN的接口IP地址。这样,可以保证所有的VLAN也可以互访了。

最后在各接入VLAN的计算机进行网络设置,将IP地址选项设置为自动获得IP地址即可。

三、总结

本文是笔者在实际工作中的一些总结。笔者力图用通俗易懂的文字来阐述创建VLAN的全过程。并且给出了详细的设置步骤,只要你对Cisco交换机的IOS有所了解,看懂本文并不难。按照本文所示的步骤一步一步地做,你完全可以给一个典型的快速以太网络建立多个VLAN。

    业务的发展常常会导致许多单位面临这样一个问题:工作站数量越来越多,管理单一的大型网络也变得越来越艰难。如果将一个单一的大型网络划分为多个子网,通过对每个子网进行单独管理,可以明显地提高整个网络的性能。

  要划分子网就需要计算子网掩码和分配相应的主机块,尽管采用二进制计算可以得出相应的结论,但如果采用十进制计算方法,计算起来更为简便。经过长期实践与经验积累,笔者总结出子网掩码及主机块的十进制算法。

  一、明确概念

  在介绍十进制算法前我们先要明确一些概念。

  类范围:IP地址常采用点分十进制表示方法X.Y.Y.Y,在这里,X在1~126范围内称为A类地址;X在128~191范围内称为B类地址;X在192~223范围内称为C类地址。比如10.202.52.130,因为X为10,在1~126范围内,所以称为A类地址。

  类默认子网掩码:A类为 255.0.0.0; B类为 255.255.0.0; C类为 255.255.255.0。当我们要划分子网用到子网掩码M时,类子网掩码的格式如下:A类为 255.M.0.0,B类为 255.255.M.0,C类为 255.255.255.M。M是相应的子网掩码,比如255.255.255.240。

  十进制计算基数是256(下面,我们所有的十进制计算都要用256来进行)。

  二、变量说明

  1.Subnet_block指可分配子网块大小,表示在某一子网掩码下子网的块数。

  2.Subnet_num是可分配子网数,指可分配子网块中要剔除首、尾两块,是某一子网掩码下可分配的实际子网数量。Subnet_num =Subnet_block-2。

  3.IP_block指每个子网可分配的IP地址块大小。

  4.IP_num指每个子网实际可分配的IP地址数。因为每个子网的首、尾IP地址必须保留(一个为网络地址,一个为广播地址),所以它等于IP_block-2,IP_num也用于计算主机块。

  5.M指子网掩码。

  表示上述变量关系的公式如下:
   M=256-IP_block IP_block=256/Subnet_block或Subnet_block=256/IP_block IP_num=IP_block-2 Subnet_num=Subnet_block-2。

  6.2的幂数。大家要熟练掌握28(256)以内的2的幂代表的十进制数(如128=27、64=26等),这样可以使我们立即推算出Subnet_block和IP_block的数目。

  三、举例说明

  现在,通过举一些实际例子,大家可以对子网掩码和主机块的十进制算法有深刻的了解。

  1.已知所需子网数12,求实际子网数。

  这里实际子网数指Subnet_num,由于12最接近2的幂为16(24),即Subnet_block=16,那么Subnet_num=16-2=14,故实际子网数为14。

  2.已知一个B类子网的每个子网主机数要达到60×255个(约相当于X.Y.0.1~X.Y.59.254的数量),求子网掩码。

  首先,60接近2的幂为64(26),即IP_block=64; 其次,子网掩码M=256-IP_block=256-64=192,最后由子网掩码格式B类是255.255.M.0得出子网掩码为255.255.192.0。

  3.如果所需子网数为7,求子网掩码。

  7最接近2的幂为8,但8个Subnet_block因为要保留首、尾2个子网块,即 8-2=6< 7,并不能达到所需子网数,所以应取2的幂为16,即Subnet_block=16。因为IP_block=256/Subnet_block=256/16=16,所以子网掩码M=256-IP_block=256-16=240。

  4.已知网络地址为211.134.12.0,要有4个子网,求子网掩码及主机块。

  由于211.Y.Y.Y是一个C类网,子网掩码格式为255.255.255.M,又知有4个子网,4接近2的幂是8(23),所以Subnet_block=8,Subnet_num=8-2=6,IP_block=256/Subnet_block=256/8=32,子网掩码M=256-IP_block=256-32=224,故子网掩码表示为255.255.255.224。又因为子网块的首、尾两块不能使用,所以可分配6个子网,每个子网有32个可分配主机块,即32~63、64~95、96~127、128~159、160~191、192~223,其中首块(0~31)和尾块(224~255)不能使用。

  由于每个子网块中的可分配主机块又有首、尾两个不能使用(一个是子网网络地址,一个是子网广播地址),所以主机块分别为33~62、65~94、97~126、129~158、161~190及193~222,因此子网掩码为255.255.255.224,主机块共有6段,分别为211.134.12.33~211.134.12.62、211.134.12.65~211.134.12.94、211.134.12.97~211.134.12.126、211.134.12.129~211.134.12.158、211.134.12.161~211.134.12.190及211.134.12.193~211.134.12.222。用户可以任选其中的4段作为4个子网。

  总之,只要理解了公式中的逻辑关系,就能很快计算出子网掩码,并得出可分配的主机块。